summaryrefslogtreecommitdiff
path: root/net-dns/dnrd
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-dns/dnrd
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-dns/dnrd')
-rw-r--r--net-dns/dnrd/Manifest1
-rw-r--r--net-dns/dnrd/dnrd-2.20.3-r1.ebuild44
-rw-r--r--net-dns/dnrd/files/dnrd24
-rw-r--r--net-dns/dnrd/files/dnrd-2.20.3-docdir.patch21
-rw-r--r--net-dns/dnrd/files/dnrd.conf11
-rw-r--r--net-dns/dnrd/metadata.xml18
6 files changed, 119 insertions, 0 deletions
diff --git a/net-dns/dnrd/Manifest b/net-dns/dnrd/Manifest
new file mode 100644
index 00000000000..3256f60c5c1
--- /dev/null
+++ b/net-dns/dnrd/Manifest
@@ -0,0 +1 @@
+DIST dnrd-2.20.3.tar.gz 161887 SHA256 aa46e7f8736b88c1d752cf606b3990041221ce91d014e955c6b02eb2167db015
diff --git a/net-dns/dnrd/dnrd-2.20.3-r1.ebuild b/net-dns/dnrd/dnrd-2.20.3-r1.ebuild
new file mode 100644
index 00000000000..4e628b7f635
--- /dev/null
+++ b/net-dns/dnrd/dnrd-2.20.3-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit autotools eutils user
+
+DESCRIPTION="A caching DNS proxy server"
+HOMEPAGE="http://dnrd.sourceforge.net/"
+SRC_URI="mirror://sourceforge/dnrd/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug"
+DEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-docdir.patch
+ eautoreconf
+}
+
+src_compile() {
+ econf \
+ $(use_enable debug) \
+ --disable-dependency-tracking \
+ --docdir=/usr/share/doc/${PF} \
+ || die
+
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ keepdir /etc/dnrd
+ doinitd ${FILESDIR}/dnrd
+ newconfd ${FILESDIR}/dnrd.conf dnrd
+}
+
+pkg_postinst() {
+ enewgroup dnrd
+ enewuser dnrd -1 -1 /dev/null dnrd
+}
diff --git a/net-dns/dnrd/files/dnrd b/net-dns/dnrd/files/dnrd
new file mode 100644
index 00000000000..403073586e3
--- /dev/null
+++ b/net-dns/dnrd/files/dnrd
@@ -0,0 +1,24 @@
+#!/sbin/runscript
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Id$
+
+PIDFILE="/var/run/dnrd.pid"
+
+depend() {
+ provide dns
+ need net
+}
+
+start() {
+ ebegin "Starting dnrd"
+ /usr/sbin/dnrd $DNRD_OPTS &> /dev/null &
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping dnrd"
+ /usr/sbin/dnrd -k
+ eend $?
+}
+
diff --git a/net-dns/dnrd/files/dnrd-2.20.3-docdir.patch b/net-dns/dnrd/files/dnrd-2.20.3-docdir.patch
new file mode 100644
index 00000000000..a3d1c8002d5
--- /dev/null
+++ b/net-dns/dnrd/files/dnrd-2.20.3-docdir.patch
@@ -0,0 +1,21 @@
+Index: doc/Makefile.am
+===================================================================
+--- doc/Makefile.am (revision 247)
++++ doc/Makefile.am (revision 248)
+@@ -1,5 +1,4 @@
+ PACKAGE = @PACKAGE_TARNAME@
+-docdir = $(datadir)/doc/$(PACKAGE)
+ doc_DATA = README-cache README-master README-cygwin master.sample
+ man_MANS = dnrd.8
+ EXTRA_DIST = $(man_MANS) $(doc_DATA)
+Index: Makefile.am
+===================================================================
+--- Makefile.am (revision 247)
++++ Makefile.am (revision 248)
+@@ -1,6 +1,5 @@
+ PACKAGE = @PACKAGE_TARNAME@
+ SUBDIRS = src doc
+-docdir = $(datadir)/doc/$(PACKAGE)
+ doc_DATA = AUTHORS COPYING ChangeLog README NEWS
+
+ EXTRA_DIST = README cygwin_post_install.sh
diff --git a/net-dns/dnrd/files/dnrd.conf b/net-dns/dnrd/files/dnrd.conf
new file mode 100644
index 00000000000..96eea43a87d
--- /dev/null
+++ b/net-dns/dnrd/files/dnrd.conf
@@ -0,0 +1,11 @@
+# options to dnrd
+
+# example: 2 default dns servers and dns servers for mydomain.com. The
+# latter are load balanced (-b)
+
+# DNRD_OPTS="
+# -s 213.142.64.170
+# -s 213.142.64.171
+# -b
+# -s 192.168.65.250:mydomain.com
+# -s 192.168.65.254:mydomain.com"
diff --git a/net-dns/dnrd/metadata.xml b/net-dns/dnrd/metadata.xml
new file mode 100644
index 00000000000..0e1cbf4d448
--- /dev/null
+++ b/net-dns/dnrd/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>proxy-maintainers</herd>
+ <maintainer>
+ <email>natanael.copa@gmail.com</email>
+ <name>Natanael Copa</name>
+ </maintainer>
+ <maintainer>
+ <email>armin76@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+Domain Name Relay Daemon is a caching, forwarding DNS proxy server. Most useful on vpn or dialup firewalls but it is also a nice DNS cache for minor networks and workstations.
+</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">dnrd</remote-id>
+ </upstream>
+</pkgmetadata>