summaryrefslogtreecommitdiff
path: root/net-dns/dnsmasq
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2015-11-10 20:26:49 -0500
committerMike Frysinger <vapier@gentoo.org>2015-11-10 20:53:23 -0500
commit2347c6fe886c6b89d93ffac0faf375a613c372b1 (patch)
tree9ac1ed0abe7e86cbfe62a110a23675af21655134 /net-dns/dnsmasq
parent8b26c09d67b36a5b5dbb295924ae14ecc5d079bd (diff)
downloadgentoo-2347c6fe886c6b89d93ffac0faf375a613c372b1.tar.gz
gentoo-2347c6fe886c6b89d93ffac0faf375a613c372b1.tar.xz
avoid using ${var^} and ${var,} as they do not work in bash-3.2
Once these upgrade to EAPI=6, they can use these case modification features, so leave a reminder note in there.
Diffstat (limited to 'net-dns/dnsmasq')
-rw-r--r--net-dns/dnsmasq/dnsmasq-2.66.ebuild6
-rw-r--r--net-dns/dnsmasq/dnsmasq-2.72-r2.ebuild4
-rw-r--r--net-dns/dnsmasq/dnsmasq-2.75.ebuild4
3 files changed, 10 insertions, 4 deletions
diff --git a/net-dns/dnsmasq/dnsmasq-2.66.ebuild b/net-dns/dnsmasq/dnsmasq-2.66.ebuild
index 74eef761c49..a5dfba9bdd5 100644
--- a/net-dns/dnsmasq/dnsmasq-2.66.ebuild
+++ b/net-dns/dnsmasq/dnsmasq-2.66.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -47,7 +47,9 @@ use_have() {
fi
local UWORD=${2:-$1}
- UWORD=${UWORD^^*}
+ # Switch to ^^ when we switch to EAPI=6.
+ #UWORD=${UWORD^^}
+ UWORD=$(tr '[:lower:]' '[:upper:]' <<<"${UWORD}")
if ! use ${1}; then
echo " -DNO_${UWORD}"
diff --git a/net-dns/dnsmasq/dnsmasq-2.72-r2.ebuild b/net-dns/dnsmasq/dnsmasq-2.72-r2.ebuild
index 2f14c001a89..b119b064ce7 100644
--- a/net-dns/dnsmasq/dnsmasq-2.72-r2.ebuild
+++ b/net-dns/dnsmasq/dnsmasq-2.72-r2.ebuild
@@ -69,7 +69,9 @@ use_have() {
shift
while [[ ${uword} ]]; do
- uword=${uword^^*}
+ # Switch to ^^ when we switch to EAPI=6.
+ #uword=${uword^^}
+ uword=$(tr '[:lower:]' '[:upper:]' <<<"${uword}")
if ! use "${useflag}"; then
echo -n " -DNO_${uword}"
diff --git a/net-dns/dnsmasq/dnsmasq-2.75.ebuild b/net-dns/dnsmasq/dnsmasq-2.75.ebuild
index 05bc1cd7314..ecc0a1b9d74 100644
--- a/net-dns/dnsmasq/dnsmasq-2.75.ebuild
+++ b/net-dns/dnsmasq/dnsmasq-2.75.ebuild
@@ -64,7 +64,9 @@ use_have() {
shift
while [[ ${uword} ]]; do
- uword=${uword^^*}
+ # Switch to ^^ when we switch to EAPI=6.
+ #uword=${uword^^}
+ uword=$(tr '[:lower:]' '[:upper:]' <<<"${uword}")
if ! use "${useflag}"; then
echo -n " -DNO_${uword}"