summaryrefslogtreecommitdiff
path: root/net-firewall/lutelwall
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-firewall/lutelwall
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-firewall/lutelwall')
-rw-r--r--net-firewall/lutelwall/Manifest1
-rw-r--r--net-firewall/lutelwall/files/lutelwall26
-rw-r--r--net-firewall/lutelwall/lutelwall-0.99.ebuild33
-rw-r--r--net-firewall/lutelwall/metadata.xml17
4 files changed, 77 insertions, 0 deletions
diff --git a/net-firewall/lutelwall/Manifest b/net-firewall/lutelwall/Manifest
new file mode 100644
index 00000000000..2509d88a91c
--- /dev/null
+++ b/net-firewall/lutelwall/Manifest
@@ -0,0 +1 @@
+DIST lutelwall-0.99.tar.gz 29209 SHA256 92ab7ab320cbefd694cd5ba3799e6143244402eac65ffcd4b52528bc31d1a1f8 SHA512 8812048c9e4ec3beff2214ed3ceb2d980d769ada686a934af22baec76a3670e51ddb171097adbfb78c63ce9bc25554b1da93ec8c86f59457277fd4651cf1068c WHIRLPOOL 842979556cecab887f9f050d5d92e0539c608023a694608d82e77a7d338ca6a6d8fc842dee49aa2def49dfeebc82faf23b12108e0363ec881395ced8279bdb76
diff --git a/net-firewall/lutelwall/files/lutelwall b/net-firewall/lutelwall/files/lutelwall
new file mode 100644
index 00000000000..5c9c64ec54b
--- /dev/null
+++ b/net-firewall/lutelwall/files/lutelwall
@@ -0,0 +1,26 @@
+#!/sbin/runscript
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Id$
+
+depend() {
+ need net
+ use logger
+}
+
+start() {
+ ebegin "Starting LutelWall"
+ /usr/sbin/lutelwall start
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping LutelWall"
+ /usr/sbin/lutelwall stop
+ eend $?
+}
+
+restart() {
+ stop
+ start
+}
diff --git a/net-firewall/lutelwall/lutelwall-0.99.ebuild b/net-firewall/lutelwall/lutelwall-0.99.ebuild
new file mode 100644
index 00000000000..f6ba5792f84
--- /dev/null
+++ b/net-firewall/lutelwall/lutelwall-0.99.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="IPTables firewall setup script"
+LICENSE="GPL-2"
+HOMEPAGE="http://www.lutel.pl/lutelwall/"
+SRC_URI="http://www.lutel.pl/wp-content/uploads/${PV}/${P}.tar.gz"
+SLOT="0"
+KEYWORDS="alpha ~amd64 ~ppc ~sparc x86"
+
+RDEPEND="
+ >=net-firewall/iptables-1.2.6
+ >=sys-apps/gawk-3.1
+ sys-apps/iproute2
+"
+
+src_install() {
+ insinto /etc
+ doins lutelwall.conf
+
+ dosbin lutelwall
+ doinitd "${FILESDIR}"/lutelwall
+
+ dodoc FEATURES ChangeLog
+}
+
+pkg_postinst() {
+ elog "Basic configuration file is /etc/lutelwall.conf"
+ elog "Adjust it to your needs before using"
+}
diff --git a/net-firewall/lutelwall/metadata.xml b/net-firewall/lutelwall/metadata.xml
new file mode 100644
index 00000000000..8a0d713fe48
--- /dev/null
+++ b/net-firewall/lutelwall/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>netmon</herd>
+<herd>proxy-maintainers</herd>
+<maintainer>
+ <email>tomek@lutel.pl</email>
+ <name>Tomek Lutelmowski</name>
+ <description>LuteWall developer, third party maintainer</description>
+</maintainer>
+<longdescription>
+LutelWall is high-level firewall configuration tool. It uses human-readable and easy
+to understand configuration to set up Netfilter in most secure way. Its flexibility
+allows firewall admins build from very simple, single-homed firewalls, to most complex
+ones - with multiple subnets, DMZ's and traffic redirections.
+</longdescription>
+</pkgmetadata>