summaryrefslogtreecommitdiff
path: root/net-firewall/nfacct
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-firewall/nfacct
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-firewall/nfacct')
-rw-r--r--net-firewall/nfacct/Manifest2
-rw-r--r--net-firewall/nfacct/metadata.xml5
-rw-r--r--net-firewall/nfacct/nfacct-1.0.0.ebuild23
-rw-r--r--net-firewall/nfacct/nfacct-1.0.1.ebuild22
4 files changed, 52 insertions, 0 deletions
diff --git a/net-firewall/nfacct/Manifest b/net-firewall/nfacct/Manifest
new file mode 100644
index 00000000000..9498245f4d7
--- /dev/null
+++ b/net-firewall/nfacct/Manifest
@@ -0,0 +1,2 @@
+DIST nfacct-1.0.0.tar.bz2 255640 SHA256 eb7e64c3ee4f1e4b5d508e933dc9dc2f91e14ea3ee5f1926aad76c114d1d2014 SHA512 5ffec413759f065f150b8af622ee61a984546d253a6c95771f3e88433cb85cbfa93a41cbc8bdda66f8a3f19ec20bccce44d38f02c7305bb2bc72dad754fea566 WHIRLPOOL 0b0a62ac2dd9c1c30fd4559a1c19adc76da39709c377cf2537ecef33338dc9174dd0f9a55d50ac55f357a725b867b82c524634ef47cd5c0da97398294ed5f8c8
+DIST nfacct-1.0.1.tar.bz2 257013 SHA256 81ef261616f313372a957431d17c5a0334984f06ceea190cf390479bf043e7c4 SHA512 4d428f51ce3b12382974de3cb7d502f6a18d9c0fd4446071fc2b5e932c44e4b33072202f8b9bd4bdf892a08a64533776bb8e9a0a7c4acc876cfec154f76227a1 WHIRLPOOL ab3983015154109389c831cf4ac8e6d4afb299b3f2d0d9e76ae6e23e716f0fcb00f3317dd0754f144a6650f5c42029d132c875aa7d90687e5f2ac8ca24c476aa
diff --git a/net-firewall/nfacct/metadata.xml b/net-firewall/nfacct/metadata.xml
new file mode 100644
index 00000000000..78692635ad2
--- /dev/null
+++ b/net-firewall/nfacct/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>netmon</herd>
+</pkgmetadata>
diff --git a/net-firewall/nfacct/nfacct-1.0.0.ebuild b/net-firewall/nfacct/nfacct-1.0.0.ebuild
new file mode 100644
index 00000000000..643c98abf5f
--- /dev/null
+++ b/net-firewall/nfacct/nfacct-1.0.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit linux-info
+
+DESCRIPTION="Command line tool to create/retrieve/delete accounting objects in NetFilter"
+HOMEPAGE="http://netfilter.org/projects/nfacct"
+SRC_URI="http://www.netfilter.org/projects/${PN}/files/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~arm x86"
+IUSE=""
+
+RDEPEND="net-libs/libmnl
+ >=net-libs/libnetfilter_acct-1.0.0"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+CONFIG_CHECK="~NETFILTER_NETLINK_ACCT"
diff --git a/net-firewall/nfacct/nfacct-1.0.1.ebuild b/net-firewall/nfacct/nfacct-1.0.1.ebuild
new file mode 100644
index 00000000000..3a91810edcd
--- /dev/null
+++ b/net-firewall/nfacct/nfacct-1.0.1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit linux-info
+
+DESCRIPTION="Command line tool to create/retrieve/delete accounting objects in NetFilter"
+HOMEPAGE="http://netfilter.org/projects/nfacct"
+SRC_URI="http://www.netfilter.org/projects/${PN}/files/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~arm x86"
+
+RDEPEND="net-libs/libmnl
+ >=net-libs/libnetfilter_acct-1.0.2"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+CONFIG_CHECK="~NETFILTER_NETLINK_ACCT"