summaryrefslogtreecommitdiff
path: root/net-firewall
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2015-08-14 05:11:46 -0400
committerMike Frysinger <vapier@gentoo.org>2015-08-14 05:28:25 -0400
commitb1c6cd94770b972e38631dbaf0dfff7625aa9a40 (patch)
tree35a5f206c1b5067d368b4b07e0681ba8fc88458c /net-firewall
parent4943e7bd0065e98269afcf3a0d321881ec6bacaf (diff)
downloadgentoo-b1c6cd94770b972e38631dbaf0dfff7625aa9a40.tar.gz
gentoo-b1c6cd94770b972e38631dbaf0dfff7625aa9a40.tar.xz
net-firewall/iptables: add support for USE=pcap #512934
Diffstat (limited to 'net-firewall')
-rw-r--r--net-firewall/iptables/iptables-1.4.21-r2.ebuild4
-rw-r--r--net-firewall/iptables/metadata.xml1
2 files changed, 4 insertions, 1 deletions
diff --git a/net-firewall/iptables/iptables-1.4.21-r2.ebuild b/net-firewall/iptables/iptables-1.4.21-r2.ebuild
index c05cbf66b7c..eaba4222c29 100644
--- a/net-firewall/iptables/iptables-1.4.21-r2.ebuild
+++ b/net-firewall/iptables/iptables-1.4.21-r2.ebuild
@@ -16,11 +16,12 @@ SRC_URI="http://www.netfilter.org/projects/iptables/files/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-IUSE="conntrack ipv6 netlink static-libs"
+IUSE="conntrack ipv6 netlink pcap static-libs"
RDEPEND="
conntrack? ( net-libs/libnetfilter_conntrack )
netlink? ( net-libs/libnfnetlink )
+ pcap? ( net-libs/libpcap )
"
DEPEND="${RDEPEND}
virtual/os-headers
@@ -49,6 +50,7 @@ src_configure() {
--libexecdir="${EPREFIX}/$(get_libdir)" \
--enable-devel \
--enable-shared \
+ $(use_enable pcap bpf-compiler) \
$(use_enable static-libs static) \
$(use_enable ipv6)
}
diff --git a/net-firewall/iptables/metadata.xml b/net-firewall/iptables/metadata.xml
index 2770855f89c..7979119512b 100644
--- a/net-firewall/iptables/metadata.xml
+++ b/net-firewall/iptables/metadata.xml
@@ -5,6 +5,7 @@
<use>
<flag name='conntrack'>Build against <pkg>net-libs/libnetfilter_conntrack</pkg> when enables the connlabel matcher</flag>
<flag name='netlink'>Build against libnfnetlink which enables the nfnl_osf util</flag>
+ <flag name='pcap'>Build against <pkg>net-libs/libpcap</pkg> which enables the nfbpf_compile util</flag>
</use>
<longdescription>
iptables is the userspace command line program used to set up, maintain, and