summaryrefslogtreecommitdiff
path: root/net-fs/samba/samba-4.3.0.ebuild
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2015-09-09 15:37:47 +0200
committerLars Wendler <polynomial-c@gentoo.org>2015-09-09 15:40:36 +0200
commit57910ecc3e953e124784addd6b73019e1a4b7e86 (patch)
tree21afacc393dca00f754f743fe6aa52deb5764d6b /net-fs/samba/samba-4.3.0.ebuild
parentec067b50f1d61f2f3c8a6882f7b9292fdb917c89 (diff)
downloadgentoo-57910ecc3e953e124784addd6b73019e1a4b7e86.tar.gz
gentoo-57910ecc3e953e124784addd6b73019e1a4b7e86.tar.xz
net-fs/samba: Fixed compilation without gnutls (bug #559996).
Added two new USE flags: -addc controls installation of Active Directory Domain Controller functionality -system-mitkrb5 uses app-crypt/mit-krb5 instead of app-crypt/heimdal Re-added pam USE flag although samba still unconditionally links against libpam when being found on the system. USE flag controls installation of pam modules for now. Slightly reworked ebuilds. Added missing files for samba-4.3 Package-Manager: portage-2.2.20.1 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'net-fs/samba/samba-4.3.0.ebuild')
-rw-r--r--net-fs/samba/samba-4.3.0.ebuild96
1 files changed, 53 insertions, 43 deletions
diff --git a/net-fs/samba/samba-4.3.0.ebuild b/net-fs/samba/samba-4.3.0.ebuild
index 98a9e44d95e..1875ddbb1d7 100644
--- a/net-fs/samba/samba-4.3.0.ebuild
+++ b/net-fs/samba/samba-4.3.0.ebuild
@@ -24,13 +24,12 @@ LICENSE="GPL-3"
SLOT="0"
-IUSE="acl addns ads aio avahi client cluster cups dmapi fam gnutls iprint
-ldap quota selinux syslog systemd test winbind"
+IUSE="acl addc addns ads aio avahi client cluster cups dmapi fam gnutls iprint
+ldap pam quota selinux syslog +system-mitkrb5 systemd test winbind"
# sys-apps/attr is an automagic dependency (see bug #489748)
# sys-libs/pam is an automagic dependency (see bug #489770)
CDEPEND="${PYTHON_DEPS}
- >=app-crypt/heimdal-1.5[-ssl]
dev-libs/iniparser:0
dev-libs/popt
sys-libs/readline:=
@@ -58,6 +57,8 @@ CDEPEND="${PYTHON_DEPS}
gnutls? ( dev-libs/libgcrypt:0
>=net-libs/gnutls-1.4.0 )
ldap? ( net-nds/openldap )
+ system-mitkrb5? ( app-crypt/mit-krb5 )
+ !system-mitkrb5? ( >=app-crypt/heimdal-1.5[-ssl] )
systemd? ( sys-apps/systemd:0= )"
DEPEND="${CDEPEND}
virtual/pkgconfig"
@@ -66,11 +67,10 @@ RDEPEND="${CDEPEND}
selinux? ( sec-policy/selinux-samba )
"
-REQUIRED_USE="ads? ( acl gnutls ldap )
+REQUIRED_USE="addc? ( gnutls )
+ ads? ( acl gnutls ldap )
${PYTHON_REQUIRED_USE}"
-RESTRICT="mirror"
-
S="${WORKDIR}/${MY_P}"
PATCHES=( "${FILESDIR}/${PN}-4.2.3-heimdal_compilefix.patch" )
@@ -81,7 +81,7 @@ WAF_BINARY="${S}/buildtools/bin/waf"
pkg_setup() {
python-single-r1_pkg_setup
- if use aio; then
+ if use aio ; then
if ! linux_config_exists || ! linux_chkconfig_present AIO; then
ewarn "You must enable AIO support in your kernel config, "
ewarn "to be able to support asynchronous I/O. "
@@ -93,6 +93,14 @@ pkg_setup() {
ewarn "and recompile your kernel..."
fi
fi
+ if ! use pam ; then
+ ewarn "You have pam USE flag disabled!"
+ ewarn "Unfortunately we still have to hard depend on virtual/pam as samba upstream"
+ ewarn "still unconditionally links libauth4-samba4.so library to libpam.so once being"
+ ewarn "found on the sytem."
+ ewarn "Disabling the pam USE flag only disables installation of samba's pam authenti-"
+ ewarn "cation modules."
+ fi
}
src_prepare() {
@@ -100,45 +108,47 @@ src_prepare() {
}
src_configure() {
- local myconf=''
- use "cluster" && myconf+=" --with-ctdb-dir=/usr"
- use "test" && myconf+=" --enable-selftest"
- myconf="${myconf} \
- --enable-fhs \
- --sysconfdir=/etc \
- --localstatedir=/var \
- --with-modulesdir=/usr/$(get_libdir)/samba \
- --with-pammodulesdir=/$(get_libdir)/security \
- --with-piddir=/var/run/${PN} \
- --disable-rpath \
- --disable-rpath-install \
- --nopyc \
- --nopyo \
- --bundled-libraries=NONE \
- --builtin-libraries=NONE \
- $(use_with addns dnsupdate) \
- $(use_with acl acl-support) \
- $(use_with ads) \
- $(use_with aio aio-support) \
- $(use_enable avahi) \
- $(use_with cluster cluster-support) \
- $(use_enable cups) \
- $(use_with dmapi) \
- $(use_with fam) \
- $(use_enable gnutls) \
- $(use_enable iprint) \
- $(use_with ldap) \
- --with-pam \
- --with-pam_smbpass \
- $(use_with quota quotas) \
- $(use_with syslog) \
- $(use_with systemd) \
+ local myconf=()
+ myconf=(
+ --enable-fhs
+ --sysconfdir=/etc
+ --localstatedir=/var
+ --with-modulesdir=/usr/$(get_libdir)/samba
+ --with-piddir=/var/run/${PN}
+ --bundled-libraries=NONE
+ --builtin-libraries=NONE
+ --disable-rpath
+ --disable-rpath-install
+ --nopyc
+ --nopyo
+ $(use_with acl acl-support)
+ $(usex addc '' '--without-ad-dc')
+ $(use_with addns dnsupdate)
+ $(use_with ads)
+ $(usex ads '--with-shared-modules=idmap_ad' '')
+ $(use_with aio aio-support)
+ $(usex cluster '--with-ctdb-dir=/usr' '')
+ $(use_enable avahi)
+ $(use_with cluster cluster-support)
+ $(use_enable cups)
+ $(use_with dmapi)
+ $(use_with fam)
+ $(use_enable gnutls)
+ $(use_enable iprint)
+ $(use_with ldap)
+ $(use_with pam)
+ $(use_with pam pam_smbpass)
+ $(usex pam "--with-pammodulesdir=/$(get_libdir)/security" '')
+ $(use_with quota quotas)
+ $(use_with syslog)
+ $(use_with systemd)
+ $(usex system-mitkrb5 '--with-system-mitkrb5' '')
$(use_with winbind)
- "
- use "ads" && myconf+=" --with-shared-modules=idmap_ad"
+ $(usex test '--enable-selftest' '')
+ )
CPPFLAGS="-I${SYSROOT}/usr/include/et ${CPPFLAGS}" \
- waf-utils_src_configure ${myconf}
+ waf-utils_src_configure ${myconf[@]}
}
src_install() {