summaryrefslogtreecommitdiff
path: root/net-ftp/filezilla
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2016-03-16 20:02:54 +0100
committerLars Wendler <polynomial-c@gentoo.org>2016-03-17 09:06:44 +0100
commit7ccfe8c8affc7cc4d81bd01dad2079c18fabe779 (patch)
tree82fdc86bb53e2e5aba28d81f5cd110ba9b1a6105 /net-ftp/filezilla
parent9f53328f221c3928539f1852bdf1c72b59869da4 (diff)
downloadgentoo-7ccfe8c8affc7cc4d81bd01dad2079c18fabe779.tar.gz
gentoo-7ccfe8c8affc7cc4d81bd01dad2079c18fabe779.tar.xz
net-ftp/filezilla: Bump to version 3.16.1
Package-Manager: portage-2.2.28 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'net-ftp/filezilla')
-rw-r--r--net-ftp/filezilla/Manifest1
-rw-r--r--net-ftp/filezilla/filezilla-3.16.1.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/net-ftp/filezilla/Manifest b/net-ftp/filezilla/Manifest
index d39142c710f..357d2e3f4d9 100644
--- a/net-ftp/filezilla/Manifest
+++ b/net-ftp/filezilla/Manifest
@@ -2,3 +2,4 @@ DIST FileZilla_3.12.0.2_src.tar.bz2 4440836 SHA256 7a296fc2cd94d00d3a14ad29b84ff
DIST FileZilla_3.14.1_src.tar.bz2 4411187 SHA256 b10871b6ced5f52062b44deda037edb8a38090b226a018b9b64b1a1feb59d46c SHA512 c97767ed01f4538a2f4b8760601778ca7f9aa99b5b928cb86c9508eba0490bbc1f31921d098e0ccd30712ff06dc9f21d323201fb8bee80b9fb7a6528fbb03368 WHIRLPOOL 1fbccfbb0de5111fad14eb0b38ee190aefc4c80777c3611189c74412dfefdf2fd96d4a42c917791d3a3318b6ae22f01a7d24a4a0904386b22a98693151b5a822
DIST FileZilla_3.15.0.2_src.tar.bz2 4404751 SHA256 333c46709506b2777047556aa9ee791b404e5f8b94236b3c8a789c1dc09f7c4f SHA512 f71cff0c32771de92d3d7140e160ad9474ce8c84b82e3170dbd7d5814d94cf91fbf40d1b4bc581f77dac2082eef662f6ef8100032bdee5a90c1b4658da69bcab WHIRLPOOL 5eef822dd16e0ea9b37097432e22e4b805ab13cfabd5e49e3fa8c0789e191563321c009d46ecf1804f220beab739140b654b188619dcd52895d5442d04f73ab2
DIST FileZilla_3.16.0_src.tar.bz2 4406422 SHA256 7dbd55a706ac1552ed4a0b86eeb59fcfc58cf6041b581c4dcf9a6cf560279b46 SHA512 f4fd44fe465c1c098a235470a7c768425b683babd309b55bd3e4b31c97f087fdc2261f8b108af04aab120da90105e22dd0d92c39be5f0bef7e70b892a6493825 WHIRLPOOL fc4b6ee203b03cbb33a8fc98e10536ae7265324a87bdf01fcb9d645df8cb29511b66ac2d371323a0f9f03ec9c872785666bf0c8bc28259ee3f35fd574b0505bb
+DIST FileZilla_3.16.1_src.tar.bz2 4406617 SHA256 3b046f854cea17f9c14d6a12aa5d2e027908c6535f44a068cfed5da9eddddda8 SHA512 0b8098e5b48254c92a0954ad43b4fad168d98cf095f78fe7e030a6287117d5000f8e499e09f356021f2bbd32c5b9637a86016ff8d444cc1ecaede5c716ff752c WHIRLPOOL f5a36bc5fe003de1b853a349961398efea31137ff2384e68f862fcb1e7d2a378f1c0dbcb0c28eeb24b76332a1f51ff0538e5ccca82ba9092c8e1be68e3fbd53e
diff --git a/net-ftp/filezilla/filezilla-3.16.1.ebuild b/net-ftp/filezilla/filezilla-3.16.1.ebuild
new file mode 100644
index 00000000000..d90f1ec8a10
--- /dev/null
+++ b/net-ftp/filezilla/filezilla-3.16.1.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+WX_GTK_VER="3.0"
+
+inherit autotools eutils flag-o-matic multilib wxwidgets
+
+MY_PV=${PV/_/-}
+MY_P="FileZilla_${MY_PV}"
+
+DESCRIPTION="FTP client with lots of useful features and an intuitive interface"
+HOMEPAGE="http://filezilla-project.org/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}_src.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="dbus nls test"
+
+# pugixml 1.7 minimal dependency is for c++11 proper configuration
+RDEPEND=">=app-eselect/eselect-wxwidgets-0.7-r1
+ >=dev-db/sqlite-3.7
+ >=dev-libs/libfilezilla-0.4.0
+ >=dev-libs/pugixml-1.7
+ net-dns/libidn
+ >=net-libs/gnutls-3.1.12
+ >=x11-libs/wxGTK-3.0.2.0-r1:3.0[X] x11-misc/xdg-utils
+ dbus? ( sys-apps/dbus )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ >=sys-devel/libtool-1.4
+ nls? ( >=sys-devel/gettext-0.11 )
+ test? ( dev-util/cppunit )"
+
+S="${WORKDIR}"/${PN}-${MY_PV}
+
+pkg_pretend() {
+ if [[ ${MERGE_TYPE} != binary ]]; then
+ if ! test-flag-CXX -std=c++14; then
+ eerror "${P} requires C++14-capable C++ compiler. Your current compiler"
+ eerror "does not seem to support -std=c++14 option. Please upgrade your compiler"
+ eerror "to gcc-4.9 or an equivalent version supporting C++14."
+ die "Currently active compiler does not support -std=c++14"
+ fi
+ fi
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-3.10.2-debug.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_with dbus) $(use_enable nls locales) \
+ --with-pugixml=system \
+ --disable-autoupdatecheck
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ doicon src/interface/resources/48x48/${PN}.png
+
+ dodoc AUTHORS ChangeLog NEWS
+}