summaryrefslogtreecommitdiff
path: root/net-ftp/gftp
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-ftp/gftp
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-ftp/gftp')
-rw-r--r--net-ftp/gftp/Manifest1
-rw-r--r--net-ftp/gftp/files/gftp-2.0.19-gftp-expand-path-sigsegv.patch21
-rw-r--r--net-ftp/gftp/gftp-2.0.19-r2.ebuild39
-rw-r--r--net-ftp/gftp/metadata.xml5
4 files changed, 66 insertions, 0 deletions
diff --git a/net-ftp/gftp/Manifest b/net-ftp/gftp/Manifest
new file mode 100644
index 00000000000..5154d3e1a14
--- /dev/null
+++ b/net-ftp/gftp/Manifest
@@ -0,0 +1 @@
+DIST gftp-2.0.19.tar.bz2 1687167 SHA256 5306a46be96d6f4d23906cb1836fb3d732039621a6c7fcfa921acc21ac110bfd SHA512 59968786d66aaf6fb520f73d52ed0f8b57751a5ed222a5c65a7257628cd9addfd0ff3213206311bfd24441d7e6cc6d245d74d6687a1ad9739361da61ca078172 WHIRLPOOL 511572735b97d504e660cc6db2acc9898cb75bf4ef00304b9c225a2340aa4378ad1aa341a83db1c5c0ad637c4645655616effca901fc6990632c2c8a401df1b2
diff --git a/net-ftp/gftp/files/gftp-2.0.19-gftp-expand-path-sigsegv.patch b/net-ftp/gftp/files/gftp-2.0.19-gftp-expand-path-sigsegv.patch
new file mode 100644
index 00000000000..f3e029dea0c
--- /dev/null
+++ b/net-ftp/gftp/files/gftp-2.0.19-gftp-expand-path-sigsegv.patch
@@ -0,0 +1,21 @@
+Fix segmentation fault, when gftpui_run_chdir is called with directory=0x0,
+and then calls gftp_expand_path (src=0x0),
+the NULL string was cloned using g_strdup, which returns NULL if
+its only argument is NULL, then this returned string was unreferenced.
+
+ lib/misc.c | 2 ++
+ 1 files changed, 2 insertions(+), 0 deletions(-)
+
+diff --git a/lib/misc.c b/lib/misc.c
+index 16c019b..2791466 100644
+--- a/lib/misc.c
++++ b/lib/misc.c
+@@ -143,6 +143,8 @@ gftp_expand_path (gftp_request * request, const char *src)
+ tempchar;
+ struct passwd *pw;
+
++ g_return_val_if_fail(src != NULL, NULL);
++
+ pw = NULL;
+ str = g_strdup (src);
+
diff --git a/net-ftp/gftp/gftp-2.0.19-r2.ebuild b/net-ftp/gftp/gftp-2.0.19-r2.ebuild
new file mode 100644
index 00000000000..6107322b23c
--- /dev/null
+++ b/net-ftp/gftp/gftp-2.0.19-r2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="Gnome based FTP Client"
+SRC_URI="http://www.gftp.org/${P}.tar.bz2"
+HOMEPAGE="http://www.gftp.org"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 ppc ppc64 sparc x86 ~x86-fbsd"
+IUSE="gtk ssl"
+
+RDEPEND="dev-libs/glib:2
+ sys-devel/gettext
+ sys-libs/ncurses
+ sys-libs/readline:0
+ gtk? ( x11-libs/gtk+:2 )
+ ssl? ( dev-libs/openssl:0 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ # Fix SIGSEGV for gftp_expand_path function
+ epatch "${FILESDIR}/${P}-${PN}-expand-path-sigsegv.patch"
+}
+
+src_configure() {
+ econf $(use_enable gtk gtkport) $(use_enable ssl)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc ChangeLog* README* THANKS TODO docs/USERS-GUIDE
+}
diff --git a/net-ftp/gftp/metadata.xml b/net-ftp/gftp/metadata.xml
new file mode 100644
index 00000000000..da6fd63d008
--- /dev/null
+++ b/net-ftp/gftp/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>gnome</herd>
+</pkgmetadata>