summaryrefslogtreecommitdiff
path: root/net-im/coccinella/coccinella-0.96.20.ebuild
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-im/coccinella/coccinella-0.96.20.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-im/coccinella/coccinella-0.96.20.ebuild')
-rw-r--r--net-im/coccinella/coccinella-0.96.20.ebuild70
1 files changed, 70 insertions, 0 deletions
diff --git a/net-im/coccinella/coccinella-0.96.20.ebuild b/net-im/coccinella/coccinella-0.96.20.ebuild
new file mode 100644
index 00000000000..c3c50472c5f
--- /dev/null
+++ b/net-im/coccinella/coccinella-0.96.20.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit eutils fdo-mime
+
+NAME=Coccinella
+DESCRIPTION="Jabber Client With a Built-in Whiteboard and VoIP (jingle)"
+HOMEPAGE="http://www.thecoccinella.org/"
+SRC_URI="mirror://sourceforge/coccinella/${NAME}-${PV}Src.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ssl"
+
+DEPEND=">=dev-lang/tk-8.5
+ >=dev-tcltk/tkpng-0.9
+ >=dev-tcltk/tktreectrl-2.2.9
+ >=dev-tcltk/tktray-1.1
+ >=dev-tcltk/snack-2.2
+ ssl? ( >=dev-tcltk/tls-1.4 )
+ >=dev-tcltk/tkimg-1.3"
+
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${NAME}-${PV}Src"
+
+#src_compile() {
+# einfo "Nothing to compile for ${P}."
+#}
+
+src_install () {
+ rm -R "${S}"/bin/unix/Linux/i686/ || die
+ rm -R "${S}"/bin/macosx || die
+ rm -R "${S}"/bin/windows || die
+ rm -R "${S}"/bin/unix/NetBSD || die
+
+ dodir /opt/coccinella
+ cp -R "${S}"/* "${D}"/opt/coccinella/
+ fperms 0755 /opt/coccinella/Coccinella.tcl
+ dosym /opt/coccinella/Coccinella.tcl /opt/bin/coccinella
+ dodoc README.txt READMEs/*
+
+ for x in 128 64 32 16 ; do
+ src=/opt/coccinella/themes/Oxygen/icons/${x}x${x}/coccinella.png
+ src2=/opt/coccinella/themes/Oxygen/icons/${x}x${x}/coccinella.png
+ src2shadow=/opt/coccinella/themes/Oxygen/icons/${x}x${x}/coccinella2-shadow.png
+ dir=/usr/share/icons/hicolor/${x}x${x}/apps
+ dodir ${dir}
+ dosym ${src} ${dir}/coccinella.png
+ dosym ${src2} ${dir}/coccinella2.png
+ dosym ${src2shadow} ${dir}/coccinella2-shadow.png
+ unset src
+ unset src2
+ unset src2shadow
+ unset dir
+ done
+
+ make_desktop_entry "coccinella" "Coccinella IM Client" "coccinella2-shadow"
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+}