summaryrefslogtreecommitdiff
path: root/net-irc
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2017-03-23 08:21:37 +0100
committerJeroen Roovers <jer@gentoo.org>2017-03-23 08:24:35 +0100
commit87cc7b99087f918ef27611292fe04cf9934d711c (patch)
tree4c3256c5600a276c89b32b5e5e572b3059746ba8 /net-irc
parentcbca31658095e7f54d32fb0d25b0482eb75e2b3a (diff)
downloadgentoo-87cc7b99087f918ef27611292fe04cf9934d711c.tar.gz
gentoo-87cc7b99087f918ef27611292fe04cf9934d711c.tar.xz
net-irc/ii: Add live ebuild.
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/ii/ii-9999.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/net-irc/ii/ii-9999.ebuild b/net-irc/ii/ii-9999.ebuild
new file mode 100644
index 00000000000..dce9e4b2dd6
--- /dev/null
+++ b/net-irc/ii/ii-9999.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit fixheadtails git-r3 toolchain-funcs
+
+DESCRIPTION="A minimalist FIFO and filesystem-based IRC client"
+HOMEPAGE="http://tools.suckless.org/ii/"
+EGIT_REPO_URI="http://git.suckless.org/ii"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS=""
+
+src_prepare() {
+ default
+
+ sed -i \
+ -e "s/CFLAGS = -g -O0/CFLAGS += /" \
+ -e "s/LDFLAGS =/LDFLAGS +=/" \
+ -e /^LIBS/d \
+ config.mk || die
+
+ # enable verbose build
+ sed -i 's/@${CC}/${CC}/' Makefile || die
+
+ ht_fix_file query.sh
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ dobin ii
+ newbin query.sh ii-query
+ dodoc CHANGES FAQ README
+ doman *.1
+}