summaryrefslogtreecommitdiff
path: root/net-libs/ignition-transport
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-02-09 09:02:39 +0100
committerAlexis Ballier <aballier@gentoo.org>2016-02-09 09:45:48 +0100
commit3158ee617a77e6127582cf3d9986cf30c030fb5e (patch)
tree4a9dc953483e70bc9a38cc4f6b65aeb1a23ad5cb /net-libs/ignition-transport
parent673267dd6863b999b2285adf0f09c37385bb140f (diff)
downloadgentoo-3158ee617a77e6127582cf3d9986cf30c030fb5e.tar.gz
gentoo-3158ee617a77e6127582cf3d9986cf30c030fb5e.tar.xz
net-libs/ignition-transport: bump to 1.0.1
Package-Manager: portage-2.2.27 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'net-libs/ignition-transport')
-rw-r--r--net-libs/ignition-transport/Manifest1
-rw-r--r--net-libs/ignition-transport/ignition-transport-1.0.1.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/net-libs/ignition-transport/Manifest b/net-libs/ignition-transport/Manifest
index 4dd0f71d27d..90c7bb45360 100644
--- a/net-libs/ignition-transport/Manifest
+++ b/net-libs/ignition-transport/Manifest
@@ -1,2 +1,3 @@
DIST ignition-transport-0.7.0.tar.bz2 339283 SHA256 93629936bf1de3fe8168f97028d76d5c34ad1ecb0869d1a2bbfc7ede0797dc61 SHA512 ce28f5cc9a4e2c71f84bdfd210f43c1410e8ae9bb59568e74ca0c33fe029ba41e016d2defbba8003f5a8228b4a068813c3fd6124f17e583c87dfa27d15303282 WHIRLPOOL 8fd7de962b67b94bde2e4c163d50b660d3b144260a3a8bdc0421775b7fb67c6b5bfd120897b076f6b94b8144720bad953fb00491845296521e3f15fb918bc4c5
DIST ignition-transport-0.9.0.tar.bz2 345080 SHA256 3ff085d0398782e4e5edb48e86b6211eee38c56b415e000f7b02a398fba44895 SHA512 af6f3b678f5ac463b59feb603e138e2ce18f404ac73580384b6fdc2cb502c9f9fb8b3e9280ff250c3ea691dd986c6c6a31296b5e19cf96f5f785da09d2530cbc WHIRLPOOL e920d0e1250eaa38fa9a625dcb7d63cf3574abc9beede6554abc50d17f737d1ff58fa8a34302572cb9e827af72ee7ba3b8b30cc2fab33aa977db41c3ddc7b16b
+DIST ignition-transport-1.0.1.tar.bz2 342960 SHA256 584b9b2ff29c349893e8b97761acfea70097f45374554d5ed0b57abac1691e23 SHA512 82314bd413fac111c07ec1ba3f32ecee3995087a98b40c97f6c634ecad3ba6a046a600a3c387f6d7a33997bb7e5a1bac962613146ac09c717d91624333d7e0a3 WHIRLPOOL 0013302cb1216513505c8eff7f11c38e5ec1e4f370bfb00c910a2682b704e0140f9f9bc032fe092ff03aaa28f5e1ce8d14d246bc5a672a60be072fb4af4e6fab
diff --git a/net-libs/ignition-transport/ignition-transport-1.0.1.ebuild b/net-libs/ignition-transport/ignition-transport-1.0.1.ebuild
new file mode 100644
index 00000000000..f965d2fac12
--- /dev/null
+++ b/net-libs/ignition-transport/ignition-transport-1.0.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-utils vcs-snapshot flag-o-matic
+
+DESCRIPTION="Combines ZeroMQ with Protobufs to create a fast and efficient message passing system"
+HOMEPAGE="http://ignitionrobotics.org/libraries/transport"
+SRC_URI="http://gazebosim.org/distributions/ign-transport/releases/${P}.tar.bz2"
+
+LICENSE="Apache-2.0"
+SLOT="0/0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="
+ dev-libs/protobuf:=
+ >=net-libs/zeromq-3.2.0:=
+ sys-apps/util-linux
+ net-libs/cppzmq
+"
+RDEPEND="${DEPEND}"
+DEPEND="${DEPEND}
+ virtual/pkgconfig"
+CMAKE_BUILD_TYPE=RelWithDebInfo
+
+src_configure() {
+ # upstream appends this conditionally...
+ append-flags "-fPIC"
+ echo "set (CMAKE_C_FLAGS_ALL \"${CXXFLAGS} \${CMAKE_C_FLAGS_ALL}\")" > "${S}/cmake/HostCFlags.cmake"
+ sed -i -e "s/LINK_FLAGS_RELWITHDEBINFO \" \"/LINK_FLAGS_RELWITHDEBINFO \" ${LDFLAGS} \"/" cmake/DefaultCFlags.cmake || die
+ cmake-utils_src_configure
+}