summaryrefslogtreecommitdiff
path: root/net-libs/libesmtp
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-libs/libesmtp
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-libs/libesmtp')
-rw-r--r--net-libs/libesmtp/Manifest1
-rw-r--r--net-libs/libesmtp/files/libesmtp-1.0-openssl.patch13
-rw-r--r--net-libs/libesmtp/libesmtp-1.0.6-r1.ebuild40
-rw-r--r--net-libs/libesmtp/libesmtp-1.0.6.ebuild39
-rw-r--r--net-libs/libesmtp/metadata.xml8
5 files changed, 101 insertions, 0 deletions
diff --git a/net-libs/libesmtp/Manifest b/net-libs/libesmtp/Manifest
new file mode 100644
index 00000000000..d947fb770f8
--- /dev/null
+++ b/net-libs/libesmtp/Manifest
@@ -0,0 +1 @@
+DIST libesmtp-1.0.6.tar.bz2 365506 SHA256 d0a61a5c52d99fa7ce7d00ed0a07e341dbda67101dbed1ab0cdae3f37db4eb0b SHA512 c122fc5995b76771cce2db58c9e59597cc3a76d273feb6fc26b869f118e91bdf98a5721ee2d1de8175c376af018b5806b0379bbeba2f5da95108916028fd8dda WHIRLPOOL 6bce1e05ca48c300917c1d079ce31f95d2e0d7b2339af9d69a126e63af94ff9585d5add3b6ab9d22c6e889fd2bb5ce50af32adbb246ed67ecd7a340b97f7d97f
diff --git a/net-libs/libesmtp/files/libesmtp-1.0-openssl.patch b/net-libs/libesmtp/files/libesmtp-1.0-openssl.patch
new file mode 100644
index 00000000000..2a7df7ea375
--- /dev/null
+++ b/net-libs/libesmtp/files/libesmtp-1.0-openssl.patch
@@ -0,0 +1,13 @@
+--- ntlm/ntlmdes.c 2003-09-17 19:27:03.000000000 +0000
++++ ntlm/ntlmdes.c 2003-09-17 19:27:40.000000000 +0000
+@@ -60,8 +60,8 @@
+ des_ecb_encrypt (iv, result, ks, DES_ENCRYPT);
+
+ /* paranoia */
+- memset (key, 0, sizeof key);
+- memset (ks, 0, sizeof ks);
++ memset (&key, 0, sizeof key);
++ memset (&ks, 0, sizeof ks);
+ }
+
+ /* Copy and convert to upper case. If supplied string is shorter than the
diff --git a/net-libs/libesmtp/libesmtp-1.0.6-r1.ebuild b/net-libs/libesmtp/libesmtp-1.0.6-r1.ebuild
new file mode 100644
index 00000000000..e98e61f21b2
--- /dev/null
+++ b/net-libs/libesmtp/libesmtp-1.0.6-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit libtool
+
+DESCRIPTION="lib that implements the client side of the SMTP protocol"
+HOMEPAGE="http://www.stafford.uklinux.net/libesmtp/"
+SRC_URI="http://www.stafford.uklinux.net/${PN}/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1 GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ppc ~ppc64 ~s390 ~sh sparc x86 ~amd64-linux ~x86-linux ~x86-macos"
+IUSE="debug ntlm ssl static-libs threads"
+
+RDEPEND="ssl? ( dev-libs/openssl )"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ elibtoolize
+}
+
+src_configure() {
+ econf \
+ --disable-dependency-tracking \
+ $(use_enable static-libs static) \
+ --enable-all \
+ $(use_enable ntlm) \
+ $(use_enable threads pthreads) \
+ $(use_enable debug) \
+ $(use_with ssl openssl)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS ChangeLog NEWS Notes README TODO
+ insinto /usr/share/doc/${PF}/xml
+ doins doc/api.xml
+}
diff --git a/net-libs/libesmtp/libesmtp-1.0.6.ebuild b/net-libs/libesmtp/libesmtp-1.0.6.ebuild
new file mode 100644
index 00000000000..e8664b956e3
--- /dev/null
+++ b/net-libs/libesmtp/libesmtp-1.0.6.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=3
+inherit libtool
+
+DESCRIPTION="lib that implements the client side of the SMTP protocol"
+HOMEPAGE="http://www.stafford.uklinux.net/libesmtp/"
+SRC_URI="http://www.stafford.uklinux.net/${PN}/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1 GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 ppc ppc64 s390 sh sparc x86 ~amd64-linux ~x86-linux ~x86-macos"
+IUSE="debug ssl static-libs threads"
+
+RDEPEND="ssl? ( dev-libs/openssl )"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ elibtoolize
+}
+
+src_configure() {
+ econf \
+ --disable-dependency-tracking \
+ $(use_enable static-libs static) \
+ --enable-all \
+ $(use_enable threads pthreads) \
+ $(use_enable debug) \
+ $(use_with ssl openssl)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog NEWS Notes README TODO
+ insinto /usr/share/doc/${PF}/xml
+ doins doc/api.xml
+}
diff --git a/net-libs/libesmtp/metadata.xml b/net-libs/libesmtp/metadata.xml
new file mode 100644
index 00000000000..90c529dd9ca
--- /dev/null
+++ b/net-libs/libesmtp/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>net-mail</herd>
+<use>
+ <flag name="ntlm">Enable support for NTLM authentication</flag>
+</use>
+</pkgmetadata>