summaryrefslogtreecommitdiff
path: root/net-libs/libgssglue
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-libs/libgssglue
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-libs/libgssglue')
-rw-r--r--net-libs/libgssglue/Manifest1
-rw-r--r--net-libs/libgssglue/files/libgssglue-0.3-protos.patch15
-rw-r--r--net-libs/libgssglue/files/libgssglue-0.4-implicit-declarations.patch15
-rw-r--r--net-libs/libgssglue/libgssglue-0.4.ebuild38
-rw-r--r--net-libs/libgssglue/metadata.xml5
5 files changed, 74 insertions, 0 deletions
diff --git a/net-libs/libgssglue/Manifest b/net-libs/libgssglue/Manifest
new file mode 100644
index 00000000000..0a099d1e9e5
--- /dev/null
+++ b/net-libs/libgssglue/Manifest
@@ -0,0 +1 @@
+DIST libgssglue-0.4.tar.gz 346984 SHA256 3f791a75502ba723e5e85e41e5e0c711bb89e2716b7c0ec6e74bd1df6739043a SHA512 25d514c08320e42851ff153d7691267a8454f205492faf942f566aa30c1ac1c83bd095732a1a0fcc010ba3a5d48b4c95a196ad05bc821598cc1fc3a2c4960d29 WHIRLPOOL 5f050ea5c429dcc97050e23e6b89bff175c5150916bc0a6b351faf31e4d962b6d81df1f4984ae5f9e44119550809a57818a5ccc6f65af77cbf5f73b19de28cb9
diff --git a/net-libs/libgssglue/files/libgssglue-0.3-protos.patch b/net-libs/libgssglue/files/libgssglue-0.3-protos.patch
new file mode 100644
index 00000000000..5aaf6d03aaa
--- /dev/null
+++ b/net-libs/libgssglue/files/libgssglue-0.3-protos.patch
@@ -0,0 +1,15 @@
+add missing prototype to header
+
+--- a/src/mglueP.h
++++ b/src/mglueP.h
+@@ -477,6 +477,10 @@ OM_uint32 generic_gss_str_to_oid
+ gss_OID * /* oid */
+ );
+
++OM_uint32
++generic_gss_copy_oid_set(OM_uint32 *minor_status,
++ const gss_OID_set_desc * const oidset,
++ gss_OID_set *new_oidset);
+
+ gss_OID gss_find_mechanism_from_name_type (gss_OID); /* name_type */
+
diff --git a/net-libs/libgssglue/files/libgssglue-0.4-implicit-declarations.patch b/net-libs/libgssglue/files/libgssglue-0.4-implicit-declarations.patch
new file mode 100644
index 00000000000..6a98569128d
--- /dev/null
+++ b/net-libs/libgssglue/files/libgssglue-0.4-implicit-declarations.patch
@@ -0,0 +1,15 @@
+* g_initialize.c:275:5: warning: implicit declaration of function 'getuid' [-Wimplicit-function-declaration]
+* g_initialize.c:275:5: warning: implicit declaration of function 'geteuid' [-Wimplicit-function-declaration]
+
+--- src/g_initialize.c
++++ src/g_initialize.c
+@@ -29,6 +29,9 @@
+ #include "mglueP.h"
+ #include <stdlib.h>
+
++#include <unistd.h> /* getuid, geteuid */
++#include <sys/types.h> /* ditto */
++
+ #include <stdio.h>
+ #include <string.h>
+ #include <ctype.h>
diff --git a/net-libs/libgssglue/libgssglue-0.4.ebuild b/net-libs/libgssglue/libgssglue-0.4.ebuild
new file mode 100644
index 00000000000..8b2e70d9c22
--- /dev/null
+++ b/net-libs/libgssglue/libgssglue-0.4.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit eutils
+
+DESCRIPTION="exports a gssapi interface which calls other random gssapi libraries"
+HOMEPAGE="http://www.citi.umich.edu/projects/nfsv4/linux/"
+SRC_URI="http://www.citi.umich.edu/projects/nfsv4/linux/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86"
+IUSE=""
+
+RDEPEND="!app-crypt/libgssapi"
+
+DOCS="AUTHORS ChangeLog NEWS README"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PN}-0.3-protos.patch \
+ "${FILESDIR}"/${PN}-0.4-implicit-declarations.patch
+}
+
+src_configure() {
+ # No need to install static libraries, as it uses libdl
+ econf --disable-static
+}
+
+src_install() {
+ default
+ prune_libtool_files
+
+ insinto /etc
+ doins doc/gssapi_mech.conf
+}
diff --git a/net-libs/libgssglue/metadata.xml b/net-libs/libgssglue/metadata.xml
new file mode 100644
index 00000000000..ca66751dee2
--- /dev/null
+++ b/net-libs/libgssglue/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>net-fs</herd>
+</pkgmetadata>