summaryrefslogtreecommitdiff
path: root/net-libs/libndp
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-libs/libndp
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-libs/libndp')
-rw-r--r--net-libs/libndp/Manifest2
-rw-r--r--net-libs/libndp/libndp-1.4.ebuild27
-rw-r--r--net-libs/libndp/libndp-1.5.ebuild28
-rw-r--r--net-libs/libndp/metadata.xml5
4 files changed, 62 insertions, 0 deletions
diff --git a/net-libs/libndp/Manifest b/net-libs/libndp/Manifest
new file mode 100644
index 00000000000..ce3f0f50dc1
--- /dev/null
+++ b/net-libs/libndp/Manifest
@@ -0,0 +1,2 @@
+DIST libndp-1.4.tar.gz 337802 SHA256 3a0be247ec024bd72fe5b40ea9491519c4023c7faf078311196fab817b2fd55f SHA512 a84d4d6672bf83bcf865eef8986e7bbcc49587686c5085a5ce5f346791223ede0e60db3b990055afc4f0005182aa1b5546c459306d2955f95d00ffb68bd58766 WHIRLPOOL 7c5a25b7bcde139bc7d194b07a53ea1fa4bc57caa2e5d6ccb93a6b89d47141706b040030e7124058f1f58f9538e558f5b86547bcd93380ca8ab8747b177e48c9
+DIST libndp-1.5.tar.gz 337212 SHA256 faf116ab70ce9514ec4e8573556025debea08f606e7f38b616de1f26e120c795 SHA512 f9a70e23e235cac92e978bf08f36eeff8324e94da158ca60290f7d607ac9ecdefc0b8b3766b877af7ed532506a061aa708155f8f2e4af4570378a97ff7d59c65 WHIRLPOOL 5b1d3b2646a1b0e4e29172e59d1dc093c504fbecf41a41a02921f30312bf1fb660c8bb4494273e5ef340b9f2b70e0faf2ec96b5da7febb4874499bc7d0afc588
diff --git a/net-libs/libndp/libndp-1.4.ebuild b/net-libs/libndp/libndp-1.4.ebuild
new file mode 100644
index 00000000000..2209baa5592
--- /dev/null
+++ b/net-libs/libndp/libndp-1.4.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+GCONF_DEBUG="no"
+
+inherit gnome2
+
+DESCRIPTION="Library for Neighbor Discovery Protocol"
+HOMEPAGE="http://libndp.org"
+SRC_URI="http://libndp.org/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="debug"
+
+KEYWORDS="~alpha amd64 arm ~arm64 ~ia64 ppc ppc64 ~sparc x86"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-static \
+ --enable-logging
+}
diff --git a/net-libs/libndp/libndp-1.5.ebuild b/net-libs/libndp/libndp-1.5.ebuild
new file mode 100644
index 00000000000..5f2ce9af583
--- /dev/null
+++ b/net-libs/libndp/libndp-1.5.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+GCONF_DEBUG="no"
+
+inherit gnome2 multilib-minimal
+
+DESCRIPTION="Library for Neighbor Discovery Protocol"
+HOMEPAGE="http://libndp.org"
+SRC_URI="http://libndp.org/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+KEYWORDS="~alpha amd64 arm ~arm64 ~ia64 ppc ppc64 ~sparc x86"
+
+DEPEND=""
+RDEPEND=""
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" \
+ gnome2_src_configure \
+ --disable-static \
+ --enable-logging
+}
diff --git a/net-libs/libndp/metadata.xml b/net-libs/libndp/metadata.xml
new file mode 100644
index 00000000000..da6fd63d008
--- /dev/null
+++ b/net-libs/libndp/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>gnome</herd>
+</pkgmetadata>