summaryrefslogtreecommitdiff
path: root/net-libs/liboping
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-libs/liboping
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-libs/liboping')
-rw-r--r--net-libs/liboping/Manifest2
-rw-r--r--net-libs/liboping/files/liboping-1.6.2-nouidmagic.patch19
-rw-r--r--net-libs/liboping/liboping-1.7.0.ebuild43
-rw-r--r--net-libs/liboping/liboping-1.8.0.ebuild43
-rw-r--r--net-libs/liboping/metadata.xml10
5 files changed, 117 insertions, 0 deletions
diff --git a/net-libs/liboping/Manifest b/net-libs/liboping/Manifest
new file mode 100644
index 00000000000..5eef357cb4b
--- /dev/null
+++ b/net-libs/liboping/Manifest
@@ -0,0 +1,2 @@
+DIST liboping-1.7.0.tar.bz2 306359 SHA256 60089a544522abced4aecbb554f494632968371e5ade7bea27015cd6aa598db3 SHA512 74ca6184fc192cabc0edb289aaab7b7d6f743a69cd0e1c0de82d768e7fd599229fbb974fbc0e1f3f5a3377c47cc8871c8cd1b16982f7b67167cd7cc5808eb38e WHIRLPOOL cf845b01582cf207c2409e1e5ee71ca9e7fb402ff8fb0131778246aa8931aa3b1c59e6318fea6923ed3f83721f8a0928991ecefb87f7ec13f2f8c4f3f8df4fdc
+DIST liboping-1.8.0.tar.bz2 316441 SHA256 1dcb9182c981b31d67522ae24e925563bed57cf950dc681580c4b0abb6a65bdb SHA512 94170de6e23c1c2380866e5195a3cdac795f30bda560ee3869bcdd9aa42b831fa3aac1a351033f72ed81d501b8e3e02db9bb5e5ada29e51ea4b1d2cca7af6217 WHIRLPOOL 724144216788a3837e2afb45b88a9ea757984e45841a365cfc7b17b43269069600dd9ed261f4b108527eb5f19b151500b24e4544c8e3f944cc1d7392e39b6c4a
diff --git a/net-libs/liboping/files/liboping-1.6.2-nouidmagic.patch b/net-libs/liboping/files/liboping-1.6.2-nouidmagic.patch
new file mode 100644
index 00000000000..2cb1b25e12e
--- /dev/null
+++ b/net-libs/liboping/files/liboping-1.6.2-nouidmagic.patch
@@ -0,0 +1,19 @@
+diff -ruN liboping-1.6.2.orig/src/Makefile.am liboping-1.6.2/src/Makefile.am
+--- liboping-1.6.2.orig/src/Makefile.am 2012-01-31 17:20:44.000000000 +0100
++++ liboping-1.6.2/src/Makefile.am 2012-06-11 21:21:08.000000000 +0200
+@@ -52,15 +52,3 @@
+ endif
+ endif # BUILD_WITH_LIBNCURSES
+
+-install-exec-hook:
+- @if test "x0" = "x$$UID"; then \
+- if test "xLinux" = "x`uname -s`"; then \
+- echo "Setting CAP_NET_RAW capability on binaries."; \
+- setcap cap_net_raw=ep $(DESTDIR)$(bindir)/oping || true; \
+- setcap cap_net_raw=ep $(DESTDIR)$(bindir)/noping || true; \
+- else \
+- echo "Setting set-UID bit on binaries."; \
+- chmod u+s $(DESTDIR)$(bindir)/oping || true; \
+- chmod u+s $(DESTDIR)$(bindir)/noping || true; \
+- fi; \
+- fi
diff --git a/net-libs/liboping/liboping-1.7.0.ebuild b/net-libs/liboping/liboping-1.7.0.ebuild
new file mode 100644
index 00000000000..502686eec83
--- /dev/null
+++ b/net-libs/liboping/liboping-1.7.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit base autotools
+
+DESCRIPTION="C library and ncurses based program to generate ICMP echo requests and ping multiple hosts at once"
+HOMEPAGE="http://verplant.org/liboping"
+SRC_URI="http://verplant.org/${PN}/files/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1 GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="perl"
+
+DEPEND="
+ sys-libs/ncurses
+ perl? ( dev-lang/perl )
+"
+RDEPEND=${DEPEND}
+
+PATCHES=( "${FILESDIR}/${PN}-1.6.2-nouidmagic.patch" )
+
+src_prepare() {
+ base_src_prepare
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_with perl perl-bindings INSTALLDIRS=vendor) \
+ --disable-static
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+
+ fperms u+s,og-r /usr/bin/oping
+ fperms u+s,og-r /usr/bin/noping
+}
diff --git a/net-libs/liboping/liboping-1.8.0.ebuild b/net-libs/liboping/liboping-1.8.0.ebuild
new file mode 100644
index 00000000000..0756a417c53
--- /dev/null
+++ b/net-libs/liboping/liboping-1.8.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit base autotools
+
+DESCRIPTION="C library and ncurses based program to generate ICMP echo requests and ping multiple hosts at once"
+HOMEPAGE="http://noping.cc/"
+SRC_URI="http://noping.cc/files/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1 GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="perl"
+
+DEPEND="
+ sys-libs/ncurses
+ perl? ( dev-lang/perl )
+"
+RDEPEND=${DEPEND}
+
+PATCHES=( "${FILESDIR}/${PN}-1.6.2-nouidmagic.patch" )
+
+src_prepare() {
+ base_src_prepare
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_with perl perl-bindings INSTALLDIRS=vendor) \
+ --disable-static
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+
+ fperms u+s,og-r /usr/bin/oping
+ fperms u+s,og-r /usr/bin/noping
+}
diff --git a/net-libs/liboping/metadata.xml b/net-libs/liboping/metadata.xml
new file mode 100644
index 00000000000..62e5578cfa8
--- /dev/null
+++ b/net-libs/liboping/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>proxy-maintainers</herd>
+ <maintainer>
+ <email>bugs@bergstroem.nu</email>
+ <name>Johan Bergström</name>
+ <description>Proxied Maintainer</description>
+ </maintainer>
+</pkgmetadata>