summaryrefslogtreecommitdiff
path: root/net-libs/libzrtpcpp
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-libs/libzrtpcpp
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-libs/libzrtpcpp')
-rw-r--r--net-libs/libzrtpcpp/Manifest2
-rw-r--r--net-libs/libzrtpcpp/libzrtpcpp-2.3.4.ebuild26
-rw-r--r--net-libs/libzrtpcpp/libzrtpcpp-4.2.4.ebuild41
-rw-r--r--net-libs/libzrtpcpp/metadata.xml5
4 files changed, 74 insertions, 0 deletions
diff --git a/net-libs/libzrtpcpp/Manifest b/net-libs/libzrtpcpp/Manifest
new file mode 100644
index 00000000000..350f445054f
--- /dev/null
+++ b/net-libs/libzrtpcpp/Manifest
@@ -0,0 +1,2 @@
+DIST ZRTPCPP-4.2.4.tar.gz 1924579 SHA256 976e24d9e0520fcce77c58c2e1a247988296c517fa980c5abf548f7cd6f06c8d SHA512 cf8ee70891b29b86f252e28f70d546ed150c7c0adcd69f8b3b7b4a6d773f1a6aa7d800fded6dfecb224e1682ea21d3edc8a57a64563b4ac2b300e2dddd594b4a WHIRLPOOL e6f14617a51d3d231a0c60ca12501fbff8256d7d9548a4eca23769efa75ceb86e1da0f7b1b97eaea9584ec175c0d5f596a0c6e001b8cf6ad4372708bd30110e0
+DIST libzrtpcpp-2.3.4.tar.gz 257234 SHA256 03e5d4de487fd154177cf2b7a45600b1c8df783136e4f01a9ebc6104b3771008 SHA512 fbadb826ae26b2729e10d64197c58d545e0e6e7bd9524775cbf4838d2ce3e6ae559932b5c20bb579a3e0cab33abd50251adf129e761cfdcf3fb25347e71ffc36 WHIRLPOOL 9bf31917100605f46242bdc6ab4fc4e7db79f445ceeb23c24b313eb1e010f42b848f1ccbeeedb21a3856cbf9ba1a56091b5e9b272d1c23559bca73ab659babcf
diff --git a/net-libs/libzrtpcpp/libzrtpcpp-2.3.4.ebuild b/net-libs/libzrtpcpp/libzrtpcpp-2.3.4.ebuild
new file mode 100644
index 00000000000..044db2a68f3
--- /dev/null
+++ b/net-libs/libzrtpcpp/libzrtpcpp-2.3.4.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-utils
+
+DESCRIPTION="GNU RTP stack for the zrtp protocol developed by Phil Zimmermann"
+HOMEPAGE="http://www.gnutelephony.org/index.php/GNU_ZRTP"
+SRC_URI="mirror://gnu/ccrtp/${P}.tar.gz"
+KEYWORDS="amd64 ppc ~ppc64 x86"
+LICENSE="GPL-3"
+IUSE=""
+SLOT="0"
+
+RDEPEND=">=net-libs/ccrtp-2
+ >=dev-cpp/commoncpp2-1.5.1
+ || (
+ >=dev-libs/openssl-0.9.8[-bindist]
+ dev-libs/libgcrypt:0=
+ )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS=( AUTHORS README.md )
diff --git a/net-libs/libzrtpcpp/libzrtpcpp-4.2.4.ebuild b/net-libs/libzrtpcpp/libzrtpcpp-4.2.4.ebuild
new file mode 100644
index 00000000000..ccb6256c78b
--- /dev/null
+++ b/net-libs/libzrtpcpp/libzrtpcpp-4.2.4.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-utils
+
+MY_P=ZRTPCPP-${PV}
+
+DESCRIPTION="GNU RTP stack for the zrtp protocol developed by Phil Zimmermann"
+HOMEPAGE="http://www.gnutelephony.org/index.php/GNU_ZRTP"
+# https://github.com/wernerd/ZRTPCPP/releases
+SRC_URI="http://dev.gentoo.org/~mgorny/dist/${MY_P}.tar.gz"
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+LICENSE="GPL-3"
+IUSE="sqlite"
+SLOT="0/4"
+
+RDEPEND="
+ dev-libs/openssl:0=
+ sqlite? ( dev-db/sqlite:3= )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS=( AUTHORS README.md )
+
+S=${WORKDIR}/${MY_P}
+
+src_configure() {
+ # note: building only core since that's what ortp wants
+
+ local mycmakeargs=(
+ -DCORE_LIB=yes
+ -DCRYPTO_STANDALONE=no
+ -DSQLITE=$(usex sqlite)
+ )
+
+ cmake-utils_src_configure
+}
diff --git a/net-libs/libzrtpcpp/metadata.xml b/net-libs/libzrtpcpp/metadata.xml
new file mode 100644
index 00000000000..4538a68724a
--- /dev/null
+++ b/net-libs/libzrtpcpp/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer><email>maintainer-needed@gentoo.org</email></maintainer>
+</pkgmetadata>