summaryrefslogtreecommitdiff
path: root/net-libs/onion
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-06-16 09:47:47 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-06-16 09:54:43 +0200
commit2cd41aa985f9ed17b7d3c365beb4d53650a15522 (patch)
treebff8d5a6e021d7997682076fd1894e265678b0eb /net-libs/onion
parent012da91264e98c69305bc17abc833319e663c9b6 (diff)
downloadgentoo-2cd41aa985f9ed17b7d3c365beb4d53650a15522.tar.gz
gentoo-2cd41aa985f9ed17b7d3c365beb4d53650a15522.tar.xz
net-libs/onion: Fix build with some useflags combination, bug #621864
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'net-libs/onion')
-rw-r--r--net-libs/onion/files/protos.patch28
-rw-r--r--net-libs/onion/onion-0.8.ebuild4
2 files changed, 31 insertions, 1 deletions
diff --git a/net-libs/onion/files/protos.patch b/net-libs/onion/files/protos.patch
new file mode 100644
index 00000000000..59050a95c4e
--- /dev/null
+++ b/net-libs/onion/files/protos.patch
@@ -0,0 +1,28 @@
+Prototypes do not match, fixes some build failures.
+
+Index: onion-0.8/src/onion/poller_libev.c
+===================================================================
+--- onion-0.8.orig/src/onion/poller_libev.c
++++ onion-0.8/src/onion/poller_libev.c
+@@ -75,7 +75,7 @@ void onion_poller_slot_set_timeout(onion
+ el->timeout=timeout_ms;
+ }
+ /// Sets the polling type: read/write/other. O_POLL_READ | O_POLL_WRITE | O_POLL_OTHER
+-void onion_poller_slot_set_type(onion_poller_slot *el, int type){
++void onion_poller_slot_set_type(onion_poller_slot *el, onion_poller_slot_type_e type){
+ el->type=0;
+ if (type&O_POLL_READ)
+ el->type|=EV_READ;
+Index: onion-0.8/src/onion/poller_libevent.c
+===================================================================
+--- onion-0.8.orig/src/onion/poller_libevent.c
++++ onion-0.8/src/onion/poller_libevent.c
+@@ -77,7 +77,7 @@ void onion_poller_slot_set_timeout(onion
+ el->timeout=timeout_ms;
+ }
+ /// Sets the polling type: read/write/other. O_POLL_READ | O_POLL_WRITE | O_POLL_OTHER
+-void onion_poller_slot_set_type(onion_poller_slot *el, int type){
++void onion_poller_slot_set_type(onion_poller_slot *el, onion_poller_slot_type_e type){
+ el->type=EV_PERSIST;
+ if (type&O_POLL_READ)
+ el->type|=EV_READ;
diff --git a/net-libs/onion/onion-0.8.ebuild b/net-libs/onion/onion-0.8.ebuild
index e815359b103..c1b092d0614 100644
--- a/net-libs/onion/onion-0.8.ebuild
+++ b/net-libs/onion/onion-0.8.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -48,6 +48,8 @@ DEPEND="${RDEPEND}
"
REQUIRED_USE="test? ( examples )"
+PATCHES=( "${FILESDIR}/protos.patch" )
+
src_configure() {
use test || echo '' > tests/CMakeLists.txt
local mycmakeargs=(