summaryrefslogtreecommitdiff
path: root/net-libs/rb_libtorrent
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2016-12-10 21:05:44 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2016-12-10 21:08:55 +0000
commit89ff91db7208e01c05a416cd793f1f396c6cf46e (patch)
treeb8ad3f9adad3df07832d576b53903e71405e58c8 /net-libs/rb_libtorrent
parent37c6d491b31628a53a5dc9da98db87a51c410bf4 (diff)
downloadgentoo-89ff91db7208e01c05a416cd793f1f396c6cf46e.tar.gz
gentoo-89ff91db7208e01c05a416cd793f1f396c6cf46e.tar.xz
net-libs/rb_libtorrent: Version bump
Gentoo-Bug: 580760 Package-Manager: portage-2.3.3
Diffstat (limited to 'net-libs/rb_libtorrent')
-rw-r--r--net-libs/rb_libtorrent/Manifest1
-rw-r--r--net-libs/rb_libtorrent/rb_libtorrent-1.1.1.ebuild105
2 files changed, 106 insertions, 0 deletions
diff --git a/net-libs/rb_libtorrent/Manifest b/net-libs/rb_libtorrent/Manifest
index 30fae0518fe..9602799a659 100644
--- a/net-libs/rb_libtorrent/Manifest
+++ b/net-libs/rb_libtorrent/Manifest
@@ -1,3 +1,4 @@
DIST libtorrent-rasterbar-0.16.17.tar.gz 3018881 SHA256 67a1d29c626d991d6e39c2f9828ca70c4053d057070ce01fff9b4ad37e64aff0 SHA512 532b2438e24c3ecad239480a1bd6241a0d73d40f8d5bdcf61ddfcee1a41f1644c9004d4f234968efd50158224219b78852ec936a05b75b15f3442b594460cdd6 WHIRLPOOL 755e201741ed77cf91cb0976cbaa83c645647341d2cfe40564552599f2792ba76bd02e82a94669d80b199f1a1d6290824686d2bb52d6b0da8663d2274176f3eb
DIST libtorrent-rasterbar-0.16.19.tar.gz 3030253 SHA256 9ebd3fa8accfa27d0c81cdbbe15d7b411ea1deec34ac6325dec7197f05d82982 SHA512 8e605802cb1ae80228d253adba44da6f5af39e7d65c59f65e15444ed1122500529ee068f6d3608b1c2a249f18b4de695073f7b67772fa445618757697d779340 WHIRLPOOL 4429d07bd95f398a09f283a7cbcf6611aeb8ac5d2b8ed76d98f89d601aa6ed66e6eb8f044b351fad6cca3606351ccc67081dba7c8dd8d9c3c433eae84aedeb2c
DIST libtorrent-rasterbar-1.0.10.tar.gz 3324494 SHA256 a865ceaca8b14acdd7be56d361ce4e64361299647e157ef7b3ac7e2812ca4c3e SHA512 08976239ec12e2d67a974dadf3f16330f48e4b6de314f9d97c5fbbdbc696b76b6b1f8e20ceab6830d46d17b1bfd7e2fe4048fb1a5a97ece12c242c0cd0f7ded2 WHIRLPOOL 1e4ef2fb41eef0b825bd7c8c665638e3f689c3cefca3caa18a01c328caad9d31cd417fb49d25a7d55da6457a89e35a891427d70fb4f4d070c74be2e2e0347a60
+DIST libtorrent-rasterbar-1.1.1.tar.gz 3641815 SHA256 f70c82367b0980460ef95aff3e117fd4a174477892d529beec434f74d615b31f SHA512 9d2409ee733f7579df61a63e37092d3c59a386b94031bae6a7ea64ffff617131d2c347ba0825b3d337ce2fedad3b527c8f697e3b49cea643d6543c972a1ebc12 WHIRLPOOL 36c4a007e0bf684e9603cd88b594a8ff91193b7d73447375e5651f945dba713c91daf0c625f90af6bb35c2ab017ca69da50d856ac6ce6be2e13f6d04ee7b2e35
diff --git a/net-libs/rb_libtorrent/rb_libtorrent-1.1.1.ebuild b/net-libs/rb_libtorrent/rb_libtorrent-1.1.1.ebuild
new file mode 100644
index 00000000000..2f9612ca4c9
--- /dev/null
+++ b/net-libs/rb_libtorrent/rb_libtorrent-1.1.1.ebuild
@@ -0,0 +1,105 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5} )
+PYTHON_REQ_USE="threads"
+DISTUTILS_OPTIONAL=true
+DISTUTILS_IN_SOURCE_BUILD=true
+
+inherit distutils-r1 eutils versionator
+
+MY_P=libtorrent-rasterbar-${PV} # TODO: rename, bug 576126
+MY_PV=$(replace_all_version_separators _)
+
+DESCRIPTION="C++ BitTorrent implementation focusing on efficiency and scalability"
+HOMEPAGE="http://libtorrent.org"
+SRC_URI="https://github.com/arvidn/libtorrent/releases/download/libtorrent-${MY_PV}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/8"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="debug +dht doc examples libressl python +ssl static-libs test"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="
+ dev-libs/boost:=[threads]
+ virtual/libiconv
+ examples? ( !net-p2p/mldonkey )
+ python? (
+ ${PYTHON_DEPS}
+ dev-libs/boost:=[python,${PYTHON_USEDEP}]
+ )
+ ssl? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:= )
+ )
+"
+DEPEND="${RDEPEND}
+ sys-devel/libtool
+"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ default
+
+ # bug 578026
+ # prepend -L${S}/... to ensure bindings link against the lib we just built
+ sed -i -e "s|^|-L${S}/src/.libs |" bindings/python/compile_flags.in || die
+
+ use python && distutils-r1_src_prepare
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable debug)
+ $(use_enable debug logging)
+ $(use_enable debug disk-stats)
+ $(use_enable dht dht $(usex debug logging yes))
+ $(use_enable examples)
+ $(use_enable ssl encryption)
+ $(use_enable static-libs static)
+ $(use_enable test tests)
+ --with-libiconv
+ )
+ econf "${myeconfargs[@]}"
+
+ if use python; then
+ myeconfargs+=(
+ --enable-python-binding
+ --with-boost-python
+ )
+ python_configure() {
+ econf "${myeconfargs[@]}"
+ }
+ distutils-r1_src_configure
+ fi
+}
+
+src_compile() {
+ default
+
+ python_compile() {
+ cd "${BUILD_DIR}/../bindings/python" || die
+ distutils-r1_python_compile
+ }
+ use python && distutils-r1_src_compile
+}
+
+src_install() {
+ use doc && HTML_DOCS+=( "${S}"/docs )
+
+ default
+
+ python_install() {
+ cd "${BUILD_DIR}/../bindings/python" || die
+ distutils-r1_python_install
+ }
+ use python && distutils-r1_src_install
+
+ prune_libtool_files
+}