summaryrefslogtreecommitdiff
path: root/net-libs
diff options
context:
space:
mode:
authorJonathan Callen <jcallen@gentoo.org>2015-10-08 18:52:30 -0400
committerJonathan Callen <jcallen@gentoo.org>2015-10-08 18:53:08 -0400
commit071e6473715de3bf9e1626bd290ebafaaa3b2310 (patch)
treeaf34b73def2c0f0db09ae410d06ea07984962076 /net-libs
parent84d25886c73dd91c146646f6c96dcda4866bd3c8 (diff)
downloadgentoo-071e6473715de3bf9e1626bd290ebafaaa3b2310.tar.gz
gentoo-071e6473715de3bf9e1626bd290ebafaaa3b2310.tar.xz
net-libs/nodejs: Fix build with USE=-npm
Gentoo-Bug: 562518 Package-Manager: portage-2.2.22
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/nodejs/nodejs-4.1.1.ebuild8
1 files changed, 5 insertions, 3 deletions
diff --git a/net-libs/nodejs/nodejs-4.1.1.ebuild b/net-libs/nodejs/nodejs-4.1.1.ebuild
index af811ba7c96..fb66363b44b 100644
--- a/net-libs/nodejs/nodejs-4.1.1.ebuild
+++ b/net-libs/nodejs/nodejs-4.1.1.ebuild
@@ -119,9 +119,11 @@ src_compile() {
src_install() {
local LIBDIR="${ED}/usr/$(get_libdir)"
emake install DESTDIR="${ED}" PREFIX=/usr
- use npm && dodoc -r "${LIBDIR}"/node_modules/npm/html
- rm -rf "${LIBDIR}"/node_modules/npm/{doc,html} || die
- find "${LIBDIR}"/node_modules -type f -name "LICENSE*" -or -name "LICENCE*" -delete || die
+ if use npm; then
+ dodoc -r "${LIBDIR}"/node_modules/npm/html
+ rm -rf "${LIBDIR}"/node_modules/npm/{doc,html} || die
+ find "${LIBDIR}"/node_modules -type f -name "LICENSE*" -or -name "LICENCE*" -delete || die
+ fi
# set up a symlink structure that npm expects..
dodir /usr/include/node/deps/{v8,uv}