summaryrefslogtreecommitdiff
path: root/net-libs
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2017-05-24 17:53:22 +0200
committerLars Wendler <polynomial-c@gentoo.org>2017-05-24 17:54:41 +0200
commit1c0b686578b2c59cc730f8134565cc7517dace37 (patch)
tree993ad7ff58562b6969cffdcbf6442c5e13acb8b8 /net-libs
parentc9d5d55359c84f800735373bbdaff2d1a0c4f603 (diff)
downloadgentoo-1c0b686578b2c59cc730f8134565cc7517dace37.tar.gz
gentoo-1c0b686578b2c59cc730f8134565cc7517dace37.tar.xz
net-libs/gsoap: Bump to version 2.8.46
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/gsoap/Manifest1
-rw-r--r--net-libs/gsoap/gsoap-2.8.46.ebuild82
2 files changed, 83 insertions, 0 deletions
diff --git a/net-libs/gsoap/Manifest b/net-libs/gsoap/Manifest
index 6200371ded8..59e381949da 100644
--- a/net-libs/gsoap/Manifest
+++ b/net-libs/gsoap/Manifest
@@ -1,2 +1,3 @@
DIST gsoap_2.8.40.zip 36317175 SHA256 54ef56d9c55a6a7a00ae57f8cb0b3266af1b26e623070be2ef20833626157f77 SHA512 fc26899e780a7d797544f21aa7beaabc6c1507b7097c4a229a641e4be763733a40e96ce0d5181024eae19653de9513a5b35d51c8b12e85078423e30d0b898a6f WHIRLPOOL 6f795590a5b1e36d796200e3669b3a2aa45c016aa3acaae6291c09543422530a12e977a159a2f892b328cd7813633f41966432e75fd36268bfe4c6d9d1bb6fbf
DIST gsoap_2.8.45.zip 33590780 SHA256 81946d1ecd99ea414383d5f090e6b292908ff3ac0211cb097a1d1d54e9808bce SHA512 db45f2f8403143387f2860339a77695079fd3224700791846eb436d510a1008fe217c85b61b980340a4982d20ed0fef87dfd8d3de07be9953b627b539ca4af2a WHIRLPOOL 73b2327a05fb065c398573cb70eafc37066c0992787f51eb39e9b0e61193aeaa6f59e608d179c805d3488875dfe538116c512660bf24554811be8ecb8442229b
+DIST gsoap_2.8.46.zip 33607528 SHA256 3083818fb42b9e7251daf21728132db15354eb8c14060c2dc6949dafbec976be SHA512 4750e42cf667334049384a10d925ffc57ebed478a57428753ef8c1c0423c5dc2a20c01e2c5b31fcc08ccb8a0d2ee3eaa4714d318c53dab35ca242a06ea18cf94 WHIRLPOOL c70610a8f1cac734f2907f04e6bfed2d45444b15d2b91ed3359e4dc1bbb1d83f9fd324f3b3a1feee03717428a1766356bc1b23f9f844eb5ce448da4e2ec0b236
diff --git a/net-libs/gsoap/gsoap-2.8.46.ebuild b/net-libs/gsoap/gsoap-2.8.46.ebuild
new file mode 100644
index 00000000000..aef077767cc
--- /dev/null
+++ b/net-libs/gsoap/gsoap-2.8.46.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools eutils
+
+MY_P="${PN}-2.8"
+
+DESCRIPTION="A cross-platform open source C and C++ SDK for SOAP/XML Web services"
+HOMEPAGE="http://gsoap2.sourceforge.net"
+SRC_URI="mirror://sourceforge/gsoap2/gsoap_${PV}.zip"
+
+LICENSE="GPL-2 gSOAP"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc debug examples ipv6 libressl gnutls +ssl"
+
+RDEPEND="
+ sys-libs/zlib
+ gnutls? ( net-libs/gnutls )
+ ssl? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl )
+ )
+"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ sys-devel/flex
+ sys-devel/bison
+"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ default
+
+ # Fix Pre-ISO headers
+ eapply "${FILESDIR}/${PN}-2.7.10-fedora-install_soapcpp2_wsdl2h_aux.patch"
+
+ # enable shared libs https://bugs.gentoo.org/583398
+ eapply "${FILESDIR}/${PN}-2.7.40-shared_libs.patch"
+
+ eautoreconf
+}
+
+src_configure() {
+ local myconf=()
+ use ssl || myconf+=( --disable-ssl )
+ use gnutls && myconf+=( --enable-gnutls )
+ use ipv6 && myconf+=( --enable-ipv6 )
+ econf \
+ ${myconf[@]} \
+ $(use_enable debug) \
+ $(use_enable examples samples)
+}
+
+src_compile() {
+ emake -j1
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ # yes, we also install the license-file since
+ # it contains info about how to apply the licenses
+ dodoc *.txt
+
+ dohtml changelog.md
+
+ prune_libtool_files --all
+
+ if use examples; then
+ rm -rf gsoap/samples/Makefile* gsoap/samples/*/Makefile* gsoap/samples/*/*.o || die
+ insinto /usr/share/doc/${PF}/examples
+ doins -r gsoap/samples/*
+ fi
+
+ if use doc; then
+ dohtml -r gsoap/doc/*
+ fi
+}