summaryrefslogtreecommitdiff
path: root/net-libs
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2015-10-24 06:57:42 +0800
committerIan Delaney <idella4@gentoo.org>2015-10-24 07:00:24 +0800
commit3d39f250ad9121fa4a1265407e0f5abf08871af0 (patch)
tree4534663f65b745e258850feb8e2ff2e83b9795e7 /net-libs
parentfdf06aeabe721bdc11b681729df7c260aaff62ae (diff)
downloadgentoo-3d39f250ad9121fa4a1265407e0f5abf08871af0.tar.gz
gentoo-3d39f250ad9121fa4a1265407e0f5abf08871af0.tar.xz
Revert "net-libs/nodejs: Keyword for ppc+ppc64. Disable tests on both platforms. Fixes bug 562984."
This reverts commit 98e09822dbca21a19966bbf533638205b6bb5fb5.
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/nodejs/nodejs-4.1.1.ebuild11
1 files changed, 2 insertions, 9 deletions
diff --git a/net-libs/nodejs/nodejs-4.1.1.ebuild b/net-libs/nodejs/nodejs-4.1.1.ebuild
index a26da97eafe..6aff4383413 100644
--- a/net-libs/nodejs/nodejs-4.1.1.ebuild
+++ b/net-libs/nodejs/nodejs-4.1.1.ebuild
@@ -28,11 +28,6 @@ DEPEND="${RDEPEND}
S="${WORKDIR}/node-v${PV}"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-# Tests do not pass on both platforms.
-if [[ ${ABI} == "ppc" || ${ABI} == "ppc64" ]]; then
- RESTRICT="test"
-fi
-
pkg_pretend() {
if ! test-flag-CXX -std=c++11 ; then
die "Your compiler doesn't support C++11. Use GCC 4.8, Clang 3.3 or newer."
@@ -92,7 +87,7 @@ src_prepare() {
src_configure() {
local myarch=""
- local myconf=( --shared-openssl --shared-libuv --shared-http-parser --shared-zlib )
+ local myconf+=( --shared-openssl --shared-libuv --shared-http-parser --shared-zlib )
use npm || myconf+=( --without-npm )
use icu && myconf+=( --with-intl=system-icu )
use snapshot && myconf+=( --with-snapshot )
@@ -105,8 +100,6 @@ src_configure() {
x32) myarch="x32";;
arm) myarch="arm";;
arm64) myarch="arm64";;
- ppc) myarch="ppc";;
- ppc64) myarch="ppc64";;
*) die "Unrecognized ARCH ${ARCH}";;
esac
@@ -115,7 +108,7 @@ src_configure() {
linux_use_bundled_gold=0" \
"${PYTHON}" configure \
--prefix="${EPREFIX}"/usr \
- --dest-cpu="${myarch}" \
+ --dest-cpu=${myarch} \
--without-dtrace \
"${myconf[@]}" || die
}