summaryrefslogtreecommitdiff
path: root/net-libs
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2017-05-27 11:55:00 +0200
committerLars Wendler <polynomial-c@gentoo.org>2017-05-27 11:55:44 +0200
commit723ae132fe007214f1c4347c7676f6182dd20f2d (patch)
treea9151ed39c29ec05e77f41575255aad49f6f7791 /net-libs
parentde0cc85ee94346fcddd7c4dc36844fadf3d26892 (diff)
downloadgentoo-723ae132fe007214f1c4347c7676f6182dd20f2d.tar.gz
gentoo-723ae132fe007214f1c4347c7676f6182dd20f2d.tar.xz
net-libs/nghttp2: Bump to version 1.23.0
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/nghttp2/Manifest1
-rw-r--r--net-libs/nghttp2/nghttp2-1.23.0.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/net-libs/nghttp2/Manifest b/net-libs/nghttp2/Manifest
index 86b5a919a4c..a5a54bb210d 100644
--- a/net-libs/nghttp2/Manifest
+++ b/net-libs/nghttp2/Manifest
@@ -2,3 +2,4 @@ DIST nghttp2-1.10.0.tar.gz 2086580 SHA256 192dc031e71e182240079befae9db7e64c9951
DIST nghttp2-1.19.0.tar.gz 2159530 SHA256 b67946ad211aa3f7c91f4d866f47b056e821da8e31ab4636130d59be87f53016 SHA512 50f45082f725c237a0e1d25af57992b9cded6c9b68f0aa95c44c16eb4448e05b14e06c853032924d03034115286163de0ad684827cfa5d70896656868fdb4e01 WHIRLPOOL d6178a31aadfcfc3547ab4b0f58ba8f5b34a95ebc1168b7f03b4bfba58a03737b061eea020c264a2da882f0f6541620cd001e62919b82f5b1ada552402c2fab0
DIST nghttp2-1.21.1.tar.gz 2167306 SHA256 4d575f872fe91bf45c424d93b5b566728d6250b5c7af4ffd7753c52cbac9e609 SHA512 d5bee6c76aee337ecd48563ad1530f15da52496a13cce97b986632258f03173d0c2f1b181e8f90765c6810e41c08f672a8bc81125c2762d186d0da388fb54a92 WHIRLPOOL 1ac14456c0ee520257dc475e76182919fe2abd3bfae39adc60d05ecc5efb4d49abcb60dae92f9cc73eb401b715a794eb1b86be4082dbd1955c2c6d45ae2a4c8f
DIST nghttp2-1.22.0.tar.gz 2176030 SHA256 f4b5f3afdad69ea2b2542bc998128e2d02a33c40e53e60fd814788518b56b13f SHA512 e439e4b2b06a8bfef80d1d963d70612b13eaf613e2be78537971e867fd82f222e5457533dee540c5239e00ee78ca8c1efbaccf8cdeacd1c46b58f89ee5ecf327 WHIRLPOOL 4d493e5ef129432ce17110279178dda9d0cf1aaa4df82a05084ae052d3fe21342aadcac46fb9c52434f6e3325c99d2750b57a47d7c11292eda2b09f15669d927
+DIST nghttp2-1.23.0.tar.gz 2178667 SHA256 90627fb05a7047f86a7e2c360b3d3d564119a589928ff741201ed1a65316a84b SHA512 6e43d525af5af0389e44bf4b6f4f18fbfe85e5a7f679859e45cc04de1fe6defddc1cb241aa127b1e6a40efb79f471e42f68c1052edac9c19991af294d3e69dc7 WHIRLPOOL c404d1aa4b6858b046e75ff438f2c1caf2de49e6609d1e05accb50cb89281c877024bb3198bdbe7f92daac4af703f6102f12b17554868de992ee58e0f11a17fc
diff --git a/net-libs/nghttp2/nghttp2-1.23.0.ebuild b/net-libs/nghttp2/nghttp2-1.23.0.ebuild
new file mode 100644
index 00000000000..3ec4b994bb7
--- /dev/null
+++ b/net-libs/nghttp2/nghttp2-1.23.0.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+# TODO: Add python support.
+
+EAPI=6
+
+inherit multilib-minimal
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/tatsuhiro-t/nghttp2.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/tatsuhiro-t/nghttp2/releases/download/v${PV}/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+fi
+
+DESCRIPTION="HTTP/2 C Library"
+HOMEPAGE="https://nghttp2.org/"
+
+LICENSE="MIT"
+SLOT="0/1.14" # <C++>.<C> SONAMEs
+IUSE="cxx debug hpack-tools jemalloc libressl static-libs test +threads utils xml"
+
+RDEPEND="
+ cxx? ( dev-libs/boost:=[${MULTILIB_USEDEP},threads] )
+ hpack-tools? ( >=dev-libs/jansson-2.5 )
+ jemalloc? ( dev-libs/jemalloc[${MULTILIB_USEDEP}] )
+ utils? (
+ >=dev-libs/libev-4.15[${MULTILIB_USEDEP}]
+ !libressl? ( >=dev-libs/openssl-1.0.2:0[-bindist,${MULTILIB_USEDEP}] )
+ libressl? ( dev-libs/libressl[${MULTILIB_USEDEP}] )
+ >=sys-libs/zlib-1.2.3[${MULTILIB_USEDEP}]
+ net-dns/c-ares:=[${MULTILIB_USEDEP}]
+ )
+ xml? ( >=dev-libs/libxml2-2.7.7:2[${MULTILIB_USEDEP}] )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ test? ( >=dev-util/cunit-2.1[${MULTILIB_USEDEP}] )"
+
+multilib_src_configure() {
+ ECONF_SOURCE=${S} \
+ econf \
+ --disable-examples \
+ --disable-failmalloc \
+ --disable-werror \
+ --without-cython \
+ --disable-python-bindings \
+ --without-spdylay \
+ $(use_enable cxx asio-lib) \
+ $(use_enable debug) \
+ $(multilib_native_use_enable hpack-tools) \
+ $(use_enable static-libs static) \
+ $(use_enable threads) \
+ $(multilib_native_use_enable utils app) \
+ $(multilib_native_use_with jemalloc) \
+ $(multilib_native_use_with xml libxml2)
+}
+
+multilib_src_install_all() {
+ use static-libs || find "${ED}"/usr -name '*.la' -delete
+}