summaryrefslogtreecommitdiff
path: root/net-libs
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2015-10-23 04:12:29 -0700
committerPatrice Clement <monsieurp@gentoo.org>2015-10-23 04:13:44 -0700
commit98e09822dbca21a19966bbf533638205b6bb5fb5 (patch)
treee1c8a09ef03c548c34d7a0a7a583b40f9a450798 /net-libs
parent10df61505856da197cac35574d74a09d6dd389fa (diff)
downloadgentoo-98e09822dbca21a19966bbf533638205b6bb5fb5.tar.gz
gentoo-98e09822dbca21a19966bbf533638205b6bb5fb5.tar.xz
net-libs/nodejs: Keyword for ppc+ppc64. Disable tests on both platforms. Fixes bug 562984.
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/nodejs/nodejs-4.1.1.ebuild11
1 files changed, 9 insertions, 2 deletions
diff --git a/net-libs/nodejs/nodejs-4.1.1.ebuild b/net-libs/nodejs/nodejs-4.1.1.ebuild
index 6aff4383413..a26da97eafe 100644
--- a/net-libs/nodejs/nodejs-4.1.1.ebuild
+++ b/net-libs/nodejs/nodejs-4.1.1.ebuild
@@ -28,6 +28,11 @@ DEPEND="${RDEPEND}
S="${WORKDIR}/node-v${PV}"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+# Tests do not pass on both platforms.
+if [[ ${ABI} == "ppc" || ${ABI} == "ppc64" ]]; then
+ RESTRICT="test"
+fi
+
pkg_pretend() {
if ! test-flag-CXX -std=c++11 ; then
die "Your compiler doesn't support C++11. Use GCC 4.8, Clang 3.3 or newer."
@@ -87,7 +92,7 @@ src_prepare() {
src_configure() {
local myarch=""
- local myconf+=( --shared-openssl --shared-libuv --shared-http-parser --shared-zlib )
+ local myconf=( --shared-openssl --shared-libuv --shared-http-parser --shared-zlib )
use npm || myconf+=( --without-npm )
use icu && myconf+=( --with-intl=system-icu )
use snapshot && myconf+=( --with-snapshot )
@@ -100,6 +105,8 @@ src_configure() {
x32) myarch="x32";;
arm) myarch="arm";;
arm64) myarch="arm64";;
+ ppc) myarch="ppc";;
+ ppc64) myarch="ppc64";;
*) die "Unrecognized ARCH ${ARCH}";;
esac
@@ -108,7 +115,7 @@ src_configure() {
linux_use_bundled_gold=0" \
"${PYTHON}" configure \
--prefix="${EPREFIX}"/usr \
- --dest-cpu=${myarch} \
+ --dest-cpu="${myarch}" \
--without-dtrace \
"${myconf[@]}" || die
}