summaryrefslogtreecommitdiff
path: root/net-libs
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2016-08-22 23:00:24 -0400
committerMike Gilbert <floppym@gentoo.org>2016-08-22 23:00:24 -0400
commitb12421a4c6f4f3599b1f09bf553c724a811f885f (patch)
treed22af19035fdbf303a67d5e3b5c0ae530539accc /net-libs
parent5f8802bc9b7a1d3697ee6483a55d140a2438e15f (diff)
downloadgentoo-b12421a4c6f4f3599b1f09bf553c724a811f885f.tar.gz
gentoo-b12421a4c6f4f3599b1f09bf553c724a811f885f.tar.xz
net-libs/zeromq: fix 4.1.5
The previous revision only installed manpages. Bump EAPI and drop autotools-utils while we are at it. Also depend on asciidoc and xmlto. Package-Manager: portage-2.3.0_p16
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/zeromq/zeromq-4.1.5-r1.ebuild (renamed from net-libs/zeromq/zeromq-4.1.5.ebuild)22
1 files changed, 11 insertions, 11 deletions
diff --git a/net-libs/zeromq/zeromq-4.1.5.ebuild b/net-libs/zeromq/zeromq-4.1.5-r1.ebuild
index f48bffb4ce6..6dc347309e2 100644
--- a/net-libs/zeromq/zeromq-4.1.5.ebuild
+++ b/net-libs/zeromq/zeromq-4.1.5-r1.ebuild
@@ -2,11 +2,9 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
-AUTOTOOLS_AUTORECONF=true
-
-inherit autotools-utils
+inherit autotools eutils
DESCRIPTION="A brokerless kernel"
HOMEPAGE="http://www.zeromq.org/"
@@ -21,6 +19,8 @@ RDEPEND="
dev-libs/libsodium:=
pgm? ( =net-libs/openpgm-5.2.122 )"
DEPEND="${RDEPEND}
+ app-text/asciidoc
+ app-text/xmlto
sys-apps/util-linux
pgm? ( virtual/pkgconfig )"
@@ -28,22 +28,22 @@ src_prepare() {
sed \
-e '/libzmq_werror=/s:yes:no:g' \
-i configure.ac || die
- autotools-utils_src_prepare
+ default
+ eautoreconf
}
src_configure() {
local myeconfargs=(
+ --enable-shared
+ $(use_enable static-libs static)
--with-relaxed
--with-libsodium
$(use_with pgm)
)
- autotools-utils_src_configure
-}
-
-src_test() {
- autotools-utils_src_test -j1
+ econf "${myeconfargs[@]}"
}
src_install() {
- doman "${BUILD_DIR}"/doc/*.[1-9]
+ default
+ prune_libtool_files
}