summaryrefslogtreecommitdiff
path: root/net-libs
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2016-08-27 18:41:16 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2016-08-27 21:20:23 +0100
commitbfe97a5ba14edaafe8694f6a74aa026506eacc68 (patch)
treea66d7d7f0becceea0e513f08a1eba0e1b219d058 /net-libs
parent61f9f50f85a35b9d4066d65cf48eda33a51d2749 (diff)
downloadgentoo-bfe97a5ba14edaafe8694f6a74aa026506eacc68.tar.gz
gentoo-bfe97a5ba14edaafe8694f6a74aa026506eacc68.tar.xz
net-libs/webkit-gtk: tweak for gcc-6, bug #592048
Adopt Fedora patch to build successfully against gcc-6.1.0. Bug: https://bugs.gentoo.org/show_bug.cgi?id=592048 Bug: https://bugs.webkit.org/show_bug.cgi?id=159124 Package-Manager: portage-2.3.0
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/webkit-gtk/files/webkit-gtk-2.4.9-gcc-6.patch29
-rw-r--r--net-libs/webkit-gtk/webkit-gtk-2.4.11-r1.ebuild3
-rw-r--r--net-libs/webkit-gtk/webkit-gtk-2.4.11-r200.ebuild3
-rw-r--r--net-libs/webkit-gtk/webkit-gtk-2.4.11.ebuild3
4 files changed, 38 insertions, 0 deletions
diff --git a/net-libs/webkit-gtk/files/webkit-gtk-2.4.9-gcc-6.patch b/net-libs/webkit-gtk/files/webkit-gtk-2.4.9-gcc-6.patch
new file mode 100644
index 00000000000..bd8507cdb01
--- /dev/null
+++ b/net-libs/webkit-gtk/files/webkit-gtk-2.4.9-gcc-6.patch
@@ -0,0 +1,29 @@
+Fedora patch fixes build failure for gcc-6 (abs/fabs ambifuity)
+https://bugs.webkit.org/show_bug.cgi?id=159124#c1
+https://bugs.gentoo.org/show_bug.cgi?id=592048
+diff -Nur webkitgtk-2.4.9.orig/Source/WebCore/platform/gtk/GtkClickCounter.cpp webkitgtk-2.4.9/Source/WebCore/platform/gtk/GtkClickCounter.cpp
+--- webkitgtk-2.4.9.orig/Source/WebCore/platform/gtk/GtkClickCounter.cpp 2015-05-20 03:03:24.000000000 -0600
++++ webkitgtk-2.4.9/Source/WebCore/platform/gtk/GtkClickCounter.cpp 2016-02-07 11:30:42.392686308 -0700
+@@ -85,8 +85,8 @@
+ guint32 eventTime = getEventTime(event);
+
+ if ((event->type == GDK_2BUTTON_PRESS || event->type == GDK_3BUTTON_PRESS)
+- || ((abs(buttonEvent->x - m_previousClickPoint.x()) < doubleClickDistance)
+- && (abs(buttonEvent->y - m_previousClickPoint.y()) < doubleClickDistance)
++ || ((fabs(buttonEvent->x - m_previousClickPoint.x()) < doubleClickDistance)
++ && (fabs(buttonEvent->y - m_previousClickPoint.y()) < doubleClickDistance)
+ && (eventTime - m_previousClickTime < static_cast<guint>(doubleClickTime))
+ && (buttonEvent->button == m_previousClickButton)))
+ m_currentClickCount++;
+diff -Nur webkitgtk-2.4.9.orig/Source/WebCore/platform/gtk/LocalizedStringsGtk.cpp webkitgtk-2.4.9/Source/WebCore/platform/gtk/LocalizedStringsGtk.cpp
+--- webkitgtk-2.4.9.orig/Source/WebCore/platform/gtk/LocalizedStringsGtk.cpp 2015-05-20 03:03:24.000000000 -0600
++++ webkitgtk-2.4.9/Source/WebCore/platform/gtk/LocalizedStringsGtk.cpp 2016-02-07 11:49:36.384691005 -0700
+@@ -659,7 +659,7 @@
+ if (!std::isfinite(time))
+ return String::fromUTF8(_("indefinite time"));
+
+- int seconds = static_cast<int>(abs(time));
++ int seconds = static_cast<int>(fabs(time));
+ int days = seconds / (60 * 60 * 24);
+ int hours = seconds / (60 * 60);
+ int minutes = (seconds / 60) % 60;
diff --git a/net-libs/webkit-gtk/webkit-gtk-2.4.11-r1.ebuild b/net-libs/webkit-gtk/webkit-gtk-2.4.11-r1.ebuild
index cb799d5d976..19135857b22 100644
--- a/net-libs/webkit-gtk/webkit-gtk-2.4.11-r1.ebuild
+++ b/net-libs/webkit-gtk/webkit-gtk-2.4.11-r1.ebuild
@@ -173,6 +173,9 @@ src_prepare() {
# https://bugs.webkit.org/show_bug.cgi?id=156510
eapply "${FILESDIR}"/${PN}-2.4.11-video-web-audio.patch
+ # https://bugs.webkit.org/show_bug.cgi?id=159124#c1
+ eapply "${FILESDIR}"/${PN}-2.4.9-gcc-6.patch
+
AT_M4DIR=Source/autotools eautoreconf
gnome2_src_prepare
diff --git a/net-libs/webkit-gtk/webkit-gtk-2.4.11-r200.ebuild b/net-libs/webkit-gtk/webkit-gtk-2.4.11-r200.ebuild
index 10f845a5af0..a92c6b1baa4 100644
--- a/net-libs/webkit-gtk/webkit-gtk-2.4.11-r200.ebuild
+++ b/net-libs/webkit-gtk/webkit-gtk-2.4.11-r200.ebuild
@@ -158,6 +158,9 @@ src_prepare() {
# https://bugs.webkit.org/show_bug.cgi?id=156510
eapply "${FILESDIR}"/${PN}-2.4.11-video-web-audio.patch
+ # https://bugs.webkit.org/show_bug.cgi?id=159124#c1
+ eapply "${FILESDIR}"/${PN}-2.4.9-gcc-6.patch
+
AT_M4DIR=Source/autotools eautoreconf
gnome2_src_prepare
diff --git a/net-libs/webkit-gtk/webkit-gtk-2.4.11.ebuild b/net-libs/webkit-gtk/webkit-gtk-2.4.11.ebuild
index 2ffe8b292bc..481850b1e9a 100644
--- a/net-libs/webkit-gtk/webkit-gtk-2.4.11.ebuild
+++ b/net-libs/webkit-gtk/webkit-gtk-2.4.11.ebuild
@@ -171,6 +171,9 @@ src_prepare() {
# https://bugs.webkit.org/show_bug.cgi?id=156510
eapply "${FILESDIR}"/${PN}-2.4.11-video-web-audio.patch
+ # https://bugs.webkit.org/show_bug.cgi?id=159124#c1
+ eapply "${FILESDIR}"/${PN}-2.4.9-gcc-6.patch
+
AT_M4DIR=Source/autotools eautoreconf
gnome2_src_prepare