summaryrefslogtreecommitdiff
path: root/net-libs
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2015-10-05 16:17:28 +0200
committerJulian Ospald <hasufell@gentoo.org>2015-10-05 16:28:25 +0200
commitf0915e35abdc413f740957a423413c607d1ee431 (patch)
treeee2862be8e0ba0d3bac0401da62bc87da9608c86 /net-libs
parentc5f2e1f80f4f1744a6009673f934694ae91f1b03 (diff)
downloadgentoo-f0915e35abdc413f740957a423413c607d1ee431.tar.gz
gentoo-f0915e35abdc413f740957a423413c607d1ee431.tar.xz
net-libs/openslp: add libressl support
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/openslp/openslp-2.0.0-r1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/net-libs/openslp/openslp-2.0.0-r1.ebuild b/net-libs/openslp/openslp-2.0.0-r1.ebuild
new file mode 100644
index 00000000000..e4f8d64cd7f
--- /dev/null
+++ b/net-libs/openslp/openslp-2.0.0-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils autotools systemd
+
+DESCRIPTION="An open-source implementation of Service Location Protocol"
+HOMEPAGE="http://www.openslp.org/"
+SRC_URI="mirror://sourceforge/openslp/${P}.tar.gz"
+
+LICENSE="BSD GPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE="libressl"
+RESTRICT="test"
+
+DEPEND="
+ !libressl? ( dev-libs/openssl:0 )
+ libressl? ( dev-libs/libressl )
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-2.0.0-cflags.patch
+ eautoreconf
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS FAQ ChangeLog NEWS README* THANKS
+ rm -rfv "${D}"/usr/doc
+ dohtml -r .
+ newinitd "${FILESDIR}"/slpd-init slpd
+ systemd_dounit "${FILESDIR}"/slpd.service
+}