summaryrefslogtreecommitdiff
path: root/net-mail/Freemail
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-mail/Freemail
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-mail/Freemail')
-rw-r--r--net-mail/Freemail/Freemail-9999.ebuild52
-rw-r--r--net-mail/Freemail/files/build.patch68
-rw-r--r--net-mail/Freemail/metadata.xml9
3 files changed, 129 insertions, 0 deletions
diff --git a/net-mail/Freemail/Freemail-9999.ebuild b/net-mail/Freemail/Freemail-9999.ebuild
new file mode 100644
index 00000000000..f200d9739eb
--- /dev/null
+++ b/net-mail/Freemail/Freemail-9999.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+EGIT_REPO_URI="git://github.com/freenet/plugin-Freemail-official.git
+ https://github.com/freenet/plugin-Freemail-official.git"
+EGIT_PROJECT="Freemail/official"
+EANT_BUILD_TARGET="dist"
+inherit eutils git-2 java-pkg-2 java-ant-2
+
+DESCRIPTION="Anonymous IMAP/SMTP e-mail server over Freenet"
+HOMEPAGE="http://www.freenetproject.org/tools.html"
+SRC_URI=""
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+CDEPEND="dev-java/bcprov:0
+ net-p2p/freenet"
+DEPEND="${CDEPEND}
+ >=virtual/jdk-1.5"
+RDEPEND="${CDEPEND}
+ >=virtual/jre-1.5"
+
+EANT_GENTOO_CLASSPATH="bcprov freenet"
+src_prepare() {
+ epatch "${FILESDIR}"/build.patch
+ java-ant_rewrite-classpath
+}
+
+src_install() {
+ java-pkg_dojar dist/Freemail.jar
+ dodir /var/freenet/plugins
+ fperms freenet:freenet /var/freenet/plugins
+ dodoc README || die "installation of documentation failed"
+}
+
+pkg_postinst () {
+ #force chmod for previously existing plugins dir owned by root
+ [[ $(stat --format="%U" /var/freenet/plugins) == "freenet" ]] || chown \
+ freenet:freenet /var/freenet/plugins
+ elog "To load Freemail, go to the plugin page of freenet and enter at"
+ elog "Plugin-URL: /usr/share/Freemail/lib/Freemail.jar"
+ elog " This should load the Freemail plugin."
+ elog "Set your email client to IMAP port 3143 and SMTP port 3025 on localhost."
+ elog "To bind freemail to different ports, or to a different freenet node, edit"
+ elog "/var/freenet/globalconfig."
+}
diff --git a/net-mail/Freemail/files/build.patch b/net-mail/Freemail/files/build.patch
new file mode 100644
index 00000000000..3fef282f74a
--- /dev/null
+++ b/net-mail/Freemail/files/build.patch
@@ -0,0 +1,68 @@
+--- build.xml 2009-06-26 16:46:58.829728329 +0200
++++ build.xml.new 2009-06-26 16:48:44.654930593 +0200
+@@ -5,64 +5,7 @@
+ <property name="build" location="build"/>
+ <property name="lib" location="lib"/>
+ <property name="dist" location="dist"/>
+- <property name="deps" location="deps"/>
+-
+- <property name="bcdist" value="lcrypto-jdk14-138"/>
+- <property name="freenetjarurl.url" value="http://downloads.freenetproject.org/alpha/freenet-testing-latest.jar.url"/>
+- <property name="freenetjarurl.localpath" value="${deps}/freenet-testing-latest.jar.url"/>
+- <property name="freenetjar" value="freenet-main.jar"/>
+-
+- <target name="freenetjar-check">
+- <available file="${deps}/${freenetjar}" property="freenetjar.present" />
+- </target>
+-
+- <!-- Fetching the Freenet jar here is far from optimal:
+- Ideally we'd compile against a the freenet jar or class files
+- which the user almost certainly has on their computer already.
+- Unfortunately about the only sensible way of doing this would
+- be with Maven2, and both Freenet and Freemail import code from
+- other projects which would make things difficult and/or ugly.
+- -->
+- <target name="freenetjar-fetch" depends="freenetjar-check" unless="freenetjar.present">
+- <echo>
+- Attempting to fetch Freenet main jar - ant cannot do this reliably, so if it fails, delete ${deps}/${freenetjar} and ${freenetjarurl.localpath} and run ant again.
+- </echo>
+- <mkdir dir="${deps}" />
+- <!-- loadresource directly from an HTTP URL is causing problems -->
+- <get src="${freenetjarurl.url}"
+- dest="${freenetjarurl.localpath}" />
+- <loadfile property="freenetjar.url"
+- srcFile="${freenetjarurl.localpath}" />
+- <get src="${freenetjar.url}"
+- dest="${deps}/${freenetjar}"
+- verbose="true" />
+- </target>
+-
+- <target name="bouncycastle-check">
+- <available file="${deps}/${bcdist}" property="bouncycastle-dist.present" />
+- <available file="${build}/org/bouncycastle" property="bouncycastle-bin.present" />
+- </target>
+-
+- <target name="bouncycastle-fetch" depends="bouncycastle-check" unless="bouncycastle-dist.present">
+- <mkdir dir="${deps}" />
+- <get src="http://www.bouncycastle.org/download/${bcdist}.zip"
+- dest="${deps}/${bcdist}.zip"
+- verbose="true"
+- usetimestamp="true" />
+-
+- <unzip src="${deps}/${bcdist}.zip" dest="${deps}" />
+- </target>
+-
+- <target name="bouncycastle-compile" depends="bouncycastle-fetch" unless="bouncycastle-bin.present">
+- <mkdir dir="build" />
+- <javac srcdir="${deps}/${bcdist}/src" destdir="${build}" debug="on" optimize="on" source="1.4" nowarn="true">
+- <exclude name="**/test/*" />
+- <exclude name="org/bouncycastle/util/IPTest.java" />
+- <exclude name="org/bouncycastle/util/AllTests.java" />
+- </javac>
+- </target>
+-
+- <target name="compile" depends="bouncycastle-compile, freenetjar-fetch">
++ <target name="compile">
+ <mkdir dir="${build}"/>
+
+ <tstamp/>
diff --git a/net-mail/Freemail/metadata.xml b/net-mail/Freemail/metadata.xml
new file mode 100644
index 00000000000..fed3658eec5
--- /dev/null
+++ b/net-mail/Freemail/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>tommy@gentoo.org</email>
+ <name>Thomas Sachau (Tommy[D])</name>
+ </maintainer>
+</pkgmetadata>
+