summaryrefslogtreecommitdiff
path: root/net-mail/checkpassword
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-mail/checkpassword
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-mail/checkpassword')
-rw-r--r--net-mail/checkpassword/Manifest1
-rw-r--r--net-mail/checkpassword/checkpassword-0.90-r2.ebuild36
-rw-r--r--net-mail/checkpassword/checkpassword-0.90-r3.ebuild38
-rw-r--r--net-mail/checkpassword/files/0.90-errno.patch11
-rw-r--r--net-mail/checkpassword/files/0.90-exit.patch10
-rw-r--r--net-mail/checkpassword/files/0.90-head-1.patch39
-rw-r--r--net-mail/checkpassword/metadata.xml9
7 files changed, 144 insertions, 0 deletions
diff --git a/net-mail/checkpassword/Manifest b/net-mail/checkpassword/Manifest
new file mode 100644
index 00000000000..932301dfb54
--- /dev/null
+++ b/net-mail/checkpassword/Manifest
@@ -0,0 +1 @@
+DIST checkpassword-0.90.tar.gz 15631 SHA256 74300364b6be26be08e34f768532e911789827179e680bc89db3525fe415762f SHA512 301d574c9f2c4c7fef6afb98818f424a43f644e456c6268234e73da898710b0f4b6797a80d240c270c5319398574349bedf6a2c9757e432f293f85ec8c01f51f WHIRLPOOL 7810b7de0006793f33a97b7c022e56c5e1d5a63a4124df83c6d0fc8c3a5e0ec165dcb1f4b29b2bc380f94eae25dc7df5b1daece8f8374528dd11776bf745c369
diff --git a/net-mail/checkpassword/checkpassword-0.90-r2.ebuild b/net-mail/checkpassword/checkpassword-0.90-r2.ebuild
new file mode 100644
index 00000000000..bd8b5b7f309
--- /dev/null
+++ b/net-mail/checkpassword/checkpassword-0.90-r2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils toolchain-funcs flag-o-matic
+
+DESCRIPTION="A uniform password checking interface for root applications"
+HOMEPAGE="http://cr.yp.to/checkpwd.html"
+SRC_URI="http://cr.yp.to/checkpwd/${P}.tar.gz"
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86"
+IUSE="static"
+RESTRICT="mirror bindist"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PV}-errno.patch
+ epatch "${FILESDIR}"/${PV}-head-1.patch
+
+ use static && append-ldflags -static
+}
+
+src_compile() {
+ echo "$(tc-getCC) ${CFLAGS}" > conf-cc
+ echo "$(tc-getCC) ${LDFLAGS}" > conf-ld
+ make || die "Error in make"
+}
+
+src_install() {
+ into /
+ dobin checkpassword || die
+ dodoc CHANGES README TODO VERSION FILES SYSDEPS TARGETS
+}
diff --git a/net-mail/checkpassword/checkpassword-0.90-r3.ebuild b/net-mail/checkpassword/checkpassword-0.90-r3.ebuild
new file mode 100644
index 00000000000..4840d1f6b5c
--- /dev/null
+++ b/net-mail/checkpassword/checkpassword-0.90-r3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils fixheadtails flag-o-matic qmail
+
+DESCRIPTION="A uniform password checking interface for root applications"
+HOMEPAGE="http://cr.yp.to/checkpwd.html"
+SRC_URI="http://cr.yp.to/checkpwd/${P}.tar.gz"
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="static"
+RESTRICT="mirror bindist"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${PV}-errno.patch
+ epatch "${FILESDIR}"/${PV}-exit.patch
+
+ ht_fix_file Makefile print-cc.sh
+
+ use static && append-ldflags -static
+}
+
+src_compile() {
+ qmail_set_cc
+ make || die
+}
+
+src_install() {
+ into /
+ dobin checkpassword || die
+ dodoc CHANGES README TODO VERSION FILES SYSDEPS TARGETS
+}
diff --git a/net-mail/checkpassword/files/0.90-errno.patch b/net-mail/checkpassword/files/0.90-errno.patch
new file mode 100644
index 00000000000..9cf40c689c1
--- /dev/null
+++ b/net-mail/checkpassword/files/0.90-errno.patch
@@ -0,0 +1,11 @@
+--- error.h.orig 2003-03-05 15:48:54.000000000 -0500
++++ error.h 2003-03-05 15:49:08.000000000 -0500
+@@ -1,7 +1,7 @@
+ #ifndef ERROR_H
+ #define ERROR_H
+
+-extern int errno;
++#include <errno.h>
+
+ extern int error_intr;
+ extern int error_nomem;
diff --git a/net-mail/checkpassword/files/0.90-exit.patch b/net-mail/checkpassword/files/0.90-exit.patch
new file mode 100644
index 00000000000..e8e4d2d1fc1
--- /dev/null
+++ b/net-mail/checkpassword/files/0.90-exit.patch
@@ -0,0 +1,10 @@
+Index: checkpassword-0.90/checkpassword.c
+===================================================================
+--- checkpassword-0.90.orig/checkpassword.c
++++ checkpassword-0.90/checkpassword.c
+@@ -1,3 +1,5 @@
++#include <unistd.h>
++
+ #include "error.h"
+ #include "pathexec.h"
+ #include "prot.h"
diff --git a/net-mail/checkpassword/files/0.90-head-1.patch b/net-mail/checkpassword/files/0.90-head-1.patch
new file mode 100644
index 00000000000..08e54297de4
--- /dev/null
+++ b/net-mail/checkpassword/files/0.90-head-1.patch
@@ -0,0 +1,39 @@
+diff -ur checkpassword-0.90.orig/Makefile checkpassword-0.90/Makefile
+--- checkpassword-0.90.orig/Makefile 2003-09-03 12:06:23.225291952 -0400
++++ checkpassword-0.90/Makefile 2003-09-03 12:06:29.578326144 -0400
+@@ -22,7 +22,7 @@
+
+ auto_home.c: \
+ auto-str conf-home
+- ./auto-str auto_home `head -1 conf-home` > auto_home.c
++ ./auto-str auto_home `head -n 1 conf-home` > auto_home.c
+
+ auto_home.o: \
+ compile auto_home.c
+@@ -91,7 +91,7 @@
+ choose: \
+ warn-auto.sh choose.sh conf-home
+ cat warn-auto.sh choose.sh \
+- | sed s}HOME}"`head -1 conf-home`"}g \
++ | sed s}HOME}"`head -n 1 conf-home`"}g \
+ > choose
+ chmod 755 choose
+
+@@ -166,7 +166,7 @@
+ warn-auto.sh conf-ld
+ ( cat warn-auto.sh; \
+ echo 'main="$$1"; shift'; \
+- echo exec "`head -1 conf-ld`" \
++ echo exec "`head -n 1 conf-ld`" \
+ '-o "$$main" "$$main".o $${1+"$$@"}' \
+ ) > load
+ chmod 755 load
+diff -ur checkpassword-0.90.orig/print-cc.sh checkpassword-0.90/print-cc.sh
+--- checkpassword-0.90.orig/print-cc.sh 2003-09-03 12:06:23.227291648 -0400
++++ checkpassword-0.90/print-cc.sh 2003-09-03 12:06:34.308607032 -0400
+@@ -1,4 +1,4 @@
+-cc="`head -1 conf-cc`"
++cc="`head -n 1 conf-cc`"
+ systype="`cat systype`"
+
+ cat warn-auto.sh
diff --git a/net-mail/checkpassword/metadata.xml b/net-mail/checkpassword/metadata.xml
new file mode 100644
index 00000000000..89dcd746873
--- /dev/null
+++ b/net-mail/checkpassword/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>net-mail</herd>
+ <maintainer>
+ <email>robbat2@gentoo.org</email>
+ <name>Robin H. Johnson</name>
+ </maintainer>
+</pkgmetadata>