summaryrefslogtreecommitdiff
path: root/net-misc/arpd/files
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-misc/arpd/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-misc/arpd/files')
-rw-r--r--net-misc/arpd/files/arpd-0.2-buildsystem-libevent-test.patch11
-rw-r--r--net-misc/arpd/files/arpd-0.2-libevent.patch28
-rw-r--r--net-misc/arpd/files/arpd.c.patch42
3 files changed, 81 insertions, 0 deletions
diff --git a/net-misc/arpd/files/arpd-0.2-buildsystem-libevent-test.patch b/net-misc/arpd/files/arpd-0.2-buildsystem-libevent-test.patch
new file mode 100644
index 00000000000..c0c0f47712a
--- /dev/null
+++ b/net-misc/arpd/files/arpd-0.2-buildsystem-libevent-test.patch
@@ -0,0 +1,11 @@
+--- configure.in.orig 2003-02-09 19:30:33.000000000 +0100
++++ configure.in 2010-09-17 00:33:36.138294836 +0200
+@@ -62,7 +62,7 @@
+ ;;
+ *)
+ AC_MSG_RESULT($withval)
+- if test -f $withval/include/event.h -a -f $withval/lib/libevent.a; then
++ if test -f $withval/include/event.h -a -f $withval/lib/libevent.so; then
+ owd=`pwd`
+ if cd $withval; then withval=`pwd`; cd $owd; fi
+ EVENTINC="-I$withval/include"
diff --git a/net-misc/arpd/files/arpd-0.2-libevent.patch b/net-misc/arpd/files/arpd-0.2-libevent.patch
new file mode 100644
index 00000000000..2d5998f8c8d
--- /dev/null
+++ b/net-misc/arpd/files/arpd-0.2-libevent.patch
@@ -0,0 +1,28 @@
+--- arpd.orig/arpd.c 2010-02-03 20:03:07.098748175 +0100
++++ arpd/arpd.c 2010-02-03 20:06:24.469749941 +0100
+@@ -445,9 +445,6 @@
+ void
+ terminate_handler(int sig)
+ {
+- extern int event_gotsig;
+-
+- event_gotsig = 1;
+ arpd_sig = sig;
+ }
+
+@@ -464,7 +461,6 @@
+ main(int argc, char *argv[])
+ {
+ struct event recv_ev;
+- extern int (*event_sigcb)(void);
+ char *dev;
+ int c, debug;
+ FILE *fp;
+@@ -524,7 +520,6 @@
+ perror("signal");
+ return (-1);
+ }
+- event_sigcb = arpd_signal;
+
+ event_dispatch();
+
diff --git a/net-misc/arpd/files/arpd.c.patch b/net-misc/arpd/files/arpd.c.patch
new file mode 100644
index 00000000000..732ed16c92d
--- /dev/null
+++ b/net-misc/arpd/files/arpd.c.patch
@@ -0,0 +1,42 @@
+--- arpd.c.orig 2005-03-30 15:13:37.136590624 -0700
++++ arpd.c 2005-03-30 15:23:50.295231384 -0700
+@@ -265,7 +265,7 @@
+ spa->addr_ip, tha->addr_eth, tpa->addr_ip);
+
+ if (op == ARP_OP_REQUEST) {
+- syslog(LOG_DEBUG, __FUNCTION__ ": who-has %s tell %s",
++ syslog(LOG_DEBUG, __FUNCTION__, ": who-has %s tell %s",
+ addr_ntoa(tpa), addr_ntoa(spa));
+ } else if (op == ARP_OP_REPLY) {
+ syslog(LOG_INFO, "arp reply %s is-at %s",
+@@ -282,7 +282,7 @@
+ int error;
+
+ if (addr_cmp(addr, &arpd_ifent.intf_addr) == 0) {
+- syslog(LOG_DEBUG, __FUNCTION__ ": %s at %s",
++ syslog(LOG_DEBUG, __FUNCTION__, ": %s at %s",
+ addr_ntoa(addr), addr_ntoa(&arpd_ifent.intf_link_addr));
+ return (0);
+ }
+@@ -291,10 +291,10 @@
+ error = arp_get(arpd_arp, &arpent);
+
+ if (error == -1) {
+- syslog(LOG_DEBUG, __FUNCTION__ ": no entry for %s",
++ syslog(LOG_DEBUG, __FUNCTION__, ": no entry for %s",
+ addr_ntoa(addr));
+ } else {
+- syslog(LOG_DEBUG, __FUNCTION__ ": %s at %s",
++ syslog(LOG_DEBUG, __FUNCTION__, ": %s at %s",
+ addr_ntoa(addr), addr_ntoa(&arpent.arp_ha));
+ }
+ return (error);
+@@ -423,7 +423,7 @@
+ if ((req = SPLAY_FIND(tree, &arpd_reqs, &tmp)) != NULL) {
+ addr_pack(&src.arp_ha, ADDR_TYPE_ETH, ETH_ADDR_BITS,
+ ethip->ar_sha, ETH_ADDR_LEN);
+- syslog(LOG_DEBUG, __FUNCTION__ ": %s at %s",
++ syslog(LOG_DEBUG, __FUNCTION__, ": %s at %s",
+ addr_ntoa(&req->pa), addr_ntoa(&src.arp_ha));
+
+ /* This address is claimed */