summaryrefslogtreecommitdiff
path: root/net-misc/astmanproxy
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-misc/astmanproxy
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-misc/astmanproxy')
-rw-r--r--net-misc/astmanproxy/Manifest1
-rw-r--r--net-misc/astmanproxy/astmanproxy-1.28.2.ebuild49
-rw-r--r--net-misc/astmanproxy/files/astmanproxy-1.1-gentoo.diff31
-rw-r--r--net-misc/astmanproxy/files/astmanproxy-1.28.2-gentoo.diff39
-rwxr-xr-xnet-misc/astmanproxy/files/astmanproxy.rc620
-rw-r--r--net-misc/astmanproxy/metadata.xml10
6 files changed, 150 insertions, 0 deletions
diff --git a/net-misc/astmanproxy/Manifest b/net-misc/astmanproxy/Manifest
new file mode 100644
index 00000000000..c35b8ae678b
--- /dev/null
+++ b/net-misc/astmanproxy/Manifest
@@ -0,0 +1 @@
+DIST astmanproxy-1.28.2.tar.gz 65506 SHA256 09c2b5750d69c9ca8d9611cb648a5cedb0fa7102540642b06654e3ac5c31ed4b SHA512 a37caaca42649b19d40b9b0cfe61c6a0e31d7d0de50378565a6add1b27ba09dd6044c7ac2d9b38c424f143fc12acbfa0931c59492399ee34db063ed73cce9293 WHIRLPOOL 08b9d9b186ce424f309efddefa05cc91856cfbfea2b60d65030a15a0868bc1f72717431ba1f884eb0dea411d18fd950c6e17af5c356eae5db030879a0d34cc67
diff --git a/net-misc/astmanproxy/astmanproxy-1.28.2.ebuild b/net-misc/astmanproxy/astmanproxy-1.28.2.ebuild
new file mode 100644
index 00000000000..1e14e7a6b83
--- /dev/null
+++ b/net-misc/astmanproxy/astmanproxy-1.28.2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit base multilib toolchain-funcs
+
+DESCRIPTION="Proxy for the Asterisk manager interface"
+HOMEPAGE="https://github.com/davies147/astmanproxy/"
+SRC_URI="https://github.com/davies147/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+IUSE=""
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+DEPEND=""
+PATCHES=( "${FILESDIR}/${P}-gentoo.diff" )
+
+src_prepare() {
+ base_src_prepare
+
+ # Fix multilib
+ sed -i -e "s#/usr/lib/#/usr/$(get_libdir)/#" "${S}/Makefile" \
+ || die "multilib sed failed"
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" \
+ LDFLAGS="${LDFLAGS}" \
+ LD="$(tc-getLD)" \
+ RAWLDFLAGS="$(raw-ldflags)"
+}
+
+src_install() {
+ dosbin astmanproxy
+
+ dodoc README VERSIONS
+
+ docinto samples
+ dodoc samples/*
+
+ insinto /etc/asterisk
+ doins configs/astmanproxy.conf
+ doins configs/astmanproxy.users
+
+ newinitd "${FILESDIR}"/astmanproxy.rc6 astmanproxy
+}
diff --git a/net-misc/astmanproxy/files/astmanproxy-1.1-gentoo.diff b/net-misc/astmanproxy/files/astmanproxy-1.1-gentoo.diff
new file mode 100644
index 00000000000..b713cdc7d51
--- /dev/null
+++ b/net-misc/astmanproxy/files/astmanproxy-1.1-gentoo.diff
@@ -0,0 +1,31 @@
+--- astmanproxy-1.1/Makefile.orig 2005-07-13 04:35:49.000000000 +0200
++++ astmanproxy-1.1/Makefile 2005-07-13 04:37:43.000000000 +0200
+@@ -1,8 +1,8 @@
+ VERSION := 1.1
+ DESTDIR :=
+-PREFIX:= /usr/local
+-CONFDIR:=/etc/asterisk
+-CONFDIR_REAL := $(DESTDIR)/etc/asterisk
++PREFIX := /usr
++CONFDIR := /etc
++CONFDIR_REAL := $(DESTDIR)$(CONFDIR)
+
+ BINDIR := $(DESTDIR)$(PREFIX)/sbin
+ LIBDIR := $(DESTDIR)/usr/lib/astmanproxy
+@@ -14,7 +14,7 @@
+ DEFINES:='-DPROXY_VERSION="$(VERSION)"' '-DCDIR="$(CONFDIR)"' '-DCFILE="$(CONFFILE)"' '-DMDIR="$(MODDIR)"'
+
+ # Add -g below for debug/GDB symbols
+-CFLAGS := $(DEFINES) -Wall -O2 -rdynamic -D_REENTRANT
++CFLAGS += -Wall -rdynamic -D_REENTRANT -fPIC $(DEFINES)
+
+ CC := gcc
+ LD := ld
+--- astmanproxy-1.1/astmanproxy.conf.orig 2005-07-13 04:38:53.000000000 +0200
++++ astmanproxy-1.1/astmanproxy.conf 2005-07-13 04:38:59.000000000 +0200
+@@ -57,4 +57,4 @@
+ autofilter = on
+
+ ; location of logfile -- will be owned by proc_user/proc_group
+-logfile = /var/log/asterisk/astmanproxy.log
++logfile = /var/log/astmanproxy.log
diff --git a/net-misc/astmanproxy/files/astmanproxy-1.28.2-gentoo.diff b/net-misc/astmanproxy/files/astmanproxy-1.28.2-gentoo.diff
new file mode 100644
index 00000000000..68534cd6108
--- /dev/null
+++ b/net-misc/astmanproxy/files/astmanproxy-1.28.2-gentoo.diff
@@ -0,0 +1,39 @@
+diff -uNr astmanproxy-1.28.2.ORIG/Makefile astmanproxy-1.28.2/Makefile
+--- astmanproxy-1.28.2.ORIG/Makefile 2014-02-10 11:18:06.027132570 +0000
++++ astmanproxy-1.28.2/Makefile 2014-02-10 11:21:07.382135291 +0000
+@@ -17,7 +17,7 @@
+
+ CC := gcc
+ INCLUDES :=
+-PREFIX:= /usr/local
++PREFIX:= /usr
+ BINDIR := $(DESTDIR)$(PREFIX)/sbin
+
+ # For compilation dependencies
+@@ -27,7 +27,7 @@
+ LIBS := -lssl
+
+ # Add -g below for debug/GDB symbols
+-CFLAGS:=-Wall -O2 -D_REENTRANT -D_GNU_SOURCE -fPIC -Isrc/include -I/usr/include/openssl
++CFLAGS += -Wall -O2 -D_REENTRANT -D_GNU_SOURCE -fPIC -Isrc/include -I/usr/include/openssl
+
+ ifeq (${OSARCH},Darwin)
+ LIBS+=-lresolv
+@@ -62,7 +62,7 @@
+ DEFINES+='-DMDIR="$(MODDIR)"' '-DPDIR="$(PERMDIR)"' '-DPFILE="$(PERMFILE)"'
+
+ PROXYCERT := $(CERTDIR)/proxy-server.pem
+-PROXYSSLCONF := $(CONFDIR)/proxy-ssl.conf
++PROXYSSLCONF := $(DESTDIR)$(CONFDIR)/proxy-ssl.conf
+
+ CFLAGS += $(DEFINES)
+
+@@ -76,7 +76,7 @@
+ SRCS := $(MODS:%=src/%.c)
+ HDRS := src/include/astmanproxy.h
+
+-all: astmanproxy cert
++all: astmanproxy
+
+ astmanproxy: $(OBJS) $(SOBJS)
+ $(CC) $(CFLAGS) -o $@ $(ASTLINK) $(OBJS) $(LIBS)
diff --git a/net-misc/astmanproxy/files/astmanproxy.rc6 b/net-misc/astmanproxy/files/astmanproxy.rc6
new file mode 100755
index 00000000000..dcb0a936ab9
--- /dev/null
+++ b/net-misc/astmanproxy/files/astmanproxy.rc6
@@ -0,0 +1,20 @@
+#!/sbin/runscript
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+depend() {
+ need net
+}
+
+start() {
+ ebegin "Starting astmanproxy"
+ start-stop-daemon --start --exec /usr/sbin/astmanproxy
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping astmanproxy"
+ start-stop-daemon --stop --exec /usr/sbin/astmanproxy
+ eend $?
+}
diff --git a/net-misc/astmanproxy/metadata.xml b/net-misc/astmanproxy/metadata.xml
new file mode 100644
index 00000000000..15557bab051
--- /dev/null
+++ b/net-misc/astmanproxy/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>chainsaw@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">davies147/astmanproxy</remote-id>
+ </upstream>
+</pkgmetadata>