summaryrefslogtreecommitdiff
path: root/net-misc/balance
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-misc/balance
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-misc/balance')
-rw-r--r--net-misc/balance/Manifest1
-rw-r--r--net-misc/balance/balance-3.54-r1.ebuild35
-rw-r--r--net-misc/balance/files/balance-3.54-Makefile.patch52
-rw-r--r--net-misc/balance/metadata.xml8
4 files changed, 96 insertions, 0 deletions
diff --git a/net-misc/balance/Manifest b/net-misc/balance/Manifest
new file mode 100644
index 00000000000..1558ce12cc1
--- /dev/null
+++ b/net-misc/balance/Manifest
@@ -0,0 +1 @@
+DIST balance-3.54.tar.gz 35166 SHA256 170b1a5dd60a566a785b72afde42a349e20fe01f53263db1279f71ef188efe45 SHA512 addddc3f76b3f85fc56ea2a8139660405d2ece43a087e20e9d57db1c0bdbbf4bd34f94c8e42936e9291c0462b3f0abae0ed97fec48540de730afd3c9898fb79d WHIRLPOOL ff4dff4c1548c2276077f2bd83d82cc64bf19feae3d48b835b48c131f5a605afdf0903459185668251328960e1a96fc644e5dbdde3a70063bdca78fc6ba5fb65
diff --git a/net-misc/balance/balance-3.54-r1.ebuild b/net-misc/balance/balance-3.54-r1.ebuild
new file mode 100644
index 00000000000..6287494e362
--- /dev/null
+++ b/net-misc/balance/balance-3.54-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="TCP Load Balancing Port Forwarder"
+HOMEPAGE="http://www.inlab.de/balance.html"
+SRC_URI="http://www.inlab.de/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc"
+
+DEPEND="doc? ( app-text/ghostscript-gpl
+ sys-apps/groff )"
+RDEPEND=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-Makefile.patch
+ tc-export CC
+ use doc || touch balance.pdf
+}
+
+src_install() {
+ default
+
+ #autocreated on program start, if missing
+ rmdir "${D}"/var/run/${PN}
+
+ use doc && dodoc balance.pdf
+}
diff --git a/net-misc/balance/files/balance-3.54-Makefile.patch b/net-misc/balance/files/balance-3.54-Makefile.patch
new file mode 100644
index 00000000000..8b231aaa831
--- /dev/null
+++ b/net-misc/balance/files/balance-3.54-Makefile.patch
@@ -0,0 +1,52 @@
+--- balance-3.54/Makefile
++++ balance-3.54/Makefile
+@@ -1,14 +1,14 @@
+ # $Id$
+
+ #CFLAGS=-g -I.
+-CFLAGS=-O2 -Wall -Wstrict-prototypes -Wuninitialized
++CFLAGS+=-Wall -Wstrict-prototypes -Wuninitialized
+
+ # uncomment for any OS other than Cygwin
+ BALANCE=balance
+ ROOT=root
+ INSTALL=install
+ BINDIR=/usr/sbin
+-MANDIR=${BINDIR}/../man/man1
++MANDIR=/usr/share/man/man1
+
+ # uncomment for Solaris:
+ # LIBRARIES=-lsocket -lnsl
+@@ -20,13 +20,13 @@
+ # BALANCE=balance.exe
+ # ROOT=Administrators
+
+-CC=gcc
++CC?=gcc
+ RELEASE=3.54
+
+ all: balance
+
+ balance: balance.o butils.o
+- $(CC) $(CFLAGS) -I. -o balance balance.o butils.o $(LIBRARIES)
++ $(CC) $(CFLAGS) $(LDFLAGS) -I. -o balance balance.o butils.o $(LIBRARIES)
+
+ balance.o: balance.c balance.h
+ $(CC) $(CFLAGS) -I. -c balance.c
+@@ -48,12 +48,15 @@
+ rm -f $(BALANCE) *.o balance.ps balance.pdf
+
+ install:
++ $(INSTALL) -o $(ROOT) -g $(ROOT) -m 755 -d \
++ $(DESTDIR)$(BINDIR) \
++ $(DESTDIR)$(MANDIR)
+ $(INSTALL) -o $(ROOT) -g $(ROOT) -m 755 $(BALANCE) \
+ $(DESTDIR)$(BINDIR)/$(BALANCE)
+ $(INSTALL) -o $(ROOT) -g $(ROOT) -m 755 balance.1 \
+ $(DESTDIR)$(MANDIR)
+ mkdir -p $(DESTDIR)/var/run/balance
+- chmod 1777 $(DESTDIR)/var/run/balance
++ chmod 1755 $(DESTDIR)/var/run/balance
+
+ release: balance.pdf
+ rm -rf ./releases/balance-$(RELEASE)
diff --git a/net-misc/balance/metadata.xml b/net-misc/balance/metadata.xml
new file mode 100644
index 00000000000..243b1ca9f63
--- /dev/null
+++ b/net-misc/balance/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>xmw@gentoo.org</email>
+ <name>Michael Weber</name>
+ </maintainer>
+</pkgmetadata>