summaryrefslogtreecommitdiff
path: root/net-misc/batctl
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-misc/batctl
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-misc/batctl')
-rw-r--r--net-misc/batctl/Manifest2
-rw-r--r--net-misc/batctl/batctl-2013.4.0.ebuild36
-rw-r--r--net-misc/batctl/batctl-2014.2.0.ebuild37
-rw-r--r--net-misc/batctl/metadata.xml9
4 files changed, 84 insertions, 0 deletions
diff --git a/net-misc/batctl/Manifest b/net-misc/batctl/Manifest
new file mode 100644
index 00000000000..6bc9c05808c
--- /dev/null
+++ b/net-misc/batctl/Manifest
@@ -0,0 +1,2 @@
+DIST batctl-2013.4.0.tar.gz 53074 SHA256 4deae3b6664d0d13acf7a8ece74175a31a72fe58fb15cb9112a9a2014b32cb4c SHA512 1c099f8b5633923669e41a01b8364f3b665de2c67efe05a1938e1977ffe6067e91be308f3445492001acd5e6fc0c9c930610edf351bda6920579b80b45811011 WHIRLPOOL 8ac0a563b4899b715542dad6b6761603f0fe6538e42dfdd5473049fb5ee112195cf078e2282b4cd33761591fa20b11c8365a4cd9138d376450c507537e1112fa
+DIST batctl-2014.2.0.tar.gz 56536 SHA256 872b4835d29e907e1c9e7181a6a6c34ead1aceda748b752d4f1afcd4fb2913c2 SHA512 4d78cd0914dce293b9a88c26f2b0f692fd8061aef6f47deeea433a0e700f6d11e608043981e1859dd36ed58b7bbe31483937b1f05070a210b0d55875160d2ca6 WHIRLPOOL 55b3db86a55c6a754735c763fd10323099f33d79e4d619c67efa865b93c616983ed5d5a104771ee3e442e8554a6a25f5176ed9596be4646557fe33e892f71a6f
diff --git a/net-misc/batctl/batctl-2013.4.0.ebuild b/net-misc/batctl/batctl-2013.4.0.ebuild
new file mode 100644
index 00000000000..aaddc031e64
--- /dev/null
+++ b/net-misc/batctl/batctl-2013.4.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit linux-info toolchain-funcs
+
+DESCRIPTION="BATMAN advanced control and management tool"
+HOMEPAGE="http://www.open-mesh.org/"
+SRC_URI="http://downloads.open-mesh.org/batman/stable/sources/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+pkg_setup() {
+ if ( linux_config_exists && linux_chkconfig_present BATMAN_ADV ) \
+ || ! has_version net-misc/batman-adv ; then
+ ewarn "You need the batman-adv kernel module,"
+ ewarn "either from the kernel tree or via net-misc/batman-adv"
+ fi
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" V=1 REVISION=gentoo-"${PVR}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}"/usr install
+ dodoc README
+}
diff --git a/net-misc/batctl/batctl-2014.2.0.ebuild b/net-misc/batctl/batctl-2014.2.0.ebuild
new file mode 100644
index 00000000000..ddd68782bd7
--- /dev/null
+++ b/net-misc/batctl/batctl-2014.2.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit linux-info toolchain-funcs
+
+DESCRIPTION="BATMAN advanced control and management tool"
+HOMEPAGE="http://www.open-mesh.org/"
+SRC_URI="http://downloads.open-mesh.org/batman/stable/sources/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-libs/libnl:3"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+pkg_setup() {
+ if ( linux_config_exists && linux_chkconfig_present BATMAN_ADV ) \
+ || ! has_version net-misc/batman-adv ; then
+ ewarn "You need the batman-adv kernel module,"
+ ewarn "either from the kernel tree or via net-misc/batman-adv"
+ fi
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" V=1 REVISION=gentoo-"${PVR}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}"/usr install
+ dodoc README
+}
diff --git a/net-misc/batctl/metadata.xml b/net-misc/batctl/metadata.xml
new file mode 100644
index 00000000000..59acc2cc580
--- /dev/null
+++ b/net-misc/batctl/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+<email>xmw@gentoo.org</email>
+<name>Michael Weber</name>
+</maintainer>
+</pkgmetadata>
+