summaryrefslogtreecommitdiff
path: root/net-misc/bfgminer
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2015-09-05 09:23:48 -0400
committerAnthony G. Basile <blueness@gentoo.org>2015-09-05 09:36:10 -0400
commit3fdad55439742dfcf13369a758d8c63a1978f8c9 (patch)
tree015da2bcdce8dfb6ccd9a917454556df315196c5 /net-misc/bfgminer
parent92af7dc5ff7a9bf15ecf55425212783040ca6cfa (diff)
downloadgentoo-3fdad55439742dfcf13369a758d8c63a1978f8c9.tar.gz
gentoo-3fdad55439742dfcf13369a758d8c63a1978f8c9.tar.xz
net-misc/bfgminer: version bump 5.3.0
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'net-misc/bfgminer')
-rw-r--r--net-misc/bfgminer/Manifest1
-rw-r--r--net-misc/bfgminer/bfgminer-5.3.0.ebuild202
2 files changed, 203 insertions, 0 deletions
diff --git a/net-misc/bfgminer/Manifest b/net-misc/bfgminer/Manifest
index 3f78149a861..a956ce6b040 100644
--- a/net-misc/bfgminer/Manifest
+++ b/net-misc/bfgminer/Manifest
@@ -7,3 +7,4 @@ DIST bfgminer-4.10.3.tar.xz 988552 SHA256 c9e4ac3754dad838d3a8120afd499751ac2e8b
DIST bfgminer-5.0.0.tar.xz 1012092 SHA256 f1dada4d83737f7bc9623ad695a07a88808d8103c9c7617ce18825d241e328fd SHA512 fc1b116347e0b2af4e2c7f895368abe156019be5495e286df2f90708c16c1739e7362682389eb88ce64835d53545a5603eab4818d70018f7f872a28b4ec6c797 WHIRLPOOL 95085f7ddc374579520bae130b12923669c5788c0ea21e7377e57e907ed997936f6a413d9067c0121410bde42b33c0b194774794965a86328b60f3cf0d881165
DIST bfgminer-5.1.0.tar.xz 1024292 SHA256 436595e8b3af267e8fed023ac6b5f208a385d891d0c3c1c41b8aa13f1c1e69c9 SHA512 826f3b1b2a3c0c0ce66ce888308cc531a2f8cf8212771bc07a650cf2811aeb40ed1d41ba1ffc8b3b16719cf261a5ce9d087bfa17603255cc53f0866b7ddc5459 WHIRLPOOL 9e1310b47f678c17840216e82f99d3c06152ad2efd49096ce27e31614282da62359bcca1e0a812ca2433fc933c5848ae0a8c271ccb2b7c8a7102e7d25b022ad2
DIST bfgminer-5.2.0.tar.xz 1017012 SHA256 0cec8a4012d5784f781201d245bee834b0085274a24737ff3a4d0a28d48edc28 SHA512 5bb930d3cf9aed0ae9eaabbd92c3a26146a7308e61bcf5ebdf67f8f5f70a7bae1df0bad51312b4bdfabcc10547b0d991a1117db5f6b98b1047c1dae6fd880f85 WHIRLPOOL f18d4d029d6296d130bbb439b1323fe9ae8dfd89ddc3cdd3f4f85742969a17ccadb7ad49ff3527e9399d4b60ff6b7c2bd83cd291003e0f676af4307141b635da
+DIST bfgminer-5.3.0.tar.xz 1017536 SHA256 d48fa6e51ff70ee1a85f77334a24f842ca6774c073c2d864fe739f07093ef77f SHA512 935b2a0595a2230f8ba9f832a280f52418c1b50b884010bebd2059cbef83d28c535d8d0b3cd7abe5b2420f6dc9fa8e9e0e32839ccdb6cd002a1e874dc5b1841a WHIRLPOOL 0244c9cf2a8928590f69819cfaa222498ae9e0b65aba4c0bc3fc751b7712e9284110ef238dd3bdeaa0562f4eaa292b4257e4d509966ff8e92731dd3f1d9f8ecc
diff --git a/net-misc/bfgminer/bfgminer-5.3.0.ebuild b/net-misc/bfgminer/bfgminer-5.3.0.ebuild
new file mode 100644
index 00000000000..136a2b86f11
--- /dev/null
+++ b/net-misc/bfgminer/bfgminer-5.3.0.ebuild
@@ -0,0 +1,202 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="Modular Bitcoin ASIC/FPGA/GPU/CPU miner in C"
+HOMEPAGE="https://bitcointalk.org/?topic=168174"
+SRC_URI="http://luke.dashjr.org/programs/bitcoin/files/${PN}/${PV}/${P}.txz -> ${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~ppc64 ~x86"
+
+# TODO: knc (needs i2c-tools header)
+# TODO: kncasic & titan (need systemwide knc-asic install)
+# TODO: minergate (needs actual miner_gate)
+IUSE="adl antminer avalon avalonmm bfsb bfx bifury bigpic bitforce bitfury cointerra cpumining drillbit dualminer examples gridseed hardened hashbuster hashbuster2 hashfast icarus jingtian keccak klondike +libusb littlefury lm_sensors metabank minion modminer nanofury ncurses opencl proxy proxy_getwork proxy_stratum rockminer screen scrypt +sha256d twinfury +udev udev-broad-rules unicode x6500 zeusminer ztex"
+REQUIRED_USE='
+ || ( keccak scrypt sha256d )
+ || ( antminer avalon avalonmm bfsb bfx bifury bigpic bitforce bitfury cointerra cpumining drillbit dualminer gridseed hashbuster hashbuster2 hashfast icarus klondike littlefury metabank modminer nanofury opencl proxy twinfury x6500 zeusminer ztex )
+ adl? ( opencl )
+ antminer? ( sha256d )
+ avalon? ( sha256d )
+ avalonmm? ( sha256d )
+ bfsb? ( sha256d bitfury )
+ bfx? ( sha256d bitfury libusb )
+ bifury? ( sha256d )
+ bigpic? ( sha256d bitfury )
+ bitforce? ( sha256d )
+ bitfury? ( sha256d )
+ cointerra? ( sha256d )
+ drillbit? ( sha256d bitfury )
+ dualminer? ( || ( sha256d scrypt ) icarus )
+ gridseed? ( scrypt )
+ hashbuster? ( sha256d bitfury )
+ hashbuster2? ( sha256d bitfury libusb )
+ hashfast? ( sha256d )
+ icarus? ( || ( scrypt sha256d ) )
+ jingtian? ( sha256d )
+ keccak? ( || ( cpumining opencl proxy ) )
+ klondike? ( sha256d libusb )
+ littlefury? ( sha256d bitfury )
+ lm_sensors? ( opencl )
+ metabank? ( sha256d bitfury )
+ minion? ( sha256d )
+ modminer? ( sha256d )
+ nanofury? ( sha256d bitfury )
+ scrypt? ( || ( cpumining dualminer gridseed opencl proxy zeusminer ) )
+ sha256d? ( || ( antminer avalon avalonmm bfx bifury bitforce bfsb bigpic bitfury cointerra cpumining drillbit dualminer hashbuster hashbuster2 hashfast icarus jingtian klondike littlefury metabank modminer nanofury opencl proxy rockminer twinfury x6500 ztex ) )
+ twinfury? ( bitfury )
+ unicode? ( ncurses )
+ proxy? ( || ( proxy_getwork proxy_stratum ) )
+ proxy_getwork? ( proxy )
+ proxy_stratum? ( proxy )
+ rockminer? ( sha256d )
+ twinfury? ( sha256d )
+ x6500? ( sha256d libusb )
+ zeusminer? ( scrypt )
+ ztex? ( sha256d libusb )
+'
+
+DEPEND='
+ net-misc/curl
+ ncurses? (
+ sys-libs/ncurses[unicode?]
+ )
+ >=dev-libs/jansson-2
+ dev-libs/libbase58
+ net-libs/libblkmaker
+ udev? (
+ virtual/udev
+ )
+ hashbuster? (
+ dev-libs/hidapi
+ )
+ libusb? (
+ virtual/libusb:1
+ )
+ lm_sensors? (
+ sys-apps/lm_sensors
+ )
+ nanofury? (
+ dev-libs/hidapi
+ )
+ proxy_getwork? (
+ net-libs/libmicrohttpd
+ )
+ proxy_stratum? (
+ dev-libs/libevent
+ )
+ screen? (
+ app-misc/screen
+ || (
+ >=sys-apps/coreutils-8.15
+ sys-freebsd/freebsd-bin
+ app-misc/realpath
+ )
+ )
+'
+RDEPEND="${DEPEND}
+ opencl? (
+ || (
+ virtual/opencl
+ virtual/opencl-sdk
+ dev-util/ati-stream-sdk
+ dev-util/ati-stream-sdk-bin
+ dev-util/amdstream
+ dev-util/amd-app-sdk
+ dev-util/amd-app-sdk-bin
+ dev-util/nvidia-cuda-sdk[opencl]
+ dev-util/intel-opencl-sdk
+ )
+ )
+"
+DEPEND="${DEPEND}
+ virtual/pkgconfig
+ >=dev-libs/uthash-1.9.7
+ sys-apps/sed
+ cpumining? (
+ amd64? (
+ >=dev-lang/yasm-1.0.1
+ )
+ x86? (
+ >=dev-lang/yasm-1.0.1
+ )
+ )
+"
+
+src_configure() {
+ local CFLAGS="${CFLAGS}"
+ local with_curses
+ use hardened && CFLAGS="${CFLAGS} -nopie"
+
+ if use ncurses; then
+ if use unicode; then
+ with_curses='--with-curses=ncursesw'
+ else
+ with_curses='--with-curses=ncurses'
+ fi
+ else
+ with_curses='--without-curses'
+ fi
+
+ CFLAGS="${CFLAGS}" \
+ econf \
+ --docdir="/usr/share/doc/${PF}" \
+ $(use_enable adl) \
+ $(use_enable antminer) \
+ $(use_enable avalon) \
+ $(use_enable avalonmm) \
+ $(use_enable bifury) \
+ $(use_enable bitforce) \
+ $(use_enable bfsb) \
+ $(use_enable bfx) \
+ $(use_enable bigpic) \
+ $(use_enable bitfury) \
+ $(use_enable cointerra) \
+ $(use_enable cpumining) \
+ $(use_enable drillbit) \
+ $(use_enable dualminer) \
+ $(use_enable gridseed) \
+ $(use_enable hashbuster) \
+ $(use_enable hashbuster2 hashbusterusb) \
+ $(use_enable hashfast) \
+ $(use_enable icarus) \
+ $(use_enable jingtian) \
+ $(use_enable keccak) \
+ $(use_enable klondike) \
+ $(use_enable littlefury) \
+ $(use_enable metabank) \
+ $(use_enable minion) \
+ $(use_enable modminer) \
+ $(use_enable nanofury) \
+ $(use_enable opencl) \
+ $(use_enable rockminer) \
+ $(use_enable scrypt) \
+ $(use_enable sha256d) \
+ $(use_enable twinfury) \
+ --with-system-libblkmaker \
+ $with_curses \
+ $(use_with udev libudev) \
+ $(use_enable udev-broad-rules broad-udevrules) \
+ $(use_with lm_sensors sensors) \
+ $(use_with proxy_getwork libmicrohttpd) \
+ $(use_with proxy_stratum libevent) \
+ $(use_enable x6500) \
+ $(use_enable zeusminer) \
+ $(use_enable ztex)
+}
+
+src_install() {
+ emake install DESTDIR="$D"
+ if ! use examples; then
+ rm -r "${D}/usr/share/doc/${PF}/rpc-examples"
+ fi
+ if ! use screen; then
+ rm "${D}/usr/bin/start-bfgminer.sh"
+ fi
+}