summaryrefslogtreecommitdiff
path: root/net-misc/bopm
diff options
context:
space:
mode:
authorNathan Phillip Brink <binki@gentoo.org>2015-10-03 03:03:06 +0000
committerNathan Phillip Brink <binki@gentoo.org>2015-10-03 03:03:06 +0000
commit0528c472627b1698f679374ceaf9534586dabfa2 (patch)
treeddcfd0c13356ee8227caa19bb348990ec63936a6 /net-misc/bopm
parent1049e0ef47481e8c76c99c96b13ab75597ea22ce (diff)
downloadgentoo-0528c472627b1698f679374ceaf9534586dabfa2.tar.gz
gentoo-0528c472627b1698f679374ceaf9534586dabfa2.tar.xz
net-misc/bopm: Support tmpfs /run for bug #562032. Thanks shentino, grknight.
Package-Manager: portage-2.2.20
Diffstat (limited to 'net-misc/bopm')
-rw-r--r--net-misc/bopm/bopm-3.1.3-r1.ebuild57
-rw-r--r--net-misc/bopm/files/bopm.conf.d-r19
-rw-r--r--net-misc/bopm/files/bopm.init.d-r117
3 files changed, 83 insertions, 0 deletions
diff --git a/net-misc/bopm/bopm-3.1.3-r1.ebuild b/net-misc/bopm/bopm-3.1.3-r1.ebuild
new file mode 100644
index 00000000000..6636224818b
--- /dev/null
+++ b/net-misc/bopm/bopm-3.1.3-r1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils multilib user
+
+DESCRIPTION="Blitzed Open Proxy Monitor"
+HOMEPAGE="http://www.blitzed.org/bopm/"
+SRC_URI="http://static.blitzed.org/www.blitzed.org/${PN}/files/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ econf \
+ --datadir="${EPREFIX}"/usr/share/doc/${PF} \
+ --localstatedir="${EPREFIX}"/var/log/${PN}
+}
+
+src_install () {
+ sed -i \
+ -e "s!/some/path/bopm.pid!/run/${PN}/${PN}.pid!" \
+ -e "s!/some/path/scan.log!/var/log/${PN}/scan.log!" \
+ bopm.conf.sample || die
+
+ # Custom Makefile.am rules do not respect DESTDIR,
+ # thus override sysconfdir and localstatedir.
+ emake \
+ DESTDIR="${D}" \
+ sysconfdir="${ED}"/etc \
+ localstatedir="${ED}"/var/log/bopm \
+ install || die "install failed"
+
+ fperms 600 /etc/bopm.conf
+
+ # Remove libopm related files, because bopm links statically to it
+ # If anybody wants libopm, please install net-libs/libopm
+ rm -r "${ED}"/usr/$(get_libdir) "${ED}"/usr/include || die
+
+ newinitd "${FILESDIR}"/bopm.init.d-r1 ${PN}
+ newconfd "${FILESDIR}"/bopm.conf.d-r1 ${PN}
+
+ dodoc ChangeLog INSTALL README TODO
+}
+
+pkg_postinst() {
+ enewuser bopm
+
+ install -d -m 0700 -o bopm -g root "${ROOT}"/var/log/bopm
+ chown bopm "${ROOT}"/etc/bopm.conf
+}
diff --git a/net-misc/bopm/files/bopm.conf.d-r1 b/net-misc/bopm/files/bopm.conf.d-r1
new file mode 100644
index 00000000000..71bacbe7f21
--- /dev/null
+++ b/net-misc/bopm/files/bopm.conf.d-r1
@@ -0,0 +1,9 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+# Config file for /etc/init.d/bopm
+
+BOPM_UID=bopm
+CONFFILE=/etc/${SVCNAME}.conf
+PIDFILE=/run/bopm/${SVCNAME}.pid
diff --git a/net-misc/bopm/files/bopm.init.d-r1 b/net-misc/bopm/files/bopm.init.d-r1
new file mode 100644
index 00000000000..4f6f2ea77bd
--- /dev/null
+++ b/net-misc/bopm/files/bopm.init.d-r1
@@ -0,0 +1,17 @@
+#!/sbin/openrc-run
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+command="/usr/bin/bopm"
+description="Blitzed Open Proxy Monitor"
+start_stop_daemon_args="--quiet --chuid ${BOPM_UID}"
+pidfile="${PIDFILE}"
+
+depend() {
+ need net
+}
+
+start_pre() {
+ checkpath -o ${BOPM_UID} -d "$(dirname "${PIDFILE}")"
+}