summaryrefslogtreecommitdiff
path: root/net-misc/bti/bti-034.ebuild
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2017-03-18 18:43:46 +1100
committerMichael Palimaka <kensington@gentoo.org>2017-03-18 18:43:56 +1100
commit9f726acfa6546d1e132d225663b48dfcf0f7fab0 (patch)
tree60c1ab249906a8d2bffbc9ab5251136c0ab1b4cb /net-misc/bti/bti-034.ebuild
parent167538b41c96244dece634e531b20b27be633355 (diff)
downloadgentoo-9f726acfa6546d1e132d225663b48dfcf0f7fab0.tar.gz
gentoo-9f726acfa6546d1e132d225663b48dfcf0f7fab0.tar.xz
net-misc/bti: version bump 034
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'net-misc/bti/bti-034.ebuild')
-rw-r--r--net-misc/bti/bti-034.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/net-misc/bti/bti-034.ebuild b/net-misc/bti/bti-034.ebuild
new file mode 100644
index 00000000000..65b7eb207a0
--- /dev/null
+++ b/net-misc/bti/bti-034.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit bash-completion-r1
+
+DESCRIPTION="A command line twitter/identi.ca client"
+HOMEPAGE="https://gregkh.github.com/bti/"
+SRC_URI="mirror://kernel/software/web/bti/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+COMMON_DEPEND="
+ dev-libs/json-c
+ dev-libs/libpcre
+ dev-libs/libxml2
+ net-libs/liboauth
+ net-misc/curl
+"
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig
+"
+# Readline is dynamically loaded, for whatever reason, and can use
+# libedit as an alternative...
+RDEPEND="${COMMON_DEPEND}
+ || ( sys-libs/readline dev-libs/libedit )
+"
+
+DOCS=( bti.example ChangeLog README RELEASE-NOTES )
+
+src_install() {
+ default
+ newbashcomp bti-bashcompletion ${PN}
+}