summaryrefslogtreecommitdiff
path: root/net-misc/bti
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-misc/bti
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-misc/bti')
-rw-r--r--net-misc/bti/Manifest1
-rw-r--r--net-misc/bti/bti-031-r1.ebuild43
-rw-r--r--net-misc/bti/files/bti-031-nonGNU.patch32
-rw-r--r--net-misc/bti/metadata.xml8
4 files changed, 84 insertions, 0 deletions
diff --git a/net-misc/bti/Manifest b/net-misc/bti/Manifest
new file mode 100644
index 00000000000..eb52053b5f8
--- /dev/null
+++ b/net-misc/bti/Manifest
@@ -0,0 +1 @@
+DIST bti-031.tar.bz2 89027 SHA256 1b2f509a818ec6b1a036daff9d56a9c7b2640741df3d0ec89376775890187cd5 SHA512 d930013eb45bdfbaa914444460f74448c8bb62f255b2db5c771736ba7c5bb71d0cf4651db76eba0f05fbd6c6a175c7bc8942d7657588bd27e18bf409bf02d9fd WHIRLPOOL 43cf7b10e01cc0f0c076faec79f9ce2f18fdd23350a72d1d081638f2d0c55f323e395fe088379455e6846b12df13a76fcbd4cc6f4bfc2835040e5c961734ed01
diff --git a/net-misc/bti/bti-031-r1.ebuild b/net-misc/bti/bti-031-r1.ebuild
new file mode 100644
index 00000000000..d6cf7562cc4
--- /dev/null
+++ b/net-misc/bti/bti-031-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit bash-completion-r1 eutils
+
+DESCRIPTION="A command line twitter/identi.ca client"
+HOMEPAGE="http://gregkh.github.com/bti/"
+SRC_URI="mirror://kernel/software/web/bti/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE=""
+
+RDEPEND="
+ net-misc/curl
+ dev-libs/libxml2
+ dev-libs/libpcre
+ net-libs/liboauth
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+
+# Readline is dynamically loaded, for whatever reason, and can use
+# libedit as an alternative...
+RDEPEND="${RDEPEND}
+ || ( sys-libs/readline dev-libs/libedit )"
+
+DOCS=( bti.example README RELEASE-NOTES )
+
+src_prepare() {
+ # Allow compilation on non-GNU systems, bug #384311
+ epatch "${FILESDIR}/${PN}-031-nonGNU.patch"
+}
+
+src_install() {
+ default
+ dobashcomp bti-bashcompletion
+}
diff --git a/net-misc/bti/files/bti-031-nonGNU.patch b/net-misc/bti/files/bti-031-nonGNU.patch
new file mode 100644
index 00000000000..14b10c1fb83
--- /dev/null
+++ b/net-misc/bti/files/bti-031-nonGNU.patch
@@ -0,0 +1,32 @@
+Avoid using strchrnul, it's a GNU addition. The code in question,
+actually doesn't really benefit from strchrnul's behaviour.
+
+--- config.c
++++ config.c
+@@ -351,20 +351,21 @@
+ * marker if it occurs at the beginning of the line, or after
+ * whitespace
+ */
+- hashmarker = strchrnul(line, '#');
++ hashmarker = strchr(line, '#');
+ if (line == hashmarker)
+ line[0] = '\0';
+ else {
+- while (hashmarker[0] != '\0') {
++ while (hashmarker != NULL) {
+ --hashmarker;
+- if (isblank(hashmarker[0]))
++ if (isblank(hashmarker[0])) {
+ hashmarker[0] = '\0';
+- else {
++ break;
++ } else {
+ /*
+ * false positive; '#' occured
+ * within a string
+ */
+- hashmarker = strchrnul(hashmarker+2, '#');
++ hashmarker = strchr(hashmarker+2, '#');
+ }
+ }
+ }
diff --git a/net-misc/bti/metadata.xml b/net-misc/bti/metadata.xml
new file mode 100644
index 00000000000..b14c9fbb175
--- /dev/null
+++ b/net-misc/bti/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>gregkh@gentoo.org</email>
+ <name>Greg Kroah-Hartman</name>
+ </maintainer>
+</pkgmetadata>