summaryrefslogtreecommitdiff
path: root/net-misc/capi4hylafax
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-misc/capi4hylafax
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-misc/capi4hylafax')
-rw-r--r--net-misc/capi4hylafax/Manifest3
-rw-r--r--net-misc/capi4hylafax/capi4hylafax-01.03.00.99.300.3-r1.ebuild142
-rw-r--r--net-misc/capi4hylafax/capi4hylafax-01.03.00.99.300.9.ebuild133
-rw-r--r--net-misc/capi4hylafax/files/capi4hylafax-01.03.00.99.300.3-recvdev.diff20
-rw-r--r--net-misc/capi4hylafax/files/capi4hylafax.confd19
-rw-r--r--net-misc/capi4hylafax/files/capi4hylafax.initd64
-rw-r--r--net-misc/capi4hylafax/metadata.xml19
7 files changed, 400 insertions, 0 deletions
diff --git a/net-misc/capi4hylafax/Manifest b/net-misc/capi4hylafax/Manifest
new file mode 100644
index 00000000000..eb5adcf141e
--- /dev/null
+++ b/net-misc/capi4hylafax/Manifest
@@ -0,0 +1,3 @@
+DIST capi4hylafax_01.03.00.99.svn.300-3.diff.gz 155360 SHA256 dec167255e2307d12b5093e11ddbb6b1f96d0ac94985643579cfd6b534313ed2
+DIST capi4hylafax_01.03.00.99.svn.300-9.diff.gz 160179 SHA256 5c116fcefa6604a351c31507644c26fb43e0dc89e51f97ee748a52a5eebbc4af
+DIST capi4hylafax_01.03.00.99.svn.300.orig.tar.gz 533410 SHA256 8c5433fda85d5f178382c0a4fbc07cf22fc22c448146a4b7a090bc6a0b1789c2
diff --git a/net-misc/capi4hylafax/capi4hylafax-01.03.00.99.300.3-r1.ebuild b/net-misc/capi4hylafax/capi4hylafax-01.03.00.99.300.3-r1.ebuild
new file mode 100644
index 00000000000..319c72afd14
--- /dev/null
+++ b/net-misc/capi4hylafax/capi4hylafax-01.03.00.99.300.3-r1.ebuild
@@ -0,0 +1,142 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils versionator autotools
+
+FAX_SPOOL_DIR="/var/spool/fax"
+
+MY_PV1="$(get_version_component_range 1-4)"
+MY_PV2="$(get_version_component_range 5)"
+MY_PV3="$(get_version_component_range 6)"
+MY_P="${PN}_${MY_PV1}.svn.${MY_PV2}"
+
+DESCRIPTION="capi4hylafax adds a faxcapi modem to the hylafax enviroment"
+SRC_URI="mirror://debian/pool/main/c/capi4hylafax/${MY_P}.orig.tar.gz
+ mirror://debian/pool/main/c/capi4hylafax/${MY_P}-${MY_PV3}.diff.gz"
+HOMEPAGE="http://packages.qa.debian.org/c/capi4hylafax.html"
+
+S="${WORKDIR}/${PN}-svn"
+
+IUSE="unicode"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="amd64 ppc x86"
+
+DEPEND="net-dialup/capi4k-utils
+ media-libs/tiff
+ virtual/jpeg
+ sys-libs/zlib"
+
+RDEPEND="${DEPEND}
+ dev-util/dialog"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # apply debian patches + update configs
+ epatch "${WORKDIR}/${MY_P}-${MY_PV3}.diff"
+
+ # apply bugfix patch (see bug #145982)
+ epatch "${FILESDIR}/${P}-recvdev.diff"
+
+ eautoreconf
+
+ # fix location of fax spool
+ for i in config.faxCAPI Readme_src src/defaults.h.in debian/*.1; do
+ [ -f "${i}" ] && sed -i -e "s:/var/spool/hylafax:${FAX_SPOOL_DIR}:g" "${i}"
+ done
+
+ # fix location of fax config
+ sed -i -e "s:/etc/hylafax:${FAX_SPOOL_DIR}/etc:g" setupconffile
+
+ # fix name and location of logfile
+ sed -i -e "s:/var/spool/fax/log/capi4hylafax:/var/log/${PN}.log:" config.faxCAPI
+ sed -i -e "s:/tmp/capifax.log:/var/log/${PN}.log:" src/defaults.h.in config.faxCAPI
+
+ # patch man pages
+ sed -i -e "s:/usr/share/doc/capi4hylafax/:/usr/share/doc/${PF}/html/:g" \
+ -e "s:c2send:c2faxsend:g" -e "s:c2recv:c2faxrecv:g" \
+ -e "s:CAPI4HYLAFAXCONFIG \"1\":C2FAXADDMODEM \"8\":g" \
+ -e "s:capi4hylafaxconfig:c2faxaddmodem:g" debian/*.1
+ cp -f debian/capi4hylafaxconfig.1 debian/c2faxaddmodem.8
+
+ # if specified, convert all relevant files from latin1 to UTF-8
+ if use unicode; then
+ for i in config.faxCAPI; do
+ einfo "Converting ${i} to UTF-8"
+ iconv -f latin1 -t utf8 -o "${i}~" "${i}" && mv -f "${i}~" "${i}" || rm -f "${i}~"
+ done
+ fi
+}
+
+src_compile() {
+ econf --with-hylafax-spooldir="${FAX_SPOOL_DIR}" || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ keepdir "${FAX_SPOOL_DIR}"/{etc,recvq,pollq,log,status}
+ fowners uucp:uucp "${FAX_SPOOL_DIR}" "${FAX_SPOOL_DIR}"/{etc,recvq,pollq,log,status}
+ fperms 0700 "${FAX_SPOOL_DIR}"
+
+ make DESTDIR="${D}" install || die "make install failed"
+
+ # install setup script
+ newsbin setupconffile c2faxaddmodem
+
+ # install sample config
+ insinto "${FAX_SPOOL_DIR}/etc"
+ newins config.faxCAPI config.faxCAPI.default
+
+ # install docs
+ dodoc AUTHORS ChangeLog Readme_src
+ newdoc debian/changelog ChangeLog.debian
+ dohtml README.html LIESMICH.html
+
+ # install man pages
+ doman debian/c2fax*.[18]
+
+ # install examples
+ insinto /usr/share/doc/${PF}/examples
+ doins sample_faxrcvd faxrcvd config.faxCAPI fritz_pic.tif GenerateFileMail.pl
+ newins sample_AVMC4_config.faxCAPI config.faxCAPI_AVMC4
+ newins debian/faxsend sample_faxsend
+
+ # finally install init-script + config
+ newinitd "${FILESDIR}/${PN}.initd" ${PN}
+ newconfd "${FILESDIR}/${PN}.confd" ${PN}
+}
+
+pkg_postinst() {
+ einfo "To use capi4hylafax:"
+ einfo "Make sure that your isdn/capi devices are owned by"
+ einfo "the \"uucp\" user (see udev or devfsd config)."
+ einfo "Modify ${FAX_SPOOL_DIR}/etc/config.faxCAPI"
+ einfo "to suit your system."
+
+ if [ -f "${FAX_SPOOL_DIR}/etc/config.faxCAPI" ]; then
+ einfo
+ einfo "If you're upgrading from a previous version"
+ einfo "please check for new or changed options."
+ einfo "A sample default config is installed as:"
+ einfo "${FAX_SPOOL_DIR}/etc/config.faxCAPI.default"
+ else
+ # install default config
+ cp -f "${FAX_SPOOL_DIR}/etc/config.faxCAPI.default" \
+ "${FAX_SPOOL_DIR}/etc/config.faxCAPI"
+ fi
+
+ einfo
+ einfo "You should also check special options in:"
+ einfo "/etc/conf.d/${PN}"
+ einfo
+ einfo "If you want to use capi4hylafax together with"
+ einfo "hylafax, then please emerge net-misc/hylafax"
+ einfo
+ einfo "Then append the following line to your hylafax"
+ einfo "config file (${FAX_SPOOL_DIR}/etc/config):"
+ einfo "SendFaxCmd: /usr/bin/c2faxsend"
+}
diff --git a/net-misc/capi4hylafax/capi4hylafax-01.03.00.99.300.9.ebuild b/net-misc/capi4hylafax/capi4hylafax-01.03.00.99.300.9.ebuild
new file mode 100644
index 00000000000..760f04b39ef
--- /dev/null
+++ b/net-misc/capi4hylafax/capi4hylafax-01.03.00.99.300.9.ebuild
@@ -0,0 +1,133 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils versionator autotools
+
+FAX_SPOOL_DIR="/var/spool/fax"
+
+MY_PV1="$(get_version_component_range 1-4)"
+MY_PV2="$(get_version_component_range 5)"
+MY_PV3="$(get_version_component_range 6)"
+MY_P="${PN}_${MY_PV1}.svn.${MY_PV2}"
+
+DESCRIPTION="capi4hylafax adds a faxcapi modem to the hylafax enviroment"
+SRC_URI="mirror://debian/pool/main/c/capi4hylafax/${MY_P}.orig.tar.gz
+ mirror://debian/pool/main/c/capi4hylafax/${MY_P}-${MY_PV3}.diff.gz"
+HOMEPAGE="http://packages.qa.debian.org/c/capi4hylafax.html"
+
+S="${WORKDIR}/${PN}-svn"
+
+IUSE=""
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+DEPEND="net-dialup/capi4k-utils
+ app-shells/bash
+ media-libs/tiff
+ virtual/jpeg
+ sys-libs/zlib"
+
+RDEPEND="${DEPEND}
+ dev-util/dialog"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # apply debian patches + update configs
+ epatch "${WORKDIR}/${MY_P}-${MY_PV3}.diff"
+
+ # update autotools
+ eautoreconf
+
+ # fix location of fax spool
+ for i in config.faxCAPI Readme_src src/defaults.h.in debian/*.1; do
+ [ -f "${i}" ] && sed -i -e "s:/var/spool/hylafax:${FAX_SPOOL_DIR}:g" "${i}"
+ done
+
+ # fix location of fax config
+ sed -i -e "s:/etc/hylafax:${FAX_SPOOL_DIR}/etc:g" setupconffile
+
+ # fix name and location of logfile
+ sed -i -e "s:/var/spool/fax/log/capi4hylafax:/var/log/${PN}.log:" config.faxCAPI
+ sed -i -e "s:/tmp/capifax.log:/var/log/${PN}.log:" src/defaults.h.in config.faxCAPI
+
+ # patch man pages
+ sed -i -e "s:/usr/share/doc/capi4hylafax/:/usr/share/doc/${PF}/html/:g" \
+ -e "s:c2send:c2faxsend:g" -e "s:c2recv:c2faxrecv:g" \
+ -e "s:CAPI4HYLAFAXCONFIG \"1\":C2FAXADDMODEM \"8\":g" \
+ -e "s:capi4hylafaxconfig:c2faxaddmodem:g" debian/*.1
+ cp -f debian/capi4hylafaxconfig.1 debian/c2faxaddmodem.8
+}
+
+src_compile() {
+ econf --with-hylafax-spooldir="${FAX_SPOOL_DIR}" || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ keepdir "${FAX_SPOOL_DIR}"/{etc,recvq,pollq,log,status}
+ fowners uucp:uucp "${FAX_SPOOL_DIR}" "${FAX_SPOOL_DIR}"/{etc,recvq,pollq,log,status}
+ fperms 0700 "${FAX_SPOOL_DIR}"
+
+ make DESTDIR="${D}" install || die "make install failed"
+
+ # install setup script
+ newsbin setupconffile c2faxaddmodem
+
+ # install sample config
+ insinto "${FAX_SPOOL_DIR}/etc"
+ newins config.faxCAPI config.faxCAPI.default
+
+ # install docs
+ dodoc AUTHORS ChangeLog Readme_src
+ newdoc debian/changelog ChangeLog.debian
+ dohtml README.html LIESMICH.html
+
+ # install man pages
+ doman debian/c2fax*.[18]
+
+ # install examples
+ insinto /usr/share/doc/${PF}/examples
+ doins sample_faxrcvd config.faxCAPI fritz_pic.tif GenerateFileMail.pl
+ newins sample_AVMC4_config.faxCAPI config.faxCAPI_AVMC4
+ newins debian/faxsend sample_faxsend
+
+ # finally install init-script + config
+ newinitd "${FILESDIR}/${PN}.initd" ${PN}
+ newconfd "${FILESDIR}/${PN}.confd" ${PN}
+}
+
+pkg_postinst() {
+ elog "To use capi4hylafax:"
+ elog "Make sure that your isdn/capi devices are owned by"
+ elog "the \"uucp\" user (see udev or devfsd config)."
+ elog "Modify ${FAX_SPOOL_DIR}/etc/config.faxCAPI"
+ elog "to suit your system."
+
+ if [ -f "${FAX_SPOOL_DIR}/etc/config.faxCAPI" ]; then
+ elog
+ elog "If you're upgrading from a previous version"
+ elog "please check for new or changed options."
+ elog "A sample default config is installed as:"
+ elog "${FAX_SPOOL_DIR}/etc/config.faxCAPI.default"
+ else
+ # install default config
+ cp -f "${FAX_SPOOL_DIR}/etc/config.faxCAPI.default" \
+ "${FAX_SPOOL_DIR}/etc/config.faxCAPI"
+ fi
+
+ elog
+ elog "You should also check special options in:"
+ elog "/etc/conf.d/${PN}"
+ elog
+ elog "If you want to use capi4hylafax together with"
+ elog "hylafax, then please emerge net-misc/hylafax"
+ elog
+ elog "Then append the following line to your hylafax"
+ elog "config file (${FAX_SPOOL_DIR}/etc/config):"
+ elog "SendFaxCmd: /usr/bin/c2faxsend"
+}
diff --git a/net-misc/capi4hylafax/files/capi4hylafax-01.03.00.99.300.3-recvdev.diff b/net-misc/capi4hylafax/files/capi4hylafax-01.03.00.99.300.3-recvdev.diff
new file mode 100644
index 00000000000..ae56d740c92
--- /dev/null
+++ b/net-misc/capi4hylafax/files/capi4hylafax-01.03.00.99.300.3-recvdev.diff
@@ -0,0 +1,20 @@
+--- src/faxrecv/recvdev.cpp.orig 2006-08-15 11:13:33.000000000 +0200
++++ src/faxrecv/recvdev.cpp 2006-10-04 02:09:46.000000000 +0200
+@@ -114,7 +114,7 @@
+ CMultiString tmpDDIs;
+ CMultiString tmpMSNs;
+ CMultiString *pMSNs;
+- tSize FindPos;
++ tUInt FindPos;
+
+ ConfigAssignment_Item CntrlAssignments[] = {
+ { "Controller", ConfigAssignment_UInt, &tmpController },
+@@ -162,7 +162,7 @@
+ MSNlauf->RemoveChars ((tChar *)" \t_()[]{}\"'`TtPp,.:;");
+ if (MSNlauf->IsEmpty() == vFalse) {
+ FindPos = MSNlauf->FindChar ('-');
+- if (FindPos == MAXVAL_tSize) {
++ if (FindPos == MAXVAL_tUInt) {
+ dprint ("Add MSN-Value=(%s) ", MSNlauf->GetPointer());
+ switch (CIPMSNList.AddMSN (tmpController, MSNlauf)) {
+ case iErr_OutOfMemory:
diff --git a/net-misc/capi4hylafax/files/capi4hylafax.confd b/net-misc/capi4hylafax/files/capi4hylafax.confd
new file mode 100644
index 00000000000..40aa8cfe603
--- /dev/null
+++ b/net-misc/capi4hylafax/files/capi4hylafax.confd
@@ -0,0 +1,19 @@
+# configuraton file for /etc/init.d/capi4hylafax
+
+# Activate Logging (Filename have to be specified in the config file).
+#ACTIVATE_LOGGING="yes"
+
+# Specify the output format. Allowed types are:
+# HYLAFAX (default), TIFF, SFF, G3
+#OUTPUT_FORMAT="HYLAFAX"
+
+# Virtual device name only needed for Hylafax.
+#VIRTUAL_DEVICE="faxCAPI"
+
+# Name and path of the config file
+#CONFIG_FILE="/var/spool/fax/etc/config.faxCAPI"
+
+# Directory where received faxes are to be stored.
+# Do not set it in Hylafax mode (see OUTPUT_FORMAT)!
+#RECEIVE_DIR="/var/spool/fax/recvq"
+
diff --git a/net-misc/capi4hylafax/files/capi4hylafax.initd b/net-misc/capi4hylafax/files/capi4hylafax.initd
new file mode 100644
index 00000000000..bfba068a028
--- /dev/null
+++ b/net-misc/capi4hylafax/files/capi4hylafax.initd
@@ -0,0 +1,64 @@
+#!/sbin/runscript
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+depend() {
+ need capi
+}
+
+checkconfig() {
+ local DEFAULT_OUTPUT_FORMAT="HYLAFAX"
+ local DEFAULT_VIRTUAL_DEVICE="faxCAPI"
+ local DEFAULT_RECEIVE_DIR="/var/spool/fax"
+ local DEFAULT_CONFIG_FILE="/var/spool/fax/etc/config.faxCAPI"
+
+ [ -n "${CONFIG_FILE}" ] || CONFIG_FILE="${DEFAULT_CONFIG_FILE}"
+ [ -n "${OUTPUT_FORMAT}" ] || OUTPUT_FORMAT="${DEFAULT_OUTPUT_FORMAT}"
+ [ -n "${VIRTUAL_DEVICE}" ] || VIRTUAL_DEVICE="${DEFAULT_VIRTUAL_DEVICE}"
+ [ "${OUTPUT_FORMAT}" = "HYLAFAX" ] || DEFAULT_RECEIVE_DIR="/var/spool/fax/recvq"
+ [ -n "${RECEIVE_DIR}" ] || RECEIVE_DIR="${DEFAULT_RECEIVE_DIR}"
+
+ if [ ! -f "${CONFIG_FILE}" ]; then
+ eerror "You're missing ${CONFIG_FILE}"
+ return 1
+ fi
+
+ OPTIONS=""
+ PIDFILE="/var/run/c2faxrecv.pid"
+
+ [ "${ACTIVATE_LOGGING}" = "yes" ] && OPTIONS="${OPTIONS} -L"
+
+ [ "${OUTPUT_FORMAT}" = "${DEFAULT_OUTPUT_FORMAT}" ] || \
+ OPTIONS="${OPTIONS} -f ${OUTPUT_FORMAT}"
+
+ [ "${CONFIG_FILE}" = "${DEFAULT_CONFIG_FILE}" ] || \
+ OPTIONS="${OPTIONS} -C ${CONFIG_FILE}"
+
+ [ "${OUTPUT_FORMAT}" = "HYLAFAX" -a "${RECEIVE_DIR}" = "${DEFAULT_RECEIVE_DIR}" ] || \
+ OPTIONS="${OPTIONS} -q ${RECEIVE_DIR}"
+
+ if [ "${VIRTUAL_DEVICE}" != "${DEFAULT_VIRTUAL_DEVICE}" ]; then
+ PIDFILE="/var/run/c2faxrecv.${VIRTUAL_DEVICE}.pid"
+ OPTIONS="${OPTIONS} ${VIRTUAL_DEVICE}"
+ fi
+}
+
+start() {
+ checkconfig || return 1
+
+ ebegin "Starting CAPI4HylaFAX for ${VIRTUAL_DEVICE}"
+ start-stop-daemon -b -m --quiet --start --pidfile ${PIDFILE} \
+ --exec /usr/bin/c2faxrecv -- ${OPTIONS}
+ eend $?
+}
+
+stop() {
+ checkconfig || return 1
+
+ ebegin "Stopping CAPI4HylaFAX for ${VIRTUAL_DEVICE}"
+ start-stop-daemon >/dev/null --quiet --stop --pidfile ${PIDFILE} --retry 10 && \
+ /bin/rm -f ${PIDFILE}
+ eend $?
+}
+
diff --git a/net-misc/capi4hylafax/metadata.xml b/net-misc/capi4hylafax/metadata.xml
new file mode 100644
index 00000000000..ed4bdf3ce27
--- /dev/null
+++ b/net-misc/capi4hylafax/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <longdescription lang="en">
+ capi4hylafax adds a faxcapi modem to the hylafax enviroment. So you can
+ send and receive FAX documents with CAPI 2.0 fax controllers via a
+ hylafax server.
+ </longdescription>
+ <longdescription lang="ja">
+ capi4hylafax は hylafax 環境に faxcopi
+ モデムを加えます。つまり hylafax
+ サーバに対して CAPI 2.0 fax コントローラ経由で FAX
+ ドキュメントを送信したり
+ 受信したりできるようになります。
+ </longdescription>
+</pkgmetadata>