summaryrefslogtreecommitdiff
path: root/net-misc/clamz
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-misc/clamz
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-misc/clamz')
-rw-r--r--net-misc/clamz/Manifest2
-rw-r--r--net-misc/clamz/clamz-0.4.ebuild44
-rw-r--r--net-misc/clamz/clamz-0.5.ebuild44
-rw-r--r--net-misc/clamz/metadata.xml8
4 files changed, 98 insertions, 0 deletions
diff --git a/net-misc/clamz/Manifest b/net-misc/clamz/Manifest
new file mode 100644
index 00000000000..ac0ca6aac9a
--- /dev/null
+++ b/net-misc/clamz/Manifest
@@ -0,0 +1,2 @@
+DIST clamz-0.4.tar.gz 73830 SHA256 ecc09d09ad329f2e24c9381983a56de3c944e3a933183ca342d25d5917f34968
+DIST clamz-0.5.tar.gz 75001 SHA256 5a63f23f15dfa6c2af00ff9531ae9bfcca0facfe5b1aa82790964f050a09832b
diff --git a/net-misc/clamz/clamz-0.4.ebuild b/net-misc/clamz/clamz-0.4.ebuild
new file mode 100644
index 00000000000..95e66d6b0f5
--- /dev/null
+++ b/net-misc/clamz/clamz-0.4.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=3
+inherit fdo-mime
+
+DESCRIPTION="Command-line downloader for the Amazon.com MP3 music store"
+HOMEPAGE="http://code.google.com/p/clamz/"
+SRC_URI="http://clamz.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="dev-libs/expat
+ net-misc/curl
+ dev-libs/libgcrypt:0"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_configure() {
+ UPDATE_MIME_DATABASE=true \
+ UPDATE_DESKTOP_DATABASE=true \
+ econf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Install failed"
+ dodoc README
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+ einfo "To link clamz with your amazon.com account, visit:"
+ einfo " http://www.amazon.com/gp/dmusic/after_download_manager_install.html"
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+}
diff --git a/net-misc/clamz/clamz-0.5.ebuild b/net-misc/clamz/clamz-0.5.ebuild
new file mode 100644
index 00000000000..c62f4418cbc
--- /dev/null
+++ b/net-misc/clamz/clamz-0.5.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit fdo-mime
+
+DESCRIPTION="Command-line downloader for the Amazon.com MP3 music store"
+HOMEPAGE="http://code.google.com/p/clamz/"
+SRC_URI="http://clamz.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-libs/expat
+ net-misc/curl
+ dev-libs/libgcrypt:0"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_configure() {
+ UPDATE_MIME_DATABASE=true \
+ UPDATE_DESKTOP_DATABASE=true \
+ econf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Install failed"
+ dodoc README
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+ einfo "To link clamz with your amazon.com account, visit:"
+ einfo " http://www.amazon.com/gp/dmusic/after_download_manager_install.html"
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+}
diff --git a/net-misc/clamz/metadata.xml b/net-misc/clamz/metadata.xml
new file mode 100644
index 00000000000..e5d9d408ffc
--- /dev/null
+++ b/net-misc/clamz/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>desktop-misc</herd>
+ <upstream>
+ <remote-id type="google-code">clamz</remote-id>
+ </upstream>
+</pkgmetadata>