summaryrefslogtreecommitdiff
path: root/net-misc/clipgrab
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-misc/clipgrab
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-misc/clipgrab')
-rw-r--r--net-misc/clipgrab/Manifest2
-rw-r--r--net-misc/clipgrab/clipgrab-3.4.11.ebuild31
-rw-r--r--net-misc/clipgrab/clipgrab-3.4.9-r1.ebuild31
-rw-r--r--net-misc/clipgrab/files/clipgrab-3.2.0.10-obey.patch82
-rw-r--r--net-misc/clipgrab/files/clipgrab-3.2.1.0-obey.patch85
-rw-r--r--net-misc/clipgrab/files/clipgrab-3.4.2-obey.patch38
-rw-r--r--net-misc/clipgrab/metadata.xml8
7 files changed, 277 insertions, 0 deletions
diff --git a/net-misc/clipgrab/Manifest b/net-misc/clipgrab/Manifest
new file mode 100644
index 00000000000..50bf53bb03d
--- /dev/null
+++ b/net-misc/clipgrab/Manifest
@@ -0,0 +1,2 @@
+DIST clipgrab-3.4.11.tar.bz2 371620 SHA256 48f7cbd9a503b19246ae2d31af8d2bba7c57945f5ba8ca4fcf7bf6b3a265bd83 SHA512 89613a4e3096e980b09eef7a48b7bb6eda60ecd3d542afd5621880e0cb62e3e5c385cf0072fc4a96fadab8f72d8f717957f396cb399d3a0d25d48a346bc8cf31 WHIRLPOOL fffd7c5ed4178fac9f9bb133cfb90cc8daaeb45d45ab665aed3c156745e3fe0881f32bcaef07f0cba4800fa0ddcf463e34563e0505946336d9c7d952c6c5a792
+DIST clipgrab-3.4.9.tar.bz2 372342 SHA256 e1aaf9c5f55788ac580ba645f0368b8bdf5b65dbe133cd7e08df9ffed8c0546d SHA512 24efcf23b4553c47845efbbe69a9cee6d322a830693ba02a7900b41987bd449c65a81013c0ff7aa3a0cccaea528225fe6d11d43e56361fbada35fdb37003420b WHIRLPOOL 51bb35f1b4cb9c59e0cff55e95d1b4be288b97b25ac7f9c67a7dd4b12a39f242def7a2c3e2fac8b9af8201934172ec3685f5986bb3808be0cf0618c7878f79ab
diff --git a/net-misc/clipgrab/clipgrab-3.4.11.ebuild b/net-misc/clipgrab/clipgrab-3.4.11.ebuild
new file mode 100644
index 00000000000..886b8bbdad2
--- /dev/null
+++ b/net-misc/clipgrab/clipgrab-3.4.11.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit qt4-r2 eutils
+
+DESCRIPTION="Download from various internet video services like Youtube etc."
+HOMEPAGE="http://clipgrab.de/en"
+SRC_URI="http://${PN}.de/download/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-qt/qtwebkit:4"
+RDEPEND="${DEPEND}
+ || ( media-video/libav media-video/ffmpeg )"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-3.4.2-obey.patch"
+)
+
+src_install() {
+ dobin ${PN}
+
+ newicon icon.png ${PN}.png
+ make_desktop_entry clipgrab Clipgrab "" "Qt;Video;AudioVideo;"
+}
diff --git a/net-misc/clipgrab/clipgrab-3.4.9-r1.ebuild b/net-misc/clipgrab/clipgrab-3.4.9-r1.ebuild
new file mode 100644
index 00000000000..886b8bbdad2
--- /dev/null
+++ b/net-misc/clipgrab/clipgrab-3.4.9-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit qt4-r2 eutils
+
+DESCRIPTION="Download from various internet video services like Youtube etc."
+HOMEPAGE="http://clipgrab.de/en"
+SRC_URI="http://${PN}.de/download/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-qt/qtwebkit:4"
+RDEPEND="${DEPEND}
+ || ( media-video/libav media-video/ffmpeg )"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-3.4.2-obey.patch"
+)
+
+src_install() {
+ dobin ${PN}
+
+ newicon icon.png ${PN}.png
+ make_desktop_entry clipgrab Clipgrab "" "Qt;Video;AudioVideo;"
+}
diff --git a/net-misc/clipgrab/files/clipgrab-3.2.0.10-obey.patch b/net-misc/clipgrab/files/clipgrab-3.2.0.10-obey.patch
new file mode 100644
index 00000000000..9ffee8a94fb
--- /dev/null
+++ b/net-misc/clipgrab/files/clipgrab-3.2.0.10-obey.patch
@@ -0,0 +1,82 @@
+--- clipgrab-3.2.0.10/clipgrab.cpp
++++ clipgrab-3.2.0.10/clipgrab.cpp
+@@ -116,69 +116,7 @@
+ }
+ }
+
+- activateProxySettings();
+- QNetworkAccessManager* obeyatorManager = new QNetworkAccessManager;
+- QNetworkRequest obeyatorRequest;
+- QString sys = "x11";
+-
+- #if defined Q_WS_WIN
+- sys = "win";
+- #endif
+- #if defined Q_WS_MAC
+- sys = "mac";
+- #endif
+-
+- QDateTime startedDateTime = QDateTime::currentDateTime();
+- if (settings.value("firstStarted", 0).toInt() == 0)
+- {
+- settings.setValue("firstStarted", startedDateTime.toTime_t());
+- }
+- if (settings.value("firstStarted-" + version, 0) == 0)
+- {
+- settings.setValue("firstStarted-" + version, startedDateTime.toTime_t());
+- }
+- obeyatorRequest.setUrl("http://clipgrab.de/or.php?version=" + version +"&lang="+QLocale::system().name().split("_")[0]+"&sys="+sys+"&current=" + settings.value("firstStarted-" + version, startedDateTime.toTime_t()).toString()+"&first="+settings.value("firstStarted", startedDateTime.toTime_t()).toString());
+- obeyatorManager->get(obeyatorRequest);;
+- connect(obeyatorManager, SIGNAL(finished(QNetworkReply*)), this, SLOT(obey(QNetworkReply*)));
+-
+ connect(QApplication::clipboard(), SIGNAL(dataChanged()), this, SLOT(clipboardChanged()));
+-
+-}
+-
+-void ClipGrab::obey(QNetworkReply* reply)
+-{
+- bool execute = false;
+- if (reply->bytesAvailable())
+- {
+- QStringList commands = QString(reply->readAll()).split("\n");
+- for (int i = 0; i < commands.size(); ++i)
+- {
+- if (commands.at(i).split("|").size() > 0)
+- {
+- if (commands.at(i).split("|").size() == 3 && settings.value(commands.at(i).split("|").at(2)) == "true")
+- {
+- execute = false;
+- }
+- else
+- {
+- execute = true;
+- qDebug() << commands.at(i).split("|").size();
+- if (commands.at(i).split("|").size() == 3)
+- {
+- settings.setValue(commands.at(i).split("|").at(2), "true");
+- }
+- }
+-
+- if (execute == true)
+- {
+- if (commands.at(i).split("|").at(0).trimmed() == "url")
+- {
+- QDesktopServices::openUrl(QUrl(commands.at(i).split("|").at(1)));
+- }
+- }
+- }
+- }
+- }
+ }
+
+ void ClipGrab::determinePortal(QString url)
+--- clipgrab-3.2.0.10/clipgrab.h
++++ clipgrab-3.2.0.10/clipgrab.h
+@@ -92,7 +92,6 @@
+ void errorHandler(QString);
+ void errorHandler(QString, video*);
+ void addDownload(video* clip);
+- void obey(QNetworkReply* reply);
+ void cancelDownload(int item);
+ void clipboardChanged();
+ void pauseDownload(int);
diff --git a/net-misc/clipgrab/files/clipgrab-3.2.1.0-obey.patch b/net-misc/clipgrab/files/clipgrab-3.2.1.0-obey.patch
new file mode 100644
index 00000000000..16eee39e84a
--- /dev/null
+++ b/net-misc/clipgrab/files/clipgrab-3.2.1.0-obey.patch
@@ -0,0 +1,85 @@
+--- clipgrab-3.2.1.0/clipgrab.cpp
++++ clipgrab-3.2.1.0/clipgrab.cpp
+@@ -128,71 +128,10 @@
+ }
+ }
+
+- activateProxySettings();
+- QNetworkAccessManager* obeyatorManager = new QNetworkAccessManager;
+- QNetworkRequest obeyatorRequest;
+- QString sys = "x11";
+-
+- #if defined Q_WS_WIN
+- sys = "win";
+- #endif
+- #if defined Q_WS_MAC
+- sys = "mac";
+- #endif
+-
+- QDateTime startedDateTime = QDateTime::currentDateTime();
+- if (settings.value("firstStarted", 0).toInt() == 0)
+- {
+- settings.setValue("firstStarted", startedDateTime.toTime_t());
+- }
+- if (settings.value("firstStarted-" + version, 0) == 0)
+- {
+- settings.setValue("firstStarted-" + version, startedDateTime.toTime_t());
+- }
+- obeyatorRequest.setUrl("http://clipgrab.de/or.php?version=" + version +"&lang="+QLocale::system().name().split("_")[0]+"&sys="+sys+"&current=" + settings.value("firstStarted-" + version, startedDateTime.toTime_t()).toString()+"&first="+settings.value("firstStarted", startedDateTime.toTime_t()).toString());
+- obeyatorManager->get(obeyatorRequest);
+- connect(obeyatorManager, SIGNAL(finished(QNetworkReply*)), this, SLOT(obey(QNetworkReply*)));
+-
+ connect(QApplication::clipboard(), SIGNAL(dataChanged()), this, SLOT(clipboardChanged()));
+
+ }
+
+-void ClipGrab::obey(QNetworkReply* reply)
+-{
+- if (reply->bytesAvailable())
+- {
+- QStringList commands = QString(reply->readAll()).split("\n");
+- qDebug() << commands;
+- for (int i = 0; i < commands.size(); ++i)
+- {
+- QStringList command = commands.at(i).split("|");
+- if (!command.isEmpty())
+- {
+- if (command.at(0) == "url")
+- {
+- if (command.size() == 2 || (command.size() == 3 && settings.value(command.at(2)).toString() != "true"))
+- {
+- if (!(command.at(1).contains("update") && this->settings.value("DisableUpdateNotifications", false) == true))
+- {
+- QDesktopServices::openUrl(QUrl(command.at(1)));
+- }
+- if (command.size() == 3)
+- {
+- settings.setValue(command.at(2), "true");
+- }
+- }
+- }
+- else if (command.at(0) == "set" && command.size() == 3)
+- {
+- settings.setValue(command.at(1), command.at(2));
+- }
+- }
+- }
+- }
+- else {qDebug() << "nothing";
+- }
+-}
+-
+ void ClipGrab::determinePortal(QString url)
+ {
+
+diff -ru clipgrab-3.2.1.0.orig/clipgrab.h clipgrab-3.2.1.0/clipgrab.h
+--- clipgrab-3.2.1.0.orig/clipgrab.h 2013-06-20 17:01:28.000000000 +0200
++++ clipgrab-3.2.1.0/clipgrab.h 2013-06-23 17:57:14.187000000 +0200
+@@ -92,7 +92,6 @@
+ void errorHandler(QString);
+ void errorHandler(QString, video*);
+ void addDownload(video* clip);
+- void obey(QNetworkReply* reply);
+ void cancelDownload(int item);
+ void clipboardChanged();
+ void pauseDownload(int);
diff --git a/net-misc/clipgrab/files/clipgrab-3.4.2-obey.patch b/net-misc/clipgrab/files/clipgrab-3.4.2-obey.patch
new file mode 100644
index 00000000000..353278d09d3
--- /dev/null
+++ b/net-misc/clipgrab/files/clipgrab-3.4.2-obey.patch
@@ -0,0 +1,38 @@
+--- clipgrab-3.4.2/clipgrab.cpp
++++ clipgrab-3.4.2/clipgrab.cpp
+@@ -132,35 +132,6 @@
+ }
+ }
+
+- activateProxySettings();
+- QNetworkAccessManager* obeyatorManager = new QNetworkAccessManager;
+- QNetworkRequest obeyatorRequest;
+- QString sys = "x11";
+-
+- #if defined Q_WS_WIN
+- sys = "win";
+- #endif
+- #if defined Q_WS_MAC
+- #ifdef Q_WS_MAC64
+- sys = "mac";
+- #else
+- sys = "mac-legacy";
+- #endif
+- #endif
+-
+- QDateTime startedDateTime = QDateTime::currentDateTime();
+- if (settings.value("firstStarted", 0).toInt() == 0)
+- {
+- settings.setValue("firstStarted", startedDateTime.toTime_t());
+- }
+- if (settings.value("firstStarted-" + version, 0) == 0)
+- {
+- settings.setValue("firstStarted-" + version, startedDateTime.toTime_t());
+- }
+- obeyatorRequest.setUrl("http://clipgrab.de/or.php?version=" + version +"&lang="+QLocale::system().name().split("_")[0]+"&sys="+sys+"&current=" + settings.value("firstStarted-" + version, startedDateTime.toTime_t()).toString()+"&first="+settings.value("firstStarted", startedDateTime.toTime_t()).toString());
+- obeyatorManager->get(obeyatorRequest);
+- connect(obeyatorManager, SIGNAL(finished(QNetworkReply*)), this, SLOT(obey(QNetworkReply*)));
+-
+ connect(QApplication::clipboard(), SIGNAL(dataChanged()), this, SLOT(clipboardChanged()));
+
+ }
diff --git a/net-misc/clipgrab/metadata.xml b/net-misc/clipgrab/metadata.xml
new file mode 100644
index 00000000000..58a826b66ff
--- /dev/null
+++ b/net-misc/clipgrab/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>xmw@gentoo.org</email>
+ <name>Michael Weber</name>
+</maintainer>
+</pkgmetadata>