summaryrefslogtreecommitdiff
path: root/net-misc/clusterssh
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-misc/clusterssh
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-misc/clusterssh')
-rw-r--r--net-misc/clusterssh/Manifest1
-rw-r--r--net-misc/clusterssh/clusterssh-4.03.03.ebuild55
-rw-r--r--net-misc/clusterssh/clusterssh-9999.ebuild45
-rw-r--r--net-misc/clusterssh/files/clusterssh-4.01.01-testfix-1.patch87
-rw-r--r--net-misc/clusterssh/metadata.xml12
5 files changed, 200 insertions, 0 deletions
diff --git a/net-misc/clusterssh/Manifest b/net-misc/clusterssh/Manifest
new file mode 100644
index 00000000000..7336cc50f82
--- /dev/null
+++ b/net-misc/clusterssh/Manifest
@@ -0,0 +1 @@
+DIST App-ClusterSSH-4.01_05.tar.gz 71502 SHA256 e57685ce83aa74a15fef868ac6d7aed11de5c81252db7c65332ad1c9972aaa3e SHA512 4b63b91684c981a28871e5264502c66435b531ae3c4bad2eab2571f8b237d43e5f45ed93d036e7497c713f2982a110d93a3055ae0004d4f33e7786df9aa56ff8 WHIRLPOOL 96df13f6f3096829949b1db8f26d8a2de8b3568597bc1b82d4d26f0fe56a9c303651f2ab58c77fa94f0e494cb90fba9e331de9f242fb0d7bfa4a8eb7796d6c48
diff --git a/net-misc/clusterssh/clusterssh-4.03.03.ebuild b/net-misc/clusterssh/clusterssh-4.03.03.ebuild
new file mode 100644
index 00000000000..5846888ac12
--- /dev/null
+++ b/net-misc/clusterssh/clusterssh-4.03.03.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MY_PN="App-ClusterSSH"
+MODULE_AUTHOR="DUNCS"
+MODULE_VERSION="4.01_05"
+
+inherit eutils perl-module versionator
+
+DESCRIPTION="Concurrent Multi-Server Terminal Access"
+HOMEPAGE="http://clusterssh.sourceforge.net"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ dev-perl/Exception-Class
+ dev-perl/Readonly
+ dev-perl/Test-Pod
+ dev-perl/Test-Pod-Coverage
+ dev-perl/Test-Trap
+ dev-perl/Test-DistManifest
+ dev-perl/Try-Tiny
+ dev-perl/perl-tk
+ dev-perl/Config-Simple
+ dev-perl/X11-Protocol
+ dev-perl/XML-Simple
+ x11-apps/xlsfonts
+ x11-terms/xterm"
+DEPEND="
+ ${RDEPEND}
+ dev-perl/File-Which
+ dev-perl/Module-Build
+ dev-perl/Test-Pod
+ dev-perl/Test-Differences"
+
+#S="${WORKDIR}"/${MY_P}
+
+SRC_TEST="do parallel"
+
+src_prepare() {
+ # broken test, check again for new releases
+ sed \
+ -e '/boilerplate/d' \
+ -e '/manifest.t/d' \
+ -i MANIFEST || die
+ rm t/boilerplate.t t/manifest.t || die
+
+ perl-module_src_prepare
+}
diff --git a/net-misc/clusterssh/clusterssh-9999.ebuild b/net-misc/clusterssh/clusterssh-9999.ebuild
new file mode 100644
index 00000000000..05f0fea627c
--- /dev/null
+++ b/net-misc/clusterssh/clusterssh-9999.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit git-2 perl-module
+
+EGIT_REPO_URI="git://clusterssh.git.sourceforge.net/gitroot/clusterssh/clusterssh"
+
+DESCRIPTION="Concurrent Multi-Server Terminal Access"
+HOMEPAGE="http://clusterssh.sourceforge.net"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE="test"
+
+RDEPEND="
+ dev-perl/Exception-Class
+ dev-perl/Readonly
+ dev-perl/Test-Pod
+ dev-perl/Test-Pod-Coverage
+ dev-perl/Test-Trap
+ dev-perl/Test-DistManifest
+ dev-perl/Try-Tiny
+ dev-perl/perl-tk
+ dev-perl/Config-Simple
+ dev-perl/X11-Protocol
+ dev-perl/XML-Simple
+ x11-apps/xlsfonts
+ x11-terms/xterm"
+DEPEND="
+ ${RDEPEND}
+ dev-perl/File-Which
+ dev-perl/Module-Build
+ dev-perl/Test-Pod
+ test? ( dev-perl/Test-Differences )"
+
+SRC_TEST="do parallel"
+
+src_unpack() {
+ git-2_src_unpack
+ perl-module_src_unpack
+}
diff --git a/net-misc/clusterssh/files/clusterssh-4.01.01-testfix-1.patch b/net-misc/clusterssh/files/clusterssh-4.01.01-testfix-1.patch
new file mode 100644
index 00000000000..666a1c6fe9c
--- /dev/null
+++ b/net-misc/clusterssh/files/clusterssh-4.01.01-testfix-1.patch
@@ -0,0 +1,87 @@
+diff --git a/t/15config.t b/t/15config.t
+index 81d8f70..522997b 100644
+--- a/t/15config.t
++++ b/t/15config.t
+@@ -8,6 +8,7 @@ use Test::More;
+ use Test::Trap;
+ use File::Which qw(which);
+ use File::Temp qw(tempdir);
++use Test::Differences;
+
+ use Readonly;
+
+@@ -72,8 +73,8 @@ Readonly::Hash my %default_config => {
+ history_height => 10,
+
+ command => q{},
+- title => q{15CONFIG.T},
+- comms => q{ssh},
++ title => q{15CONFIG.T},
++ comms => q{ssh},
+ max_host_menu_items => 30,
+
+ max_addhost_menu_cluster_items => 6,
+@@ -241,11 +242,11 @@ is( $trap->stdout, q{}, 'Expecting no STDOUT' );
+ is( $trap->stderr, q{}, 'Expecting no STDERR' );
+ is_deeply( $config, \%expected, 'amended config is correct' );
+ is( $path, which('ls'), 'Found correct path to "ls"' );
+-is( $path, $newpath, 'No change made from find_binary');
++is( $path, $newpath, 'No change made from find_binary' );
+
+ # give false path to force another search
+ trap {
+- $newpath = $config->find_binary('/does/not/exist/'.$path);
++ $newpath = $config->find_binary( '/does/not/exist/' . $path );
+ };
+ is( $trap->leaveby, 'return', 'returned ok' );
+ isa_ok( $config, "App::ClusterSSH::Config" );
+@@ -254,7 +255,7 @@ is( $trap->stdout, q{}, 'Expecting no STDOUT' );
+ is( $trap->stderr, q{}, 'Expecting no STDERR' );
+ is_deeply( $config, \%expected, 'amended config is correct' );
+ is( $path, which('ls'), 'Found correct path to "ls"' );
+-is( $path, $newpath, 'No change made from find_binary');
++is( $path, $newpath, 'No change made from find_binary' );
+
+ note('Checks on loading configs');
+ note('empty dir');
+@@ -456,12 +457,12 @@ is( $trap->stderr,
+ );
+
+ note('Checking dump');
+-$config = App::ClusterSSH::Config->new();
++$config = App::ClusterSSH::Config->new(
++ send_menu_xml_file => $ENV{HOME} . '/.csshrc_send_menu' );
+ trap {
+ $config->dump();
+ };
+-my $expected = <<'EOF';
+-# Configuration dump produced by "cssh -u"
++my $expected = qq{# Configuration dump produced by "cssh -u"
+ auto_close=5
+ auto_quit=yes
+ console_position=
+@@ -486,7 +487,7 @@ screen_reserve_bottom=60
+ screen_reserve_left=0
+ screen_reserve_right=0
+ screen_reserve_top=0
+-send_menu_xml_file=/home/dferguson/.csshrc_send_menu
++send_menu_xml_file=} . $ENV{HOME} . qq{/.csshrc_send_menu
+ show_history=0
+ ssh_args=
+ telnet_args=
+@@ -509,10 +510,11 @@ use_all_a_records=0
+ use_hotkeys=yes
+ window_tiling=yes
+ window_tiling_direction=right
+-EOF
++};
++
+ isa_ok( $config, "App::ClusterSSH::Config" );
+-is( $trap->die, undef, 'die message correct' );
+-is( $trap->stdout, $expected, 'Expecting no STDOUT' );
+-is( $trap->stderr, q{}, 'Expecting no STDERR' );
++is( $trap->die, undef, 'die message correct' );
++eq_or_diff( $trap->stdout, $expected, 'Expecting no STDOUT' );
++is( $trap->stderr, q{}, 'Expecting no STDERR' );
+
+ done_testing();
diff --git a/net-misc/clusterssh/metadata.xml b/net-misc/clusterssh/metadata.xml
new file mode 100644
index 00000000000..8929edd8ee4
--- /dev/null
+++ b/net-misc/clusterssh/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>cluster</herd>
+ <longdescription lang="en">
+ ClusterSSH is a tool for making the same change on multiple servers
+ at the same time. The 'cssh' command opens an administration console
+ and an xterm to all specified hosts. Any text typed into
+ the administration console is replicated to all windows.
+ All windows may also be typed into directly.
+</longdescription>
+</pkgmetadata>