summaryrefslogtreecommitdiff
path: root/net-misc/dhcpcd
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2017-09-20 09:09:25 -0500
committerWilliam Hubbs <williamh@gentoo.org>2017-09-20 09:28:45 -0500
commitcaddc3ce86f52b544158a81144ebf7f7140db679 (patch)
tree6ab1db07f25c5eb381984460acc2300602a5f7ac /net-misc/dhcpcd
parenta7f644930f10b6ffad03b3d918366b88b0230471 (diff)
downloadgentoo-caddc3ce86f52b544158a81144ebf7f7140db679.tar.gz
gentoo-caddc3ce86f52b544158a81144ebf7f7140db679.tar.xz
net-misc/dhcpcd: 7.0.0_rc2 version bump
Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'net-misc/dhcpcd')
-rw-r--r--net-misc/dhcpcd/Manifest1
-rw-r--r--net-misc/dhcpcd/dhcpcd-7.0.0_rc2.ebuild148
2 files changed, 149 insertions, 0 deletions
diff --git a/net-misc/dhcpcd/Manifest b/net-misc/dhcpcd/Manifest
index 9f56dff0801..7ce3456e92a 100644
--- a/net-misc/dhcpcd/Manifest
+++ b/net-misc/dhcpcd/Manifest
@@ -4,3 +4,4 @@ DIST dhcpcd-6.11.3.tar.xz 194892 SHA256 5abd12c4df2947d608f60a35227f9bf8ae8ab9de
DIST dhcpcd-6.11.5.tar.xz 198080 SHA256 6f9674dc7e27e936cc787175404a6171618675ecfb6903ab9887b1b66a87d69e SHA512 a23d5dde66567c4addbc86c8b3fbf2c5d4dba3b463659729778a310306ab0e949be8998154ef15401ac2d289bde2f090d44492bba6a1becd2f01890d4efe7051 WHIRLPOOL 1b4bdd56112db20a0c6b0c843549f7c9cd8c534a9353df026d2c63a4b4bfd624f7fbc68282e04fd4f4c7c257d996e5019d3aa624f01b532074311d63b151164f
DIST dhcpcd-7.0.0-beta3.tar.xz 203440 SHA256 ba8af748d0d1aa8daa8ba6813c1cf395f517bb51fe4274309170af9d2f1a89ef SHA512 b71154fa2596826e23820df984992e8786a6b89588648db60e9340a383b67fdb555307e9a47b7c33097ed4191fdb911e443c6bf9fc76b0194770e66e2de64b95 WHIRLPOOL 211564a4c218853bf3c6f219ffa36ef3d14fe3cc355bb5931bb98d5461717d0145145511540ab93ad4dcf99640c48ddcb1d82fc56361c329764c0756c12881a6
DIST dhcpcd-7.0.0-rc1.tar.xz 204496 SHA256 8d4134596f1c8a647d94291fea0ed6f39dad648a4822472b481dfe48407b1cd3 SHA512 536ed4c09638a7a0fb16ad6a4a16fd74242ffbe2fe53e183c6756d2c62c94ce02869c95e828fbf3aa49aca06a129ab710195bf3d1dc9c9b52ac550ec51f68a1e WHIRLPOOL ec6898bbba3f4f2f42f9b8f16dd60f8b4b64170e4ad6c7e1326a80afd32241ad6b3ea941bfeb4e7113bd26ecb597fa04aebd1e1626c214ee10e48011251b065f
+DIST dhcpcd-7.0.0-rc2.tar.xz 206108 SHA256 ddae2ccf7c41a3ea5508e8adb2b7b9bbcd2b8a1ebe20871982243e513e83101a SHA512 a3e596c605c8ffe9f87f7113522f460d24a639b54dcc31182c70c3d0589d34d8c1cc765d5dfcfc6fd026697846866f7aa5714ef0d0d9eb049404973ef21f8ec7 WHIRLPOOL 46da14e26fb62320051e3457476d506847fa5630b898d01af14c7726175cfa9fcb01f505af5fe1668a89a2972f9ae40d46aad2918065c3f994c064a9b17dcb05
diff --git a/net-misc/dhcpcd/dhcpcd-7.0.0_rc2.ebuild b/net-misc/dhcpcd/dhcpcd-7.0.0_rc2.ebuild
new file mode 100644
index 00000000000..deffde72be0
--- /dev/null
+++ b/net-misc/dhcpcd/dhcpcd-7.0.0_rc2.ebuild
@@ -0,0 +1,148 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+if [[ ${PV} == "9999" ]]; then
+ EGIT_REPO_URI="git://roy.marples.name/dhcpcd"
+ inherit git-r3
+else
+ MY_P="${P/_alpha/-alpha}"
+ MY_P="${MY_P/_beta/-beta}"
+ MY_P="${MY_P/_rc/-rc}"
+ SRC_URI="http://roy.marples.name/downloads/${PN}/${MY_P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux"
+ S="${WORKDIR}/${MY_P}"
+fi
+
+inherit eutils systemd toolchain-funcs
+
+DESCRIPTION="A fully featured, yet light weight RFC2131 compliant DHCP client"
+HOMEPAGE="http://roy.marples.name/projects/dhcpcd/"
+LICENSE="BSD-2"
+SLOT="0"
+IUSE="elibc_glibc +embedded ipv6 kernel_linux +udev"
+
+COMMON_DEPEND="udev? ( virtual/udev )"
+DEPEND="${COMMON_DEPEND}"
+RDEPEND="${COMMON_DEPEND}"
+
+src_configure()
+{
+ local dev hooks rundir
+ use udev || dev="--without-dev --without-udev"
+ hooks="--with-hook=ntp.conf"
+ use elibc_glibc && hooks="${hooks} --with-hook=yp.conf"
+ use kernel_linux && rundir="--rundir=${EPREFIX}/run"
+ econf \
+ --prefix="${EPREFIX}" \
+ --libexecdir="${EPREFIX}/lib/dhcpcd" \
+ --dbdir="${EPREFIX}/var/lib/dhcpcd" \
+ --localstatedir="${EPREFIX}/var" \
+ ${rundir} \
+ $(use_enable embedded) \
+ $(use_enable ipv6) \
+ ${dev} \
+ CC="$(tc-getCC)" \
+ ${hooks}
+}
+
+src_install()
+{
+ default
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+ systemd_dounit "${FILESDIR}"/${PN}.service
+}
+
+pkg_postinst()
+{
+ local dbdir="${EROOT%/}"/var/lib/dhcpcd old_files=
+
+ local old_old_duid="${EROOT%/}"/var/lib/dhcpcd/dhcpcd.duid
+ local old_duid="${EROOT%/}"/etc/dhcpcd.duid
+ local new_duid="${dbdir}"/duid
+ if [ -e "${old_old_duid}" ]; then
+ # Upgrade the duid file to the new format if needed
+ if ! grep -q '..:..:..:..:..:..' "${old_old_duid}"; then
+ sed -i -e 's/\(..\)/\1:/g; s/:$//g' "${old_old_duid}"
+ fi
+
+ # Move the duid to /etc, a more sensible location
+ if [ ! -e "${old_duid}" ]; then
+ cp -p "${old_old_duid}" "${new_duid}"
+ fi
+ old_files="${old_files} ${old_old_duid}"
+ fi
+
+ # dhcpcd-7 moves the files out of /etc
+ if [ -e "${old_duid}" ]; then
+ if [ ! -e "${new_duid}" ]; then
+ cp -p "${old_duid}" "${new_duid}"
+ fi
+ old_files="${old_files} ${old_duid}"
+ fi
+ local old_secret="${EROOT%/}"/etc/dhcpcd.secret
+ local new_secret="${dbdir}"/secret
+ if [ -e "${old_secret}" ]; then
+ if [ ! -e "${new_secret}" ]; then
+ cp -p "${old_secret}" "${new_secret}"
+ fi
+ old_files="${old_files} ${old_secret}"
+ fi
+
+ # dhcpcd-7 renames some files in /var/lib/dhcpcd
+ local old_rdm="${dbdir}"/dhcpcd-rdm.monotonic
+ local new_rdm="${dbdir}"/rdm_monotonic
+ if [ -e "${old_rdm}" ]; then
+ if [ ! -e "${new_rdm}" ]; then
+ cp -p "${old_rdm}" "${new_rdm}"
+ fi
+ old_files="${old_files} ${old_rdm}"
+ fi
+ local lease=
+ for lease in "${dbdir}"/dhcpcd-*.lease*; do
+ [ -f "$lease" ] || continue
+ old_files="${old_files} ${lease}"
+ local new_lease=$(basename "$lease" | sed -e "s/dhcpcd-//")
+ [ -e "${dbdir}/${new_lease}" ] && continue
+ cp "${lease}" "${dbdir}/${new_lease}"
+ done
+
+ # Warn about removing stale files
+ if [ -n "${old_files}" ]; then
+ elog
+ elog "dhcpcd-7 has copied dhcpcd.duid and dhcpcd.secret from"
+ elog "${EROOT%/}/etc to ${dbdir}"
+ elog "and copied leases in ${dbdir} to new files with the dhcpcd-"
+ elog "prefix dropped."
+ elog
+ elog "You should remove these files if you don't plan on reverting"
+ elog "to an older version:"
+ local old_file=
+ for old_file in ${old_files}; do
+ elog " ${old_file}"
+ done
+ fi
+
+ if [ -z "$REPLACING_VERSIONS" ]; then
+ elog
+ elog "dhcpcd has zeroconf support active by default."
+ elog "This means it will always obtain an IP address even if no"
+ elog "DHCP server can be contacted, which will break any existing"
+ elog "failover support you may have configured in your net configuration."
+ elog "This behaviour can be controlled with the noipv4ll configuration"
+ elog "file option or the -L command line switch."
+ elog "See the dhcpcd and dhcpcd.conf man pages for more details."
+
+ elog
+ elog "Dhcpcd has duid enabled by default, and this may cause issues"
+ elog "with some dhcp servers. For more information, see"
+ elog "https://bugs.gentoo.org/show_bug.cgi?id=477356"
+ fi
+
+ if ! has_version net-dns/bind-tools; then
+ elog
+ elog "If you activate the lookup-hostname hook to look up your hostname"
+ elog "using the dns, you need to install net-dns/bind-tools."
+ fi
+}