summaryrefslogtreecommitdiff
path: root/net-misc/directvnc
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-misc/directvnc
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-misc/directvnc')
-rw-r--r--net-misc/directvnc/Manifest2
-rw-r--r--net-misc/directvnc/directvnc-0.7.6-r1.ebuild43
-rw-r--r--net-misc/directvnc/directvnc-0.7.8.ebuild52
-rw-r--r--net-misc/directvnc/files/directvnc-0.7.6-mouse.patch30
-rw-r--r--net-misc/directvnc/files/directvnc-0.7.8-mouse.patch29
-rw-r--r--net-misc/directvnc/files/directvnc-mouse.patch77
-rw-r--r--net-misc/directvnc/metadata.xml15
7 files changed, 248 insertions, 0 deletions
diff --git a/net-misc/directvnc/Manifest b/net-misc/directvnc/Manifest
new file mode 100644
index 00000000000..3f7fe1c9030
--- /dev/null
+++ b/net-misc/directvnc/Manifest
@@ -0,0 +1,2 @@
+DIST directvnc-0.7.6.tar.gz 380677 SHA256 9e170e7e25a5cacd4f8ca9b808a62940ef24ccc33c7cef521b6e64a0be5e7134 SHA512 dd64fdc6bee5fc1aeb7ed7ccf18f0962db0f6b2733e20f7647065fb58907dbb499a048a12ef7d3ec84f5a45b1acccd6f4c2db39078fb2c2a224605f91d648a51 WHIRLPOOL 569dec31c543f98223d635402d35ca92fe2790f5d9a2dd3f52ef809c002df1ac6d33856553113e039875b69e6dc0a81f2f9c3c91be7b1ac13635754db18551cc
+DIST directvnc-0.7.8.tar.gz 374455 SHA256 07d6109aef5bba2df86f0dd658be7ed9d828801be0878eba3d32f041189d3330 SHA512 15c2cbca3c5ada18bf68f8cf8e4123504fc887a97b0aceb0e2c8d9db769414653b0e62c5896d041cba5daf2e911a83db9c70a2d2a509f309ae62e49d75c91271 WHIRLPOOL fdcc16e4209283ddce2975b2068fe77d19b7d136cb1316d6fcc95dad7875a26806c0858f1814f67214420004f00e300c7543a6672b372391f543a14b25886f54
diff --git a/net-misc/directvnc/directvnc-0.7.6-r1.ebuild b/net-misc/directvnc/directvnc-0.7.6-r1.ebuild
new file mode 100644
index 00000000000..e2c43f256a5
--- /dev/null
+++ b/net-misc/directvnc/directvnc-0.7.6-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+AUTOTOOLS_IN_SOURCE_BUILD=1
+AUTOTOOLS_AUTORECONF=1
+
+inherit eutils autotools-utils
+
+DESCRIPTION="Very thin VNC client for unix framebuffer systems"
+HOMEPAGE="http://drinkmilk.github.com/directvnc/"
+SRC_URI="http://github.com/downloads/drinkmilk/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~amd64"
+IUSE="+mouse dmalloc"
+
+RDEPEND="dev-libs/DirectFB[fbcon,dynload]
+ virtual/jpeg"
+
+DEPEND="${RDEPEND}
+ dmalloc? ( dev-libs/dmalloc )
+ x11-proto/xproto"
+
+DOCS=( NEWS THANKS )
+
+src_prepare() {
+ # Make mouse support optional
+ use mouse || epatch "${FILESDIR}/${P}-mouse.patch"
+ sed -i -e 's|$(prefix)/share/doc/@PACKAGE@|@docdir@|g' Makefile.am || die
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ myeconfargs=(
+ $(use_with dmalloc)
+ )
+
+ autotools-utils_src_configure
+}
diff --git a/net-misc/directvnc/directvnc-0.7.8.ebuild b/net-misc/directvnc/directvnc-0.7.8.ebuild
new file mode 100644
index 00000000000..287936a760e
--- /dev/null
+++ b/net-misc/directvnc/directvnc-0.7.8.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+AUTOTOOLS_IN_SOURCE_BUILD=1
+AUTOTOOLS_AUTORECONF=1
+
+inherit eutils autotools-utils
+
+DESCRIPTION="Very thin VNC client for unix framebuffer systems"
+HOMEPAGE="http://drinkmilk.github.com/directvnc/"
+SRC_URI="http://github.com/downloads/drinkmilk/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="+mouse dmalloc"
+
+RDEPEND="dev-libs/DirectFB[fbcon,dynload]
+ virtual/jpeg"
+
+DEPEND="${RDEPEND}
+ dmalloc? ( dev-libs/dmalloc )
+ x11-proto/xproto"
+
+DOCS=( NEWS THANKS )
+
+src_prepare() {
+ use mouse || epatch "${FILESDIR}"/${P}-mouse.patch
+
+ # fix package version
+ sed -i -e '/^AM_INIT_AUTOMAKE/s/0.7.7/0.7.8/g' configure.in || die
+ # fix build system don't respect --docdir option
+ sed -i -e 's|$(prefix)/share/doc/@PACKAGE@|@docdir@|g' Makefile.am || die
+
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ myeconfargs=(
+ $(use_with dmalloc)
+ )
+
+ autotools-utils_src_configure
+}
+
+pkg_postinst() {
+ einfo "To customize your keyboard mapping, please consult the manual"
+ einfo " commmand: man 7 directvnc-kbmapping"
+}
diff --git a/net-misc/directvnc/files/directvnc-0.7.6-mouse.patch b/net-misc/directvnc/files/directvnc-0.7.6-mouse.patch
new file mode 100644
index 00000000000..71d90166177
--- /dev/null
+++ b/net-misc/directvnc/files/directvnc-0.7.6-mouse.patch
@@ -0,0 +1,30 @@
+diff --git a/src/dfb.c b/src/dfb.c
+old mode 100755
+new mode 100644
+index 8de0f0a..0241c82
+--- a/src/dfb.c
++++ b/src/dfb.c
+@@ -28,7 +28,6 @@ IDirectFB *dfb = NULL;
+ IDirectFBSurface *primary;
+ IDirectFBDisplayLayer *layer;
+ IDirectFBInputDevice *keyboard;
+-IDirectFBInputDevice *mouse;
+ IDirectFBEventBuffer *input_buffer;
+ DFBResult err;
+ DFBSurfaceDescription dsc;
+@@ -70,7 +69,6 @@ dfb_init(int argc, char *argv[])
+ primary->GetSize (primary, &opt.client.width, &opt.client.height);
+
+ DFBCHECK(dfb->GetInputDevice( dfb, DIDID_KEYBOARD, &keyboard ));
+- DFBCHECK(dfb->GetInputDevice( dfb, DIDID_MOUSE, &mouse ));
+ DFBCHECK (dfb->CreateInputEventBuffer (dfb, DICAPS_ALL, DFB_TRUE, &input_buffer));
+ }
+
+@@ -84,7 +82,6 @@ dfb_deinit()
+ primary->Release( primary );
+ input_buffer->Release(input_buffer);
+ keyboard->Release( keyboard );
+- mouse->Release( mouse );
+ layer->Release( layer );
+ dfb->Release( dfb );
+ }
diff --git a/net-misc/directvnc/files/directvnc-0.7.8-mouse.patch b/net-misc/directvnc/files/directvnc-0.7.8-mouse.patch
new file mode 100644
index 00000000000..b37b381ae23
--- /dev/null
+++ b/net-misc/directvnc/files/directvnc-0.7.8-mouse.patch
@@ -0,0 +1,29 @@
+diff --git a/src/dfb.c b/src/dfb.c
+index 5335ea2..8f3adbc 100644
+--- a/src/dfb.c
++++ b/src/dfb.c
+@@ -28,7 +28,6 @@ IDirectFB *dfb = NULL;
+ IDirectFBSurface *primary = NULL;
+ IDirectFBDisplayLayer *layer = NULL;
+ IDirectFBInputDevice *keyboard = NULL;
+-IDirectFBInputDevice *mouse = NULL;
+ IDirectFBEventBuffer *input_buffer = NULL;
+ DFBResult err;
+ DFBSurfaceDescription dsc;
+@@ -70,7 +69,6 @@ dfb_init(int argc, char *argv[])
+ primary->GetSize (primary, &opt.client.width, &opt.client.height);
+
+ DFBCHECK(dfb->GetInputDevice( dfb, DIDID_KEYBOARD, &keyboard ));
+- DFBCHECK(dfb->GetInputDevice( dfb, DIDID_MOUSE, &mouse ));
+ DFBCHECK (dfb->CreateInputEventBuffer (dfb, DICAPS_ALL, DFB_TRUE, &input_buffer));
+ }
+
+@@ -87,8 +85,6 @@ dfb_deinit()
+ input_buffer->Release( input_buffer );
+ if ( keyboard )
+ keyboard->Release( keyboard );
+- if ( mouse )
+- mouse->Release( mouse );
+ if ( layer )
+ layer->Release( layer );
+ if ( dfb )
diff --git a/net-misc/directvnc/files/directvnc-mouse.patch b/net-misc/directvnc/files/directvnc-mouse.patch
new file mode 100644
index 00000000000..4396aef6a9a
--- /dev/null
+++ b/net-misc/directvnc/files/directvnc-mouse.patch
@@ -0,0 +1,77 @@
+*** dfb.c 2003-01-31 03:51:59.000000000 -0500
+--- dfb-new.c 2005-07-10 15:12:37.000000000 -0400
+***************
+*** 24,34 ****
+ /* DirectFB interfaces needed */
+ IDirectFB *dfb = NULL;
+ IDirectFBSurface *primary;
+ IDirectFBDisplayLayer *layer;
+ IDirectFBInputDevice *keyboard;
+! IDirectFBInputDevice *mouse;
+ IDirectFBEventBuffer *input_buffer;
+ DFBResult err;
+ DFBSurfaceDescription dsc;
+ DFBCardCapabilities caps;
+ DFBDisplayLayerConfig layer_config;
+--- 24,34 ----
+ /* DirectFB interfaces needed */
+ IDirectFB *dfb = NULL;
+ IDirectFBSurface *primary;
+ IDirectFBDisplayLayer *layer;
+ IDirectFBInputDevice *keyboard;
+! /* IDirectFBInputDevice *mouse; */
+ IDirectFBEventBuffer *input_buffer;
+ DFBResult err;
+ DFBSurfaceDescription dsc;
+ DFBCardCapabilities caps;
+ DFBDisplayLayerConfig layer_config;
+***************
+*** 64,74 ****
+ dsc.pixelformat = DSPF_RGB16;
+ DFBCHECK(dfb->CreateSurface(dfb, &dsc, &primary ));
+ primary->GetSize (primary, &opt.client.width, &opt.client.height);
+
+ DFBCHECK(dfb->GetInputDevice( dfb, DIDID_KEYBOARD, &keyboard ));
+! DFBCHECK(dfb->GetInputDevice( dfb, DIDID_MOUSE, &mouse ));
+ DFBCHECK (dfb->CreateInputEventBuffer (dfb, DICAPS_ALL, DFB_TRUE, &input_buffer));
+ }
+
+
+ /*
+--- 64,74 ----
+ dsc.pixelformat = DSPF_RGB16;
+ DFBCHECK(dfb->CreateSurface(dfb, &dsc, &primary ));
+ primary->GetSize (primary, &opt.client.width, &opt.client.height);
+
+ DFBCHECK(dfb->GetInputDevice( dfb, DIDID_KEYBOARD, &keyboard ));
+! /* DFBCHECK(dfb->GetInputDevice( dfb, DIDID_MOUSE, &mouse )); */
+ DFBCHECK (dfb->CreateInputEventBuffer (dfb, DICAPS_ALL, DFB_TRUE, &input_buffer));
+ }
+
+
+ /*
+***************
+*** 78,88 ****
+ dfb_deinit()
+ {
+ primary->Release( primary );
+ input_buffer->Release(input_buffer);
+ keyboard->Release( keyboard );
+! mouse->Release( mouse );
+ layer->Release( layer );
+ dfb->Release( dfb );
+ }
+
+ void
+--- 78,88 ----
+ dfb_deinit()
+ {
+ primary->Release( primary );
+ input_buffer->Release(input_buffer);
+ keyboard->Release( keyboard );
+! /* mouse->Release( mouse ); */
+ layer->Release( layer );
+ dfb->Release( dfb );
+ }
+
+ void
diff --git a/net-misc/directvnc/metadata.xml b/net-misc/directvnc/metadata.xml
new file mode 100644
index 00000000000..071297add33
--- /dev/null
+++ b/net-misc/directvnc/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>dlan@gentoo.org</email>
+ <name>Yixun Lan</name>
+ </maintainer>
+ <use>
+ <flag name="mouse">Adds mouse support</flag>
+ <flag name="dmalloc">Enable debugging with the dmalloc library</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">downloads/drinkmilk</remote-id>
+ </upstream>
+</pkgmetadata>