summaryrefslogtreecommitdiff
path: root/net-misc/fatrat
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-misc/fatrat
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-misc/fatrat')
-rw-r--r--net-misc/fatrat/Manifest1
-rw-r--r--net-misc/fatrat/fatrat-1.2.0_beta2.ebuild57
-rw-r--r--net-misc/fatrat/files/fatrat-1.2.0_beta2-build.patch29
-rw-r--r--net-misc/fatrat/files/fatrat-1.2.0_beta2-libcrypto_linking.patch13
-rw-r--r--net-misc/fatrat/metadata.xml15
5 files changed, 115 insertions, 0 deletions
diff --git a/net-misc/fatrat/Manifest b/net-misc/fatrat/Manifest
new file mode 100644
index 00000000000..89d22568698
--- /dev/null
+++ b/net-misc/fatrat/Manifest
@@ -0,0 +1 @@
+DIST fatrat-1.2.0_beta2.tar.xz 3677188 SHA256 b9e1116e5754a2cfff952908145eea6f27454cd8a2260422a54be59e43d2d5e5 SHA512 f8ca441eb7f2264d6c3b6968bcbfc01dcc495340d7b34432a9430065ec7fb4e8f5ce68cde77de42d61577fe3f46014d9ce041ca513e17da8afab2c0888352751 WHIRLPOOL f5c774872c7d9b4f09dd13a04cd0d21a706195eecec103ab883029013228d473f8b82975cc61afcd93001be19ab3350e22288523bc7cac3c043dd2e3e13e0d4f
diff --git a/net-misc/fatrat/fatrat-1.2.0_beta2.ebuild b/net-misc/fatrat/fatrat-1.2.0_beta2.ebuild
new file mode 100644
index 00000000000..4fabdb96661
--- /dev/null
+++ b/net-misc/fatrat/fatrat-1.2.0_beta2.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-utils
+
+DESCRIPTION="Qt4-based download/upload manager"
+HOMEPAGE="http://fatrat.dolezel.info/"
+SRC_URI="http://www.dolezel.info/download/data/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="bittorrent +curl doc xmpp nls webinterface"
+
+RDEPEND="dev-qt/qtdbus:4
+ dev-qt/qtgui:4
+ dev-qt/qtsvg:4
+ bittorrent? ( >=net-libs/rb_libtorrent-0.14.5
+ >=dev-cpp/asio-1.1.0
+ dev-qt/qtwebkit:4 )
+ curl? ( >=net-misc/curl-7.18.2 )
+ doc? ( dev-qt/qthelp:4 )
+ xmpp? ( net-libs/gloox )
+ webinterface? ( dev-qt/qtscript:4 )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+PATCHES=(
+ "${FILESDIR}/${P}-build.patch"
+ "${FILESDIR}/${P}-libcrypto_linking.patch"
+)
+
+src_configure() {
+ local mycmakeargs="
+ $(cmake-utils_use_with bittorrent) \
+ $(cmake-utils_use_with curl) \
+ $(cmake-utils_use_with doc DOCUMENTATION) \
+ $(cmake-utils_use_with xmpp JABBER) \
+ $(cmake-utils_use_with nls) \
+ $(cmake-utils_use_with webinterface)"
+ cmake-utils_src_configure
+}
+
+src_install() {
+ use bittorrent && echo "MimeType=application/x-bittorrent;" >> "${S}"/data/${PN}.desktop
+ cmake-utils_src_install
+}
+
+pkg_postinst() {
+ # this is a completely optional and NOT automagic dep
+ if ! has_version dev-libs/geoip; then
+ elog "If you want the GeoIP support, then emerge dev-libs/geoip."
+ fi
+}
diff --git a/net-misc/fatrat/files/fatrat-1.2.0_beta2-build.patch b/net-misc/fatrat/files/fatrat-1.2.0_beta2-build.patch
new file mode 100644
index 00000000000..f1725bfb720
--- /dev/null
+++ b/net-misc/fatrat/files/fatrat-1.2.0_beta2-build.patch
@@ -0,0 +1,29 @@
+--- fatrat-1.2.0_beta2/CMakeLists.txt
++++ fatrat-1.2.0_beta2/CMakeLists.txt
+@@ -121,16 +121,12 @@
+ endif(curl_FOUND)
+ endif(WITH_CURL)
+
+-ADD_DEFINITIONS(-Wl,--stack,524 288)
+ if(CMAKE_BUILD_TYPE MATCHES Debug)
++ ADD_DEFINITIONS(-Wl,--stack,524 288)
+ ADD_DEFINITIONS(-ggdb)
+ ADD_DEFINITIONS(-DDEBUG_BUILD)
+ ADD_DEFINITIONS(-DNDEBUG)
+ ADD_DEFINITIONS(-Wall)
+-else(CMAKE_BUILD_TYPE MATCHES Debug)
+- ADD_DEFINITIONS(-ggdb)
+- ADD_DEFINITIONS(-DNDEBUG)
+- ADD_DEFINITIONS(-Wall)
+ endif(CMAKE_BUILD_TYPE MATCHES Debug)
+
+ CHECK_INCLUDE_FILES(sys/epoll.h HAVE_SYS_EPOLL_H)
+@@ -577,7 +573,7 @@
+
+ set(fatrat_DEV_HEADERS
+ ${CMAKE_CURRENT_SOURCE_DIR}/src/fatrat.h
+- ${CMAKE_CURRENT_SOURCE_DIR}/config.h
++ ${CMAKE_CURRENT_BINARY_DIR}/config.h
+ ${CMAKE_CURRENT_SOURCE_DIR}/src/DelayedIcon.h
+ ${CMAKE_CURRENT_SOURCE_DIR}/src/AppTools.h
+ ${CMAKE_CURRENT_SOURCE_DIR}/src/Transfer.h
diff --git a/net-misc/fatrat/files/fatrat-1.2.0_beta2-libcrypto_linking.patch b/net-misc/fatrat/files/fatrat-1.2.0_beta2-libcrypto_linking.patch
new file mode 100644
index 00000000000..07e1193d455
--- /dev/null
+++ b/net-misc/fatrat/files/fatrat-1.2.0_beta2-libcrypto_linking.patch
@@ -0,0 +1,13 @@
+http://git.dolezel.info/?p=fatrat.git;a=commitdiff_plain;h=c799fb1ee91c1affb05aabd580e3c0d59b2223d2
+
+--- fatrat-1.2.0_beta2/CMakeLists.txt
++++ fatrat-1.2.0_beta2/CMakeLists.txt
+@@ -572,7 +572,7 @@
+ # This used to be a workaround until it started causing the exact opposite... oh dear!
+ #STRING(REPLACE "-mt" "" pion-net_LIBRARIES "${pion-net_LIBRARIES}")
+ #message(STATUS ${pion-net_LIBRARIES})
+-target_link_libraries(fatrat -ldl -lpthread ${QT_LIBRARIES} ${libtorrent_LDFLAGS} ${gloox_LDFLAGS} ${curl_LDFLAGS} ${Boost_LIBRARIES} ${pion-net_LIBRARIES} ${QT_ADDITIONAL_LIBS} ${XATTR_LIBRARIES} -export-dynamic)
++target_link_libraries(fatrat -ldl -lpthread ${QT_LIBRARIES} ${libtorrent_LDFLAGS} ${gloox_LDFLAGS} ${curl_LDFLAGS} ${Boost_LIBRARIES} ${pion-net_LIBRARIES} ${QT_ADDITIONAL_LIBS} ${XATTR_LIBRARIES} crypto -export-dynamic)
+ target_link_libraries(fatrat-conf ${QT_LIBRARIES})
+
+ set(fatrat_DEV_HEADERS
diff --git a/net-misc/fatrat/metadata.xml b/net-misc/fatrat/metadata.xml
new file mode 100644
index 00000000000..6bf0b584a75
--- /dev/null
+++ b/net-misc/fatrat/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>polynomial-c@gentoo.org</email>
+ <name>Lars Wendler</name>
+ </maintainer>
+ <longdescription lang="en">
+ FatRat is an open source download manager for Linux.
+ </longdescription>
+ <use>
+ <flag name='bittorrent'>Use the bittorrent protocol via net-libs/rb_libtorrent.</flag>
+ <flag name='webinterface'>Enable builtin webinterface.</flag>
+ </use>
+</pkgmetadata>