summaryrefslogtreecommitdiff
path: root/net-misc/goog-sitemapgen
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-misc/goog-sitemapgen
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-misc/goog-sitemapgen')
-rw-r--r--net-misc/goog-sitemapgen/Manifest1
-rw-r--r--net-misc/goog-sitemapgen/files/goog-sitemapgen-1.5.patch8
-rw-r--r--net-misc/goog-sitemapgen/goog-sitemapgen-1.5.ebuild34
-rw-r--r--net-misc/goog-sitemapgen/metadata.xml21
4 files changed, 64 insertions, 0 deletions
diff --git a/net-misc/goog-sitemapgen/Manifest b/net-misc/goog-sitemapgen/Manifest
new file mode 100644
index 00000000000..185b210f0c2
--- /dev/null
+++ b/net-misc/goog-sitemapgen/Manifest
@@ -0,0 +1 @@
+DIST sitemap_gen_1.5.tar.gz 22742 SHA256 d66a5df1450ae70a2ee29a52325c663019d8022cf2813d2592860ec635b0cf73 SHA512 47d0fab242611e5a94ff097d99dce4392831837d1c5f4c0afde51b256df80060799263cad7f30695579b18e0917087b2b6a4a19136c184521c338353cea96596 WHIRLPOOL 381af46dcdf9f24b1ec1567d1105693d2a7671bb96a6f55fcd01046caea272f258cf26f14c4501c9a5c55ae0f07a881b58256c998578a3477f4ccfca6d2d7bde
diff --git a/net-misc/goog-sitemapgen/files/goog-sitemapgen-1.5.patch b/net-misc/goog-sitemapgen/files/goog-sitemapgen-1.5.patch
new file mode 100644
index 00000000000..4f4d8d1074f
--- /dev/null
+++ b/net-misc/goog-sitemapgen/files/goog-sitemapgen-1.5.patch
@@ -0,0 +1,8 @@
+--- setup.py~ 2007-07-19 05:51:20.000000000 +0200
++++ setup.py 2012-03-20 11:47:32.218963792 +0100
+@@ -9,4 +9,5 @@
+ author='Google Inc.',
+ author_email='opensource@google.com',
+ url='http://code.google.com/p/sitemap-generators/',
++ scripts=['sitemap_gen'],
+ )
diff --git a/net-misc/goog-sitemapgen/goog-sitemapgen-1.5.ebuild b/net-misc/goog-sitemapgen/goog-sitemapgen-1.5.ebuild
new file mode 100644
index 00000000000..6f6029919eb
--- /dev/null
+++ b/net-misc/goog-sitemapgen/goog-sitemapgen-1.5.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+PYTHON_DEPEND="2"
+
+inherit eutils python distutils
+
+MY_P="sitemap_gen_${PV}"
+
+DESCRIPTION="A python script which will generate an XML sitemap for your web site"
+HOMEPAGE="http://sitemap-generators.googlecode.com/"
+SRC_URI="http://sitemap-generators.googlecode.com/files/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DOCS="AUTHORS ChangeLog example_* README"
+
+S=${WORKDIR}
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ distutils_src_prepare
+ epatch "${FILESDIR}"/${P}.patch
+ mv sitemap_gen.py sitemap_gen || die
+}
diff --git a/net-misc/goog-sitemapgen/metadata.xml b/net-misc/goog-sitemapgen/metadata.xml
new file mode 100644
index 00000000000..0e811a41ed1
--- /dev/null
+++ b/net-misc/goog-sitemapgen/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <longdescription>Sitemap Gen is a python script which will generate an xml Sitemap for
+ your web site.
+ The sitemap_gen.py script analyzes your web server and generates one or
+ more Sitemap files. These files are XML listings of content you make
+ available on your web server. The files can be directly submitted to
+ search engines as hints for the search engine web crawlers as they
+ index your web site. This can result in better coverage of your web
+ content in search engine indices, and less of your bandwidth spent
+ doing it.
+ The sitemap_gen.py script is written in Python 2.2 and released to the
+ open source community for continuous improvements.</longdescription>
+ <upstream>
+ <remote-id type="google-code">sitemap-generators</remote-id>
+ </upstream>
+</pkgmetadata>