summaryrefslogtreecommitdiff
path: root/net-misc/gwget
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-misc/gwget
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-misc/gwget')
-rw-r--r--net-misc/gwget/Manifest1
-rw-r--r--net-misc/gwget/files/gwget-1.0.4-glib-single-include.patch13
-rw-r--r--net-misc/gwget/files/gwget-1.0.4-libnotify-0.7.patch29
-rw-r--r--net-misc/gwget/gwget-1.0.4.ebuild55
-rw-r--r--net-misc/gwget/metadata.xml14
5 files changed, 112 insertions, 0 deletions
diff --git a/net-misc/gwget/Manifest b/net-misc/gwget/Manifest
new file mode 100644
index 00000000000..8906e60bc1d
--- /dev/null
+++ b/net-misc/gwget/Manifest
@@ -0,0 +1 @@
+DIST gwget-1.0.4.tar.bz2 444843 SHA256 a65b2b2b3befb6cf34a697a13111b35498a6d63f9a9b048a22b8654f35ef643f SHA512 fab9d5eb4e6fd9d061a51848d7f4df9a44925ef8c74386753a7250c4d92b0c95419a8355acf83611c83838e87d906613659e146132a086ada0bdb69cc2ac13cd WHIRLPOOL 1179c07d3330611573c9cfe61d0380289a4f71a7d1b6bafc02e111cc8964acf4c25c6fa5b0801fca4c4fc7e5b94428ca13745eba9bf9e8836da6b1324acf6fdd
diff --git a/net-misc/gwget/files/gwget-1.0.4-glib-single-include.patch b/net-misc/gwget/files/gwget-1.0.4-glib-single-include.patch
new file mode 100644
index 00000000000..a5cf4ee995b
--- /dev/null
+++ b/net-misc/gwget/files/gwget-1.0.4-glib-single-include.patch
@@ -0,0 +1,13 @@
+Index: gwget-1.0.4/src/gwget-application.h
+===================================================================
+--- gwget-1.0.4.orig/src/gwget-application.h
++++ gwget-1.0.4/src/gwget-application.h
+@@ -18,7 +18,7 @@
+ #ifndef GWGET_APPLICATION_H
+ #define GWGET_APPLICATION_H
+
+-#include <glib/gerror.h>
++#include <glib.h>
+ #include <glib-object.h>
+
+ G_BEGIN_DECLS
diff --git a/net-misc/gwget/files/gwget-1.0.4-libnotify-0.7.patch b/net-misc/gwget/files/gwget-1.0.4-libnotify-0.7.patch
new file mode 100644
index 00000000000..116cf60b992
--- /dev/null
+++ b/net-misc/gwget/files/gwget-1.0.4-libnotify-0.7.patch
@@ -0,0 +1,29 @@
+--- src/systray.c
++++ src/systray.c
+@@ -6,6 +6,12 @@
+ #include "systray.h"
+ #include "main_window_cb.h"
+
++#ifdef HAVE_NOTIFY
++#ifndef NOTIFY_CHECK_VERSION
++#define NOTIFY_CHECK_VERSION(x,y,z) 0
++#endif
++#endif
++
+ static GdkPixbuf *systray_load_icon (const gchar *filename);
+ static GdkPixbuf *systray_pixbuf_new_from_file(const gchar *filename);
+ static void systray_clicked(GtkStatusIcon *status_icon,guint button,guint activate_time,gpointer user_data);
+@@ -224,7 +230,12 @@
+ if (!notify_is_initted ())
+ if (!notify_init ("gwget"))
+ return;
+- NotifyNotification *notification = notify_notification_new(primary,secondary,icon_name,NULL);
++ NotifyNotification *notification = notify_notification_new(primary,secondary,icon_name
++#if NOTIFY_CHECK_VERSION (0, 7, 0)
++ );
++#else
++ ,NULL);
++#endif
+ notify_notification_show(notification,NULL);
+ #endif
+
diff --git a/net-misc/gwget/gwget-1.0.4.ebuild b/net-misc/gwget/gwget-1.0.4.ebuild
new file mode 100644
index 00000000000..ea0aefd8ebe
--- /dev/null
+++ b/net-misc/gwget/gwget-1.0.4.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+GNOME_TARBALL_SUFFIX="bz2"
+
+inherit eutils gnome2
+
+DESCRIPTION="GTK2 WGet Frontend"
+HOMEPAGE="http://gnome.org/projects/gwget/"
+
+KEYWORDS="amd64 ppc x86"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="epiphany libnotify"
+
+# FIXME: dbus should be optional
+# needs patching for linguas/intltool
+RDEPEND="net-misc/wget
+ >=x11-libs/gtk+-2.6:2
+ >=dev-libs/glib-2.16.0:2
+ >=gnome-base/gconf-2:2
+ >=gnome-base/libgnomeui-2
+ >=dev-libs/dbus-glib-0.70
+ epiphany? ( >=www-client/epiphany-1.4 )
+ libnotify? ( >=x11-libs/libnotify-0.2.2 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ >=dev-util/intltool-0.35.0
+ >=sys-devel/gettext-0.10.4"
+
+pkg_setup() {
+ DOCS="AUTHORS ChangeLog NEWS README THANKS TODO"
+ G2CONF="${G2CONF}
+ $(use_enable epiphany epiphany-extension)
+ $(use_enable libnotify)
+ --disable-static
+ --disable-schemas-install"
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-libnotify-0.7.patch
+ epatch "${FILESDIR}"/${P}-glib-single-include.patch
+ gnome2_src_prepare
+}
+
+src_install() {
+ gnome2_src_install
+
+ # remove /var/lib, which is created without any reason
+ rm -rf "${D}"/var || die "rm failed"
+}
diff --git a/net-misc/gwget/metadata.xml b/net-misc/gwget/metadata.xml
new file mode 100644
index 00000000000..9359a065c80
--- /dev/null
+++ b/net-misc/gwget/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>gnome</herd>
+ <longdescription>Gwget2 is a gtk2 front-end for the wget program. Wget is commonly used for retrieving files from the internet, and with an easy to use gtk2 interface, gwget2 brings the utility of wget to the GNOME desktop. Gwget2 supports drag and drop from most gtk2 compatible browsers, as well as the ability to pause and continue downloads over sessions.</longdescription>
+ <longdescription lang="ja">
+Gwget2 は wget プログラムの GTK2 フロントエンドです。wget とはインターネットからファイルを回収するのに一般的に
+使われているもので、gwget2 はGNOME デスクトップへ wget ユーティリティを統合し、GTK2 インターフェイスで使い易くします。
+Gwget2 は GTK2 互換のブラウザからのドラッグ・アンド・ドロップ及びセッションを越えた停止と再開をサポートします。
+</longdescription>
+ <use>
+ <flag name="epiphany">Build epiphany extensions</flag>
+ </use>
+</pkgmetadata>