summaryrefslogtreecommitdiff
path: root/net-misc/ices
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-misc/ices
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-misc/ices')
-rw-r--r--net-misc/ices/Manifest2
-rw-r--r--net-misc/ices/files/ices.initd17
-rw-r--r--net-misc/ices/files/ices.initd-r114
-rw-r--r--net-misc/ices/ices-2.0.1-r1.ebuild44
-rw-r--r--net-misc/ices/ices-2.0.2.ebuild43
-rw-r--r--net-misc/ices/metadata.xml5
6 files changed, 125 insertions, 0 deletions
diff --git a/net-misc/ices/Manifest b/net-misc/ices/Manifest
new file mode 100644
index 00000000000..3593aff1815
--- /dev/null
+++ b/net-misc/ices/Manifest
@@ -0,0 +1,2 @@
+DIST ices-2.0.1.tar.bz2 273805 SHA256 04ec784b5ca6f5a2951631252d61e01c6d16c6fcf17cbe32d702dbe761fc238d
+DIST ices-2.0.2.tar.bz2 293818 SHA256 96458df835033c39236ad3bb099286c033241f8ea7c138e7ccf714e7ade75900 SHA512 ff257b478a7237886ba59bf7d1a494ebd4c7c12fd74e8e10c00ea65710249ead1b5b1ae8d9540fab05f2e4486949c6e350f3da59a1d1bf261397ca257806b2c7 WHIRLPOOL a0523f412aae8cb967de4614fb549e7dfc31aef3980639bce13cfd5d8bec118a2ffa7962d3d59b3fc01ddd105c98554e2b1528ae93b5b41fc3244721abecdd0d
diff --git a/net-misc/ices/files/ices.initd b/net-misc/ices/files/ices.initd
new file mode 100644
index 00000000000..595bfb30001
--- /dev/null
+++ b/net-misc/ices/files/ices.initd
@@ -0,0 +1,17 @@
+#!/sbin/runscript
+
+depend() {
+ need net
+}
+
+start() {
+ ebegin "Starting IceS 2"
+ start-stop-daemon --background --start --pidfile /var/run/ices.pid --make-pidfile --exec /usr/bin/ices /etc/ices2/ices.xml
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping IceS 2"
+ start-stop-daemon --stop --pidfile /var/run/ices.pid --name ices
+ eend $?
+}
diff --git a/net-misc/ices/files/ices.initd-r1 b/net-misc/ices/files/ices.initd-r1
new file mode 100644
index 00000000000..0e86303562a
--- /dev/null
+++ b/net-misc/ices/files/ices.initd-r1
@@ -0,0 +1,14 @@
+#!/sbin/runscript
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+description="Icecast OGG streaming client"
+pidfile="/var/run/ices.pid"
+command="/usr/bin/ices"
+command_args="/etc/ices2/ices.xml"
+command_background="true"
+
+depend() {
+ need net
+}
diff --git a/net-misc/ices/ices-2.0.1-r1.ebuild b/net-misc/ices/ices-2.0.1-r1.ebuild
new file mode 100644
index 00000000000..eae1baa4733
--- /dev/null
+++ b/net-misc/ices/ices-2.0.1-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils user
+
+DESCRIPTION="Icecast OGG streaming client, supports on the fly re-encoding"
+HOMEPAGE="http://www.icecast.org/ices.php"
+SRC_URI="http://downloads.xiph.org/releases/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm ppc64 sparc x86"
+IUSE=""
+
+RDEPEND="dev-libs/libxml2
+ >=media-libs/libshout-2
+ >=media-libs/libvorbis-1"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+pkg_setup() {
+ enewgroup ices
+ enewuser ices -1 -1 -1 ices
+}
+
+src_compile() {
+ econf --sysconfdir=/etc/ices2
+ emake || die "emake failed."
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed."
+ dodoc AUTHORS README TODO
+ insinto /etc/ices2
+ doins conf/*.xml
+ dohtml doc/*.{html,css}
+ newman debian/ices2.1 ices.1
+ newinitd "${FILESDIR}"/ices.initd ices
+ keepdir /var/log/ices
+ fperms 660 /var/log/ices
+ fowners ices:ices /var/log/ices
+ rm -rf "${D}"/usr/share/ices
+}
diff --git a/net-misc/ices/ices-2.0.2.ebuild b/net-misc/ices/ices-2.0.2.ebuild
new file mode 100644
index 00000000000..71e80229255
--- /dev/null
+++ b/net-misc/ices/ices-2.0.2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils user
+
+DESCRIPTION="Icecast OGG streaming client, supports on the fly re-encoding"
+HOMEPAGE="http://www.icecast.org/ices.php"
+SRC_URI="http://downloads.xiph.org/releases/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND="dev-libs/libxml2
+ >=media-libs/libshout-2
+ >=media-libs/libvorbis-1"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+pkg_setup() {
+ enewgroup ices
+ enewuser ices -1 -1 -1 ices
+}
+
+src_configure() {
+ econf --sysconfdir=/etc/ices2
+}
+
+src_install() {
+ default
+ insinto /etc/ices2
+ doins conf/*.xml
+ dohtml doc/*.{html,css}
+ newinitd "${FILESDIR}"/ices.initd-r1 ices
+ keepdir /var/log/ices
+ fperms 660 /var/log/ices
+ fowners ices:ices /var/log/ices
+ rm -rf "${D}"/usr/share/ices
+}
diff --git a/net-misc/ices/metadata.xml b/net-misc/ices/metadata.xml
new file mode 100644
index 00000000000..3bf6bcfeb51
--- /dev/null
+++ b/net-misc/ices/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sound</herd>
+</pkgmetadata>