summaryrefslogtreecommitdiff
path: root/net-misc/iodine
diff options
context:
space:
mode:
authorJason A. Donenfeld <zx2c4@gentoo.org>2016-11-25 15:13:52 +0100
committerJason A. Donenfeld <zx2c4@gentoo.org>2016-11-25 15:14:13 +0100
commite2649018143dce25f5e298536118fcea0acadc66 (patch)
tree059b4812bdb922ca97b2e8ec3ac90bbce6499746 /net-misc/iodine
parent8f656e7566bcb377af9a6ef2369155b6c10819c9 (diff)
downloadgentoo-e2649018143dce25f5e298536118fcea0acadc66.tar.gz
gentoo-e2649018143dce25f5e298536118fcea0acadc66.tar.xz
net-misc/iodine: fix 477102 competently
While we're at it, we make sure this builds with new systemd. Package-Manager: portage-2.3.2
Diffstat (limited to 'net-misc/iodine')
-rw-r--r--net-misc/iodine/files/iodine-0.7.0-new-systemd.patch19
-rw-r--r--net-misc/iodine/iodine-0.7.0-r2.ebuild (renamed from net-misc/iodine/iodine-0.7.0-r1.ebuild)3
2 files changed, 2 insertions, 20 deletions
diff --git a/net-misc/iodine/files/iodine-0.7.0-new-systemd.patch b/net-misc/iodine/files/iodine-0.7.0-new-systemd.patch
index 1f54d38073d..e18b64a086f 100644
--- a/net-misc/iodine/files/iodine-0.7.0-new-systemd.patch
+++ b/net-misc/iodine/files/iodine-0.7.0-new-systemd.patch
@@ -1,20 +1,3 @@
-From cc4bc22447d15deacf44bc1d369621a63c934427 Mon Sep 17 00:00:00 2001
-From: "Jason A. Donenfeld" <Jason@zx2c4.com>
-Date: Fri, 25 Jul 2014 02:02:48 +0200
-Subject: [PATCH] osflags: use pkg-config for systemd support
-
-Recent versions of systemd don't ship with libsystemd-daemon.so anymore,
-but instead use libsystemd.so for everything. This is obviously
-problematic for using the same LDFLAGS on old systemd and new systemd.
-So, they also ship compatability pkgconfig files, which use the old
-names but return the new library. So, the most portable way to support
-both old and new systemd is to use pkgconfig. It's not a problem either,
-since systems that use systemd are bound to also have pkgconfig
-installed.
----
- src/osflags | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
diff --git a/src/osflags b/src/osflags
index 9eda8f0..0f8a26c 100755
--- a/src/osflags
@@ -24,7 +7,7 @@ index 9eda8f0..0f8a26c 100755
FLAGS="";
[ -e /usr/include/selinux/selinux.h ] && FLAGS="$FLAGS -lselinux";
- [ -e /usr/include/systemd/sd-daemon.h ] && FLAGS="$FLAGS -lsystemd-daemon";
-+ [ -e /usr/include/systemd/sd-daemon.h ] && FLAGS="$FLAGS $(pkg-config --libs libsystemd-daemon)";
++ [ -e /usr/include/systemd/sd-daemon.h ] && FLAGS="$FLAGS $(pkg-config --libs libsystemd)";
echo $FLAGS;
;;
esac
diff --git a/net-misc/iodine/iodine-0.7.0-r1.ebuild b/net-misc/iodine/iodine-0.7.0-r2.ebuild
index 00beaa1c1b4..cf75d16fdbb 100644
--- a/net-misc/iodine/iodine-0.7.0-r1.ebuild
+++ b/net-misc/iodine/iodine-0.7.0-r2.ebuild
@@ -48,6 +48,5 @@ src_install() {
newinitd "${FILESDIR}"/iodined-1.init iodined
newconfd "${FILESDIR}"/iodined.conf iodined
keepdir /var/empty
- fowners root:nogroup /etc/conf.d/iodined
- fperms 640 /etc/conf.d/iodined
+ fperms 600 /etc/conf.d/iodined
}