summaryrefslogtreecommitdiff
path: root/net-misc/jigdo
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-misc/jigdo
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-misc/jigdo')
-rw-r--r--net-misc/jigdo/Manifest1
-rw-r--r--net-misc/jigdo/files/jigdo-0.7.3-gcc43.patch80
-rw-r--r--net-misc/jigdo/files/jigdo-0.7.3-strip.patch23
-rw-r--r--net-misc/jigdo/jigdo-0.7.3-r2.ebuild39
-rw-r--r--net-misc/jigdo/metadata.xml15
5 files changed, 158 insertions, 0 deletions
diff --git a/net-misc/jigdo/Manifest b/net-misc/jigdo/Manifest
new file mode 100644
index 00000000000..402b2b0f3d6
--- /dev/null
+++ b/net-misc/jigdo/Manifest
@@ -0,0 +1 @@
+DIST jigdo-0.7.3.tar.bz2 644670 SHA256 875c069abad67ce67d032a9479228acdb37c8162236c0e768369505f264827f0 SHA512 e183a2d93126935057244b9eb6bf6dadc1900cb17c36194f69e63a15d70ddfea81ce1167de5abfcdfd7507ac9fe6250a05be9d9d29392c961d44fde796158f7c WHIRLPOOL 25ffc64cc57dd8bd98c3edc7560e6d5bac3e8dd710237d9ccd75f73f40e819259176aa71f3fccb2ac20bc50b8509465340b788b23ab191b000b81a33343d1f19
diff --git a/net-misc/jigdo/files/jigdo-0.7.3-gcc43.patch b/net-misc/jigdo/files/jigdo-0.7.3-gcc43.patch
new file mode 100644
index 00000000000..07356f0233e
--- /dev/null
+++ b/net-misc/jigdo/files/jigdo-0.7.3-gcc43.patch
@@ -0,0 +1,80 @@
+diff -ur jigdo-0.7.3.orig/src/compat.hh jigdo-0.7.3/src/compat.hh
+--- jigdo-0.7.3.orig/src/compat.hh 2005-07-02 10:21:35.000000000 -0700
++++ jigdo-0.7.3/src/compat.hh 2008-03-11 23:01:45.000000000 -0700
+@@ -20,6 +20,7 @@
+
+ #include <string>
+ #include <stdio.h>
++#include <stdlib.h>
+ #include <unistd-jigdo.h>
+ #include <sys/stat.h>
+ #include <sys/types.h>
+diff -ur jigdo-0.7.3.orig/src/gtk/gtk-single-url.cc jigdo-0.7.3/src/gtk/gtk-single-url.cc
+--- jigdo-0.7.3.orig/src/gtk/gtk-single-url.cc 2005-10-15 14:27:39.000000000 -0700
++++ jigdo-0.7.3/src/gtk/gtk-single-url.cc 2008-03-11 23:05:48.000000000 -0700
+@@ -15,6 +15,7 @@
+
+ #include <time.h>
+ #include <errno.h>
++#include <string.h>
+
+ #include <autoptr.hh>
+ #include <gtk-single-url.hh>
+diff -ur jigdo-0.7.3.orig/src/gtk/jigdo.cc jigdo-0.7.3/src/gtk/jigdo.cc
+--- jigdo-0.7.3.orig/src/gtk/jigdo.cc 2005-07-09 15:21:04.000000000 -0700
++++ jigdo-0.7.3/src/gtk/jigdo.cc 2008-03-11 23:06:26.000000000 -0700
+@@ -16,6 +16,8 @@
+ # include <unistd-jigdo.h>
+ #endif
+
++#include <string.h>
++
+ #include <iostream>
+ #include <string>
+ #include <vector>
+diff -ur jigdo-0.7.3.orig/src/recursedir.cc jigdo-0.7.3/src/recursedir.cc
+--- jigdo-0.7.3.orig/src/recursedir.cc 2006-05-14 11:23:31.000000000 -0700
++++ jigdo-0.7.3/src/recursedir.cc 2008-03-11 23:04:21.000000000 -0700
+@@ -32,6 +32,7 @@
+ #include <recursedir.hh>
+
+ #include <iostream>
++#include <string.h>
+ #include <errno.h>
+ #include <sys/stat.h>
+ #include <sys/types.h>
+diff -ur jigdo-0.7.3.orig/src/util/configfile.cc jigdo-0.7.3/src/util/configfile.cc
+--- jigdo-0.7.3.orig/src/util/configfile.cc 2003-09-27 14:31:04.000000000 -0700
++++ jigdo-0.7.3/src/util/configfile.cc 2008-03-11 23:05:00.000000000 -0700
+@@ -19,6 +19,8 @@
+ #include <iostream>
+ #include <fstream>
+
++#include <string.h>
++
+ #include <configfile.hh>
+ #include <string.hh>
+ //______________________________________________________________________
+diff -ur jigdo-0.7.3.orig/src/util/md5sum.hh jigdo-0.7.3/src/util/md5sum.hh
+--- jigdo-0.7.3.orig/src/util/md5sum.hh 2005-04-09 16:09:52.000000000 -0700
++++ jigdo-0.7.3/src/util/md5sum.hh 2008-03-11 23:07:04.000000000 -0700
+@@ -28,6 +28,8 @@
+
+ #include <config.h>
+
++#include <string.h>
++
+ #include <cstdlib>
+ #include <iosfwd>
+ #include <string>
+diff -ur jigdo-0.7.3.orig/src/util/string-utf.cc jigdo-0.7.3/src/util/string-utf.cc
+--- jigdo-0.7.3.orig/src/util/string-utf.cc 2004-09-11 16:26:30.000000000 -0700
++++ jigdo-0.7.3/src/util/string-utf.cc 2008-03-11 23:07:43.000000000 -0700
+@@ -15,6 +15,7 @@
+ #include <glib.h>
+ #include <stdarg.h>
+ #include <stdio.h>
++#include <string.h>
+
+ #include <debug.hh>
+ #include <string-utf.hh>
diff --git a/net-misc/jigdo/files/jigdo-0.7.3-strip.patch b/net-misc/jigdo/files/jigdo-0.7.3-strip.patch
new file mode 100644
index 00000000000..c4be7a95c5a
--- /dev/null
+++ b/net-misc/jigdo/files/jigdo-0.7.3-strip.patch
@@ -0,0 +1,23 @@
+--- jigdo-0.7.3/Makefile.in.orig 2006-05-19 16:55:41.000000000 +0200
++++ jigdo-0.7.3/Makefile.in 2009-09-04 17:37:31.000000000 +0200
+@@ -15,7 +15,7 @@
+
+ PACKAGE = jigdo
+ INSTALL = @INSTALL@
+-INSTALL_EXE = @INSTALL@ -s
++INSTALL_EXE = @INSTALL@
+ INSTALL_DATA = @INSTALL@ -m 644
+ INSTALL_SCRIPT = @INSTALL@ -m 755
+ AWK = @AWK@
+--- jigdo-0.7.3/src/Makefile.in.orig 2005-07-06 17:51:28.000000000 +0200
++++ jigdo-0.7.3/src/Makefile.in 2009-09-04 17:38:58.000000000 +0200
+@@ -161,8 +161,7 @@
+ cd .. && sh config.status; \
+ fi
+ strip:
+- for p in $(programs); do if test -f "$$p"; then \
+- strip -R .comment -R .note "$$p"; fi; done
++ true
+
+ TEST-DEFAULTOBJS = util/log.o util/string-utf.o util/debug.o
+ TEST-LDFLAGS = @LDFLAGS@ $(GLIBLIBS)
diff --git a/net-misc/jigdo/jigdo-0.7.3-r2.ebuild b/net-misc/jigdo/jigdo-0.7.3-r2.ebuild
new file mode 100644
index 00000000000..925daee8d54
--- /dev/null
+++ b/net-misc/jigdo/jigdo-0.7.3-r2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit eutils
+
+DESCRIPTION="Jigsaw Download is a tool designed to ease the distribution of large files, for example DVD images"
+HOMEPAGE="http://atterer.net/jigdo/"
+SRC_URI="http://atterer.net/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="gtk nls berkdb"
+
+RDEPEND="gtk? ( x11-libs/gtk+:2 )
+ berkdb? ( >=sys-libs/db-3.2 )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gcc43.patch \
+ "${FILESDIR}"/${P}-strip.patch
+}
+
+src_configure() {
+ local myconf
+ use berkdb || myconf="${myconf} --without-libdb"
+ econf $(use_enable nls) ${myconf}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ doicon gfx/jigdo-icon.png
+ make_desktop_entry "${PN}" "${PN}" jigdo-icon
+ dodoc changelog README THANKS doc/{Hacking,README-bindist,TechDetails}.txt
+ dohtml doc/*.html
+}
diff --git a/net-misc/jigdo/metadata.xml b/net-misc/jigdo/metadata.xml
new file mode 100644
index 00000000000..72dbea83cc6
--- /dev/null
+++ b/net-misc/jigdo/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+ Jigsaw Download, or jigdo for short, is a tool designed to ease the
+ distribution of very large files over the internet, for example CD or
+ DVD images. Its aim is to make downloading the images as easy for users
+ as a click on a direct download link in a browser, while avoiding all
+ the problems that server administrators have with hosting such large
+ files.
+ </longdescription>
+</pkgmetadata>