summaryrefslogtreecommitdiff
path: root/net-misc/l7-protocols
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-misc/l7-protocols
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-misc/l7-protocols')
-rw-r--r--net-misc/l7-protocols/Manifest1
-rw-r--r--net-misc/l7-protocols/l7-protocols-2009.05.28.ebuild64
-rw-r--r--net-misc/l7-protocols/metadata.xml17
3 files changed, 82 insertions, 0 deletions
diff --git a/net-misc/l7-protocols/Manifest b/net-misc/l7-protocols/Manifest
new file mode 100644
index 00000000000..00d23ac757c
--- /dev/null
+++ b/net-misc/l7-protocols/Manifest
@@ -0,0 +1 @@
+DIST l7-protocols-2009-05-28.tar.gz 142050 SHA256 d6bf98a69268558543bd32fccea287cb3f14b37521d18c790e2b6f8dcfaa5381 SHA512 020730d0170537213080dcefd847439a2306eea759317e4054549d12e344520e9db222ca48f74c184cb17ba5ff244270b688fb7e89ed0dd21a196e02721e4477 WHIRLPOOL d40993652acac332261fba3555cbce1196e3d35cc52e68ac1fc71b6e5623bce31caa059f021823a6e8225e1d6bcf0a2f529921bd25a15403e912e8f11cbb6245
diff --git a/net-misc/l7-protocols/l7-protocols-2009.05.28.ebuild b/net-misc/l7-protocols/l7-protocols-2009.05.28.ebuild
new file mode 100644
index 00000000000..8a199803a20
--- /dev/null
+++ b/net-misc/l7-protocols/l7-protocols-2009.05.28.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils fixheadtails toolchain-funcs
+
+IUSE=""
+
+MY_P=${PN}-${PV//./-}
+
+DESCRIPTION="Protocol definitions of l7-filter kernel modules"
+HOMEPAGE="http://l7-filter.sourceforge.net/protocols"
+
+SRC_URI="mirror://sourceforge/l7-filter/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm ~hppa ~ia64 ppc ppc64 ~s390 ~sh sparc x86"
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+
+ cd "${S}"
+ sed -e "s|gcc.*\-o|$(tc-getCC) ${CFLAGS} ${LDFLAGS} -o|g" \
+ -e "s|g++.*\-o|$(tc-getCXX) ${CXXFLAGS} ${LDFLAGS} -o|g" \
+ -i testing/Makefile
+ ht_fix_file testing/*.sh
+}
+
+src_compile() {
+ emake -C testing || die
+}
+
+# NOTE Testing mechanism is currently broken:
+# stack smashing attack in function main()
+
+# Is also extraordinarly inefficent getting random data.
+#
+#src_test() {
+# cd testing
+# find ${S} -name \*.pat -print -exec ./test_match.sh {} \; \
+# -exec ./timeit.sh {} \; || die "failed tests"
+# einfo "patterns past testing"
+#}
+
+src_install() {
+ dodir /usr/share/${PN}
+ pushd testing > /dev/null
+ cp -pPR randprintable randchars test_speed-{kernel,userspace} README \
+ match_kernel *.sh data "${D}"/usr/share/${PN}
+ popd > /dev/null
+ mv example_traffic "${D}"/usr/share/${PN}
+
+ dodoc README CHANGELOG HOWTO WANTED || die
+ for dir in extra file_types malware ; do
+ newdoc ${dir}/README README.${dir}
+ done
+ rm -rf README CHANGELOG HOWTO LICENSE Makefile WANTED */README testing
+
+ dodir /etc/l7-protocols
+ cp -R * "${D}"/etc/l7-protocols
+ chown -R root:0 "${D}"
+}
diff --git a/net-misc/l7-protocols/metadata.xml b/net-misc/l7-protocols/metadata.xml
new file mode 100644
index 00000000000..125e82bf548
--- /dev/null
+++ b/net-misc/l7-protocols/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>bircoph@gentoo.org</email>
+ <name>Andrew Savchenko</name>
+ </maintainer>
+ <longdescription>
+ These are patterns (protocol definitions) for the Linux layer 7 packet
+ classifier (l7-filter). To use them, you need the kernel and iptables patches
+ (or l7-filter userspace version) available trough ebuild tree as
+ net-misc/l7-filter and net-firewall/iptables built with l7filter USE flag.
+</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">l7-filter</remote-id>
+ </upstream>
+</pkgmetadata>