summaryrefslogtreecommitdiff
path: root/net-misc/libteam
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-misc/libteam
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-misc/libteam')
-rw-r--r--net-misc/libteam/Manifest3
-rw-r--r--net-misc/libteam/libteam-1.0.ebuild58
-rw-r--r--net-misc/libteam/libteam-1.11.ebuild61
-rw-r--r--net-misc/libteam/libteam-1.14.ebuild55
-rw-r--r--net-misc/libteam/metadata.xml18
5 files changed, 195 insertions, 0 deletions
diff --git a/net-misc/libteam/Manifest b/net-misc/libteam/Manifest
new file mode 100644
index 00000000000..131f8227d79
--- /dev/null
+++ b/net-misc/libteam/Manifest
@@ -0,0 +1,3 @@
+DIST libteam-1.0.tar.gz 99558 SHA256 5fb6dcf296f07be20e6ff61b4f18f4e98346ed158032f8d733bedd6f39b48f8f SHA512 69206709ebb9ad576b844402ad5c2327bf85a0d48d386a51decafd22f0fd638fa0d6d09e822afb77d511006d20749c3820b84c17e4c6874ce1fdc1499484a313 WHIRLPOOL f68274b50771aa67ac30abf38f9f2af8401eb84cacaf0eeb3468dbb845b3336af78d0459eec087d8081551c13640fa2097e1dfc5d4741c33a2bb7c29682bd7c6
+DIST libteam-1.11.tar.gz 497560 SHA256 b89e81258f8a8f4abd718ec1c91f85cb66d4d29e4d50095a3d2a4ffd8ce4bf7a SHA512 0e7da9ffbe2e0fe15d1caa67bdb2b8acb69f12884656005d4a0bd91beb82c71eb380af46263d92c543b42fc0087d40a4b607847ee895482109a6f34847eafcbf WHIRLPOOL d1eed93acdb6212e0615170f927c77d359f8963262700aa76104859dd102fa4407fbae6f5705b104f2e59905cfa24a3551c9488cf214e1c9456a58004cfba187
+DIST libteam-1.14.tar.gz 524122 SHA256 294cdabd85cddfeac304ecbd4f331ef3f9afbf03f8b8ef7bb3a9c5827ab22d97 SHA512 11cad4baf42b27cf9bce106d202d5e6dd2685bac45784233868f0757c12d9b6f672db6d65e4cd1138de4f22c89665838db578b1ce30c8da283f3e258a56b65e8 WHIRLPOOL 9471099dde384948274c925bfbd38530be71b4676a15283bc645b47aab7d7199ba0c494bd5ccaece8dc4f124044b4f3cd4efcae3b00a809b4d9f6c6978525968
diff --git a/net-misc/libteam/libteam-1.0.ebuild b/net-misc/libteam/libteam-1.0.ebuild
new file mode 100644
index 00000000000..b3bc121d26c
--- /dev/null
+++ b/net-misc/libteam/libteam-1.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=1
+inherit autotools-utils linux-info
+
+DESCRIPTION="Library and tools set for controlling team network device"
+HOMEPAGE="https://fedorahosted.org/libteam/"
+SRC_URI="https://github.com/jpirko/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="debug examples static-libs +syslog"
+
+DEPEND="dev-libs/jansson
+ dev-libs/libdaemon
+ >=dev-libs/libnl-3.2.19[utils]
+ sys-apps/dbus
+ "
+RDEPEND="${DEPEND}
+ syslog? ( virtual/logger )"
+
+CONFIG_CHECK="~NET_TEAM ~NET_TEAM_MODE_ROUNDROBIN ~NET_TEAM_MODE_ACTIVEBACKUP"
+ERROR_NET_TEAM="NET_TEAM is not enabled in this kernel!
+Only >=3.3.0 kernel version support in team mode"
+
+DOCS=( HOWTO.BASICS README )
+
+src_prepare() {
+ # avoid using -Werror in CFLAGS
+ sed -i -e '/^CFLAGS/s/-Werror//' configure.ac || die 'sed on CFLAGS failed'
+
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable debug)
+ $(use_enable syslog logging)
+ )
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install
+
+ insinto /etc/dbus-1/system.d
+ doins teamd/dbus/teamd.conf
+
+ if use examples; then
+ docinto examples
+ dodoc teamd/example_configs/*
+ fi
+}
diff --git a/net-misc/libteam/libteam-1.11.ebuild b/net-misc/libteam/libteam-1.11.ebuild
new file mode 100644
index 00000000000..09ae4905f74
--- /dev/null
+++ b/net-misc/libteam/libteam-1.11.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=1
+AUTOTOOLS_IN_SOURCE_BUILD=1
+inherit autotools-utils linux-info
+
+DESCRIPTION="Library and tools set for controlling team network device"
+HOMEPAGE="http://libteam.org"
+SRC_URI="http://libteam.org/files/${P}.tar.gz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 x86"
+IUSE="dbus debug examples static-libs +syslog"
+
+DEPEND=">=dev-libs/jansson-2.4
+ dev-libs/libdaemon
+ >=dev-libs/libnl-3.2.19[utils]
+ dbus? ( sys-apps/dbus )
+ "
+RDEPEND="${DEPEND}
+ syslog? ( virtual/logger )"
+
+CONFIG_CHECK="~NET_TEAM ~NET_TEAM_MODE_ROUNDROBIN ~NET_TEAM_MODE_ACTIVEBACKUP"
+ERROR_NET_TEAM="NET_TEAM is not enabled in this kernel!
+Only >=3.3.0 kernel version support in team mode"
+
+DOCS=( README )
+
+src_prepare() {
+ # avoid using -Werror in CFLAGS
+ sed -i -e '/^CFLAGS/s/-Werror//' configure.ac || die 'sed on CFLAGS failed'
+
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable debug)
+ $(use_enable syslog logging)
+ $(use_enable dbus)
+ --disable-zmq
+ )
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install
+
+ insinto /etc/dbus-1/system.d
+ doins teamd/dbus/teamd.conf
+
+ if use examples; then
+ docinto examples
+ dodoc teamd/example_configs/*
+ fi
+}
diff --git a/net-misc/libteam/libteam-1.14.ebuild b/net-misc/libteam/libteam-1.14.ebuild
new file mode 100644
index 00000000000..e83dab4a164
--- /dev/null
+++ b/net-misc/libteam/libteam-1.14.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+AUTOTOOLS_IN_SOURCE_BUILD=1
+inherit autotools-utils linux-info
+
+DESCRIPTION="Library and tools set for controlling team network device"
+HOMEPAGE="http://libteam.org"
+SRC_URI="http://libteam.org/files/${P}.tar.gz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="dbus debug examples static-libs +syslog zmq"
+
+DEPEND=">=dev-libs/jansson-2.4
+ dev-libs/libdaemon
+ >=dev-libs/libnl-3.2.19[utils]
+ dbus? ( sys-apps/dbus )
+ zmq? ( >=net-libs/zeromq-3.2.0 )
+ "
+
+RDEPEND="${DEPEND}
+ syslog? ( virtual/logger )"
+
+CONFIG_CHECK="~NET_TEAM ~NET_TEAM_MODE_ROUNDROBIN ~NET_TEAM_MODE_ACTIVEBACKUP ~NET_TEAM_MODE_BROADCAST ~NET_TEAM_MODE_RANDOM ~NET_TEAM_MODE_LOADBALANCE"
+ERROR_NET_TEAM="NET_TEAM is not enabled in this kernel!
+Only >=3.3.0 kernel version support in team mode"
+
+DOCS=( README )
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable debug)
+ $(use_enable syslog logging)
+ $(use_enable dbus)
+ $(use_enable zmq)
+ )
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install
+
+ insinto /etc/dbus-1/system.d
+ doins teamd/dbus/teamd.conf
+
+ if use examples; then
+ docinto examples
+ dodoc teamd/example_configs/*
+ fi
+}
diff --git a/net-misc/libteam/metadata.xml b/net-misc/libteam/metadata.xml
new file mode 100644
index 00000000000..eb53daa6585
--- /dev/null
+++ b/net-misc/libteam/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>proxy-maintainers</herd>
+ <maintainer>
+ <email>andreis.vinogradovs@gmail.com</email>
+ <name>Andreis Vinogradovs</name>
+ <description>Maintainer. Assign bugs to him</description>
+ </maintainer>
+ <maintainer>
+ <email>pinkbyte@gentoo.org</email>
+ <name>Sergey Popov</name>
+ <description>Proxy maintainer. CC him on bugs</description>
+ </maintainer>
+ <use>
+ <flag name='zmq'>Build witch <pkg>net-libs/zeromq</pkg> support</flag>
+ </use>
+</pkgmetadata>